i-Vu CCN Pro 4.2
Installation Guide
# Table of Contents

What Is i-Vu CCN Pro 4.2? .................................................................................................................. 1
   A typical i-Vu CCN Pro system ................................................................................................. 1
   i-Vu CCN Pro design tools ................................................................................................. 1

Before starting your i-Vu CCN Pro.................................................................................................. 3
   Step 1: Install software and get documentation ready ................................................................. 3
   Step 2: Install i-Vu CCN device managers ................................................................................. 4
   Step 3: Use Network Service Tool V to ensure hardware is communicating on the CCN network 4
   Step 4: System Preparation ....................................................................................................... 5
   Step 5: Set up a computer and browser to view i-Vu CCN Pro .................................................. 5

Use SiteBuilder to begin setting up your system ............................................................................ 7
   Create a new SiteBuilder database .......................................................................................... 7

Operating i-Vu CCN Pro .................................................................................................................... 10
   Running i-Vu CCN Pro Server .................................................................................................. 10
      To run a system ......................................................................................................................... 10
      To run a system without connecting to the controllers ......................................................... 10
      To switch to a different system ............................................................................................. 10
      To send a message to logged in operators .......................................................................... 11
      To log off an operator ......................................................................................................... 11
      To shut down a system ....................................................................................................... 11

Getting to know the i-Vu CCN Pro workspace .............................................................................. 12
   Navigating the system ............................................................................................................. 12
   To show or hide the navigation pane ..................................................................................... 12
   Zooming and resizing contents of the action pane ............................................................... 13
   Using right-click menus ....................................................................................................... 13
   To print the action pane ....................................................................................................... 14
   Colors and status in i-Vu CCN Pro ....................................................................................... 14
   Colors and setpoints ......................................................................................................... 14

Using System Setup ...................................................................................................................... 15
   Prepare to scan ...................................................................................................................... 15
      Customize the navigation tree .......................................................................................... 16
      Scan for devices ............................................................................................................... 17
      Update library and change addressing ........................................................................... 17
      Re-scan or download equipment ...................................................................................... 17

Working with Universal and Comfort Controllers (CCN) .............................................................. 18
   Create custom equipment files for UC/CC's that link only to CNN points ............................ 18
   Create custom equipment files for UC/CC's that link to TPI points ........................................ 19
   Use Global Modify to view and change the same property in multiple microblocks ............ 21
   Create stand-alone applications ......................................................................................... 22
   Assign and download a custom UC/CC equipment file ..................................................... 22
   Map to Point procedures for the Universal and Comfort Controller ................................... 23
   Setpoint mapping .............................................................................................................. 24

Working with Terminal System Managers .................................................................................. 24
   Create custom equipment files in ApplicationBuilder for Terminal System Managers (TSM) ........................................................................................................... 24
   Assign and download a TSM equipment file in i-Vu CCN Pro .......................................... 25
   Configure the path to the source of the point for TSM Groups and Zones ......................... 26

Working with equipment ................................................................................................................. 27
   Graphics pages .................................................................................................................... 28
      To attach a graphic in i-Vu CCN Pro .............................................................................. 28
      To edit a graphic from i-Vu CCN Pro in ViewBuilder .................................................... 29
      To perform downloads from the Download page ............................................................ 29
Table of Contents

Monitor and control equipment ............................................................................................................................... 33

To display or change driver or set driver properties ..................................................................................... 43

To view an equipment's CCN tables ................................................................................................................ 43

To force a CCN point value ............................................................................................................................. 43

Manage setpoints ............................................................................................................................................... 44

Setpoints ......................................................................................................................................................... 45

To display or change driver or set driver properties ..................................................................................... 45

i-Vu CCN Pro CCN schedules .......................................................................................................................... 46

To view schedules .......................................................................................................................................... 47

Create and modify an i-Vu schedule .............................................................................................................. 47

To create a group override CCN time schedule ............................................................................................ 48

To apply a schedule to single equipment or to all equipment in an area ...................................................... 48

To apply a schedule to a group of equipment ................................................................................................. 49

Using schedule categories ............................................................................................................................... 49

To add a custom schedule category in i-Vu CCN Pro .................................................................................... 50

To view, edit, or delete a schedule category .................................................................................................... 51

Graphics pages ............................................................................................................................................... 51

To edit a graphic from i-Vu CCN Pro in ViewBuilder .................................................................................... 52

To upload your graphic to i-Vu CCN Pro .......................................................................................................... 52

Alarms .............................................................................................................................................................. 52

View, acknowledge, and delete alarms ............................................................................................................ 53

To view alarms in i-Vu CCN Pro ....................................................................................................................... 53

To acknowledge alarms .................................................................................................................................... 55

To delete alarms .............................................................................................................................................. 55

To receive audible notification of alarms ......................................................................................................... 56

Set up alarm actions ......................................................................................................................................... 56

To assign alarm actions to alarm sources ......................................................................................................... 57

Alarm Popup .................................................................................................................................................... 57

Print ................................................................................................................................................................. 59

Run External Program .................................................................................................................................. 60

Send Alphanumeric Page ............................................................................................................................... 61

Send E-mail .................................................................................................................................................... 63

Send SNMP Trap ............................................................................................................................................. 65

Write Property .................................................................................................................................................. 67

Operator access ............................................................................................................................................. 35

Privileges .......................................................................................................................................................... 35

Privilege sets .................................................................................................................................................... 38

Admin privilege set .......................................................................................................................................... 38

To add or edit a privilege set ........................................................................................................................... 38

To delete a privilege set .................................................................................................................................. 39

Operators and operator groups ........................................................................................................................ 39

To add or edit an operator .................................................................................................................................. 40

To delete an operator ....................................................................................................................................... 40

To add or edit an operator group ...................................................................................................................... 41

To delete an operator group ............................................................................................................................ 41

My Settings .................................................................................................................................................... 41

Set points .......................................................................................................................................................... 35
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Write to Database</strong></td>
<td>67</td>
</tr>
<tr>
<td><strong>Write to File</strong></td>
<td>70</td>
</tr>
<tr>
<td><strong>Set up an alarm source in i-Vu CCN Pro</strong></td>
<td>71</td>
</tr>
<tr>
<td>To set up, edit, or disable alarm sources</td>
<td>71</td>
</tr>
<tr>
<td>To view all instances of an alarm source</td>
<td>73</td>
</tr>
<tr>
<td><strong>Alarm categories</strong></td>
<td>73</td>
</tr>
<tr>
<td><strong>Trends</strong></td>
<td>74</td>
</tr>
<tr>
<td>To collect trend data for a point</td>
<td>74</td>
</tr>
<tr>
<td><strong>Graphing data for multiple points</strong></td>
<td>76</td>
</tr>
<tr>
<td>To create a comparison trend graph</td>
<td>76</td>
</tr>
<tr>
<td>To edit a comparison trend graph</td>
<td>77</td>
</tr>
<tr>
<td>To delete a comparison trend graph</td>
<td>77</td>
</tr>
<tr>
<td><strong>Using trend graphs</strong></td>
<td>78</td>
</tr>
<tr>
<td>To view a trend graph</td>
<td>78</td>
</tr>
<tr>
<td>Tools for viewing trends</td>
<td>78</td>
</tr>
<tr>
<td>To print a trend graph</td>
<td>79</td>
</tr>
<tr>
<td>To transfer trend data to a table format</td>
<td>79</td>
</tr>
<tr>
<td><strong>Customizing graph appearance</strong></td>
<td>80</td>
</tr>
<tr>
<td>To edit graph properties</td>
<td>80</td>
</tr>
<tr>
<td>To change colors, line styles, and marker types</td>
<td>81</td>
</tr>
<tr>
<td>To copy a trend graph’s properties</td>
<td>82</td>
</tr>
<tr>
<td>To add, edit, or delete a trend category</td>
<td>82</td>
</tr>
<tr>
<td><strong>Reports</strong></td>
<td>83</td>
</tr>
<tr>
<td><strong>i-Vu CCN Pro reports</strong></td>
<td>83</td>
</tr>
<tr>
<td>To run a report</td>
<td>84</td>
</tr>
<tr>
<td>To create a PDF or Excel spreadsheet</td>
<td>84</td>
</tr>
<tr>
<td><strong>Custom reports</strong></td>
<td>85</td>
</tr>
<tr>
<td>Equipment Summary</td>
<td>85</td>
</tr>
<tr>
<td>Equipment Values</td>
<td>86</td>
</tr>
<tr>
<td>Trend Samples</td>
<td>87</td>
</tr>
<tr>
<td>To view a custom report</td>
<td>88</td>
</tr>
<tr>
<td>To create a PDF or Excel spreadsheet</td>
<td>88</td>
</tr>
<tr>
<td>To edit or delete a custom report</td>
<td>89</td>
</tr>
<tr>
<td>To organize custom reports</td>
<td>89</td>
</tr>
<tr>
<td><strong>System Maintenance</strong></td>
<td>90</td>
</tr>
<tr>
<td>To backup your system</td>
<td>90</td>
</tr>
<tr>
<td><strong>Updating the Library</strong></td>
<td>90</td>
</tr>
<tr>
<td><strong>Troubleshooting i-Vu CCN Pro</strong></td>
<td>92</td>
</tr>
<tr>
<td><strong>Manual commands</strong></td>
<td>92</td>
</tr>
<tr>
<td><strong>TCP/UDP Port Usage</strong></td>
<td>94</td>
</tr>
<tr>
<td><strong>FAQ - Frequently Asked Questions</strong></td>
<td>94</td>
</tr>
</tbody>
</table>
What is i-Vu CCN Pro 4.2?

i-Vu CCN Pro is a web-based building automation system that can be accessed from anywhere in the world through Internet Explorer, without the need for special software on the workstation. Through Internet Explorer, you can access all building management functions such as:

- adjust setpoints and other control parameters
- set and change schedules
- graphically trend important building conditions
- view and acknowledge alarms
- run preconfigured and custom reports on energy usage, occupant overrides, tenant billing, and much more

A typical i-Vu CCN Pro system

i-Vu CCN Pro uses a network of microprocessor-based controllers to control heating, air conditioning, lighting, and other facility systems. A web-based server communicates with these controllers and generates web pages that the user can access through Internet Explorer. i-Vu CCN Pro allows you to gather information, change operating properties, run reports, and perform other building management functions on a single building, an entire campus, or a network of facilities that stretch around the globe.

- **The i-Vu CCN Pro client** uses Internet Explorer to access i-Vu CCN Pro Server as a website.
- **The i-Vu CCN Pro server** has great flexibility because of its Java 2 architecture. You can configure the database using a Java Database Connectivity-compliant (JDBC) database format.

i-Vu CCN Pro supports:

- Unlimited simultaneous users
- Multiple operating systems and databases
- Built-in alarming, trending, and reporting
- International languages
- Third-party integration
- WAP-enabled devices
- Secure server access using TLS/SSL

i-Vu CCN Pro design tools

Develop and configure graphics, and a system database for your i-Vu CCN Pro system using the following i-Vu CCN Pro design tools.
What is i-Vu CCN Pro 4.2?

<table>
<thead>
<tr>
<th>Use...</th>
<th>To...</th>
</tr>
</thead>
<tbody>
<tr>
<td>ViewBuilder</td>
<td>Create graphics and BACview screens.</td>
</tr>
<tr>
<td>ViewBuilder for WAP</td>
<td>Customize pages for WAP-enabled devices.</td>
</tr>
<tr>
<td>SiteBuilder</td>
<td>Create and modify the system database.</td>
</tr>
<tr>
<td>ApplicationBuilder</td>
<td>Create custom equipment files and graphics for Universal and Comfort Controllers, Terminal System Managers (TSM), and Hydronic System Managers (HSM).</td>
</tr>
<tr>
<td>LonWorks Integration Tool</td>
<td>Configure LonWorks integration points in your equipment.</td>
</tr>
</tbody>
</table>
i-Vu CCN Pro systems consist of both

- i-Vu CCN Pro device (the i-Vu web appliance)
- i-Vu device managers (i-Vu CCN Routers or i-Vu Links)

i-Vu device managers

- Are equivalent to CCN-to-Ethernet converters (the same CCN rules apply)
- Enable connection of a Carrier Comfort Network (CCN) to an Ethernet-based Local Area Network (LAN)
- Can function as a CCN Ethernet Gateway and be installed on the primary Bus 0
- Can function as a bridge to create secondary CCN Communication Buses, in order to extend a CCN over an Ethernet LAN within a campus or building

**IMPORTANT!** Only **ONE** i-Vu device manager must be configured as the Gateway!

---

**CAUTION!** The following MUST be completed prior to powering up the i-Vu CCN Pro.

---

**Step 1: Install software and get documentation ready**

i-Vu CCN Pro is supported on Windows 2000 (SP4 or later), Windows XP (SP2 or later), Server 2003 SP2, Vista Business and Ultimate. The 64 bit version of any operating system is **not** supported.

1  Insert the i-Vu CCN Pro CD into the server PC. AutoRun should start the software installation*. Follow the Installation Wizard to download the following:
   - i-Vu CCN Pro
   - ViewBuilder
   - ViewBuilder for WAP
   - ApplicationBuilder
   - LonWorks Integration Tool

2  If needed, print the **i-Vu Link** and/or **i-Vu CCN Router Installation Guide** from the **Documentation CD**.

3  If you will be integrating third party devices using an i-Vu Link, then print the applicable **Third Party Integration Guide** from the **Documentation CD**.

4  Follow the rest of this document to set up your entire system.

*If AutoRun does not automatically start the installation, then browse the CD and navigate to the **Windows > Setup** folder and double-click on Setup.exe to start the installation.
Step 2: Install i-Vu CCN device managers

Refer to the i-Vu CCN Router or i-Vu Link Installation Guide for mounting and wiring instructions. Download these from the Documentation CD.

You will need the instructions in that document for the following:

- Mounting and wiring the router
- Wiring the ports for communication and configuration
- Setting up IP addressing

Step 3: Use Network Service Tool V to ensure hardware is communicating on the CCN network

1. Connect the 3-terminal connector of the Network Service Tool's USB to CCN Converter to Port S1 on the i-Vu device manager.

<table>
<thead>
<tr>
<th>Carrier USB to CCN converter (top CCN Port)</th>
<th>i-Vu device manager (Port S1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Net+ (Pin 1)</td>
</tr>
<tr>
<td>G</td>
<td>Signal Ground (Pin 5)</td>
</tr>
<tr>
<td>-</td>
<td>Net- (Pin 2)</td>
</tr>
</tbody>
</table>

2. Launch Network Service Tool and connect to the i-Vu device manager. Each i-Vu device manager defaults to Gateway functionality and has a CCN address of 0,1.

CAUTION! Every CCN device must have a unique CCN address on the CCN network! Do not use Bus 0, Element 238, as it is automatically assigned to i-Vu CCN Pro.

3. Upload the i-Vu device manager.

4. Change the address of the i-Vu device manager using the Display/Set Properties function.

5. Access Service Configuration Table IP_CONF to enter the following configuration options.

NOTE A static IP address is required, as DHCP is not supported.

- **Host IP Address** - enter the IP address for the device manager, as provided by the LAN administrator. (allowable entries for xxx.xxx.xxx.xxx: xxx is a decimal number between 0 - 255)
- **Subnet Mask** - enter the IP address for the device manager, as provided by the LAN administrator. (allowable entries for xxx.xxx.xxx.xxx: xxx is a decimal number between 0 - 255)
- **Default Gateway** - enter the IP address of the default gateway on the Ethernet LAN for the device manager, as provided by the LAN administrator.

**CCN ENET Configuration**

**Device Type**

- Select 0 if this device manager is the Gateway. **(NOTE** Only one gateway is permitted per system.)
- Select 1 if this device manager is the Bridge.
If using the Router as a Bridge, enter **CCN/Ethernet Gateway IP** (the IP address of the i-Vu device manager that is configured as the Gateway). This is the same address that was entered in the **Host IP address** for the CCN Gateway.

**NOTE** Record the IP address of the gateway, because it is necessary to install the i-Vu CCN Pro.

6 Repeat the above steps for each i-Vu device manager used in the CCN system.

---

**Step 4: System Preparation**

1 Have a list of all of the devices at your job site, along with the name of each device, the bus and element numbers, and their respective locations.

2 For a retrofit project which is already using CCN global and network schedules, you must have a list of all existing CCN schedule numbers, systems using global and network schedules, and all global schedule masters.

3 Verify that each device has a unique element number because duplicates will not scan correctly.

**CAUTION** Do not use Bus 0, Element 238. It is automatically assigned to the i-Vu CCN Pro device.

4 Once equipment is scanned in, i-Vu CCN Pro begins broadcasting a 24/7 schedule to local CCN schedule# 64.

**NOTE** See *i-Vu CCN Pro CCN schedules* (page 46) in this document or consult the Help files for more information.

5 i-Vu CCN Pro allows unlimited pieces of equipment: (140 per i-Vu CCN Router, 70 per i-Vu Link). The device managers are each counted as a piece of equipment.

**NOTE** CCN Bridges and Ethernet Gateways configured as Bridges are each counted as a piece of equipment by the i-Vu CCN Pro.

---

**Step 5: Set up a computer and browser to view i-Vu CCN Pro**

**NOTES**

- i-Vu CCN Pro Server must be running before operators can log in from client browsers.
- To view trends, client computers need Sun's Java VM plugin. Go to **Main Menu > System Options > Client Installs** page for a link to the Java website.

<table>
<thead>
<tr>
<th>Browser settings</th>
<th>Where to change setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept First-party and Third-party cookies.*</td>
<td>Tools &gt; Internet Options &gt; Privacy tab &gt;Advanced button</td>
</tr>
<tr>
<td>Automatically check for newer versions of stored pages.*</td>
<td>Tools &gt; Internet Options &gt; General tab &gt; Settings button</td>
</tr>
</tbody>
</table>
### Browser settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Where to change setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load ActiveX Control*</td>
<td>Tools &gt; Internet Options &gt; Security &gt; Custom Level &gt; ActiveX controls (enable all of the following settings)</td>
</tr>
<tr>
<td></td>
<td>• Download signed ActiveX controls &gt; Prompt</td>
</tr>
<tr>
<td></td>
<td>• Download unsigned ActiveX controls &gt; Disable</td>
</tr>
<tr>
<td></td>
<td>• Run ActiveX controls and plug-ins &gt; Enable</td>
</tr>
<tr>
<td></td>
<td>Script ActiveX controls marked safe for for scripting &gt; Enable</td>
</tr>
<tr>
<td>Disable the Image Toolbar.</td>
<td>Tools &gt; Internet Options &gt; Advanced tab &gt; Multimedia section</td>
</tr>
<tr>
<td>Select Play animations in web pages.</td>
<td>Tools &gt; Internet Options &gt; Advanced tab &gt; Multimedia section</td>
</tr>
<tr>
<td>Do not save passwords if the computer is used by multiple operators.</td>
<td>Tools &gt; Internet Options &gt; Content tab &gt; AutoComplete button</td>
</tr>
<tr>
<td>Disable all the options on the Explorer Bar.</td>
<td>View &gt; Explorer Bar</td>
</tr>
<tr>
<td>Hide the browser's toolbars.</td>
<td>View &gt; Toolbars</td>
</tr>
<tr>
<td>Maximize the browser window.</td>
<td></td>
</tr>
</tbody>
</table>

### Computer settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Where to change setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set the monitor's screen resolution to a minimum of 1024 x 768 with 24- or 32-bit color quality.</td>
<td>Start &gt; Control Panel &gt; Display &gt; Settings tab</td>
</tr>
<tr>
<td>Disable navigation sounds.</td>
<td>Start &gt; Control Panel &gt; Sounds and Audio Devices &gt; Sounds tab</td>
</tr>
</tbody>
</table>

* *i-Vu CCN Pro cannot function without this setting.*
Before starting i-Vu CCN Pro for the first time, you must use SiteBuilder to create a database that i-Vu CCN Pro Server uses to communicate with the gateway. Follow the steps to Create a new database (page 7). i-Vu CCN Pro will use this information to scan your system and discover your equipment.

SiteBuilder uses a tree interface to display the system hierarchy. The Geographic tree represents the areas, controlled zones, and mechanical equipment in a system. The Network tree represents the communication network of routers and controllers with i-Vu CCN Pro Server.

You will use i-Vu CCN Pro to construct the logical groupings of equipment via Main Menu > System Settings. See Customize the navigation tree (page 16).

---

**Create a new SiteBuilder database**

1. Launch SiteBuilder program from Windows Start > Programs > i-Vu CCN Pro > SiteBuilder.
2. Click File > New.
3. Enter appropriate values in each of the New Database dialog boxes. See table below.
4. Click Finish.
5. This database has now been created. Close SiteBuilder.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
</table>

---

i-Vu CCN Pro 4.2 7
Use SiteBuilder to begin setting up your system

Field | Notes
--- | ---
**System Name** | Enter the name for this system that will be displayed at the top of i-Vu CCN Pro's navigation tree.

**System Directory Name** | The name of the folder that contains all the system files: `i-Vu CCN Pro.x\webroot\<system_directory_name>`

This name is automatically generated from the **System Name**, but it can be edited. The **System Directory Name** must have:
- less than 80 characters
- only alphanumeric characters, dashes, and underscores
- no spaces

**Database Type** | SiteBuilder automatically creates several files and a folder structure for an Access or MSDE database. Do not move or rename system files or folders.

If you choose MySQL, PostgreSQL, or SQL Server, you must replace the following items in the **Database Connect String** fields:

- `<host>` The IP address of the server that runs i-Vu CCN Pro.
- `<port>` The port number assigned by the system administrator.
- **NOTE** Do not use port number if running SiteBuilder and i-Vu CCN Pro on the local computer.
- `<instance>` The name of the database that you have created for the system.
- `<odbc-alias>` The ODBC alias you have defined for an SQL Server database.

Database Connect String examples:

MySQL: `jdbc:mysql://127.0.0.1/bac_technologies`
PostgreSQL: `jdbc:postgresql://127.0.0.1/bac_technologies`
SQL Server: `jdbc:odbc:bac_technologies`

**NOTE** To change connect strings for an existing system, select the **Modify Database Connection Parameters** checkbox in the **File > Open** dialog box, then click **Next**.

If you choose MySQL, PostgreSQL, or SQL Server, you must change the **Login** and **Password** fields to the user and password you set up in the database.

See **NOTES** below for information on MySQL, PostgreSQL, or SQL Server databases.

**Make this the default system for i-Vu CCN Pro** | Select this box to display this system when you start i-Vu CCN Pro.

**CCN Gateway IP Address** | Fill in this information obtained from Network Service Tool V.

**Time Zone and Units** | Select preferences.

**Supported Languages** | Languages that are supported by your system are displayed and selectable.

**System** | Languages selected in the Supported Languages list are listed here. Select the appropriate language for this system.

**NOTES**

MySQL | For MySQL installation information, go to www.mysql.com.

Install the version 5.0 MySQL driver to use with i-Vu CCN Pro.

Create 4 MySQL databases.

Create a user in MySQL with the same name and password as the user in SiteBuilder so that SiteBuilder can access the databases.
| **PostgreSQL**                  | PostgreSQL can only be installed on a Unix platform.  
|                               | Create four PostgreSQL databases.  
|                               | Create a user in PostgreSQL with the same name and password as the user in SiteBuilder so SiteBuilder can access the databases. |
| **SQL Server**                | When installing SQL Server, use mixed-mode authentication.  
|                               | Create four SQL Server databases.  
|                               | Create a user with the same name and password as the user in SiteBuilder with system administrator privileges so SiteBuilder can access the databases.  
|                               | After creating the databases, turn on Auto Shrink.  
|                               | After creating the databases, set the recovery mode to simple.  
|                               | Create an ODBC reference for each of the four databases. |
Operating i-Vu CCN Pro

Running i-Vu CCN Pro Server

i-Vu CCN Pro Server accesses and maintains the system database that is viewed and edited from client browsers.

The Current Users, Connections, and Output tabs allow you to monitor the status of the system. Output information is continually archived to i-Vu CCN Pro x.x\logs\WEBSERVER.log.

To run a system

i-Vu CCN Pro Server must be running before operators can log in from client browsers.

1 Select Start > Programs > i-Vu CCN Pro x.x > i-Vu CCN Pro Server.

   TIP If you use i-Vu CCN Pro as a Windows service, your computer can automatically start i-Vu CCN Pro Server every time the computer starts. See Running i-Vu CCN Pro as a Windows service in the i-Vu CCN Pro Help files.

2 Start the Internet browser on one or more client computers.

3 Verify that your browser is set up for displaying i-Vu CCN Pro. See Step 5: Set up a browser to view i-Vu CCN Pro (page 5).

4 Type the i-Vu CCN Pro server's address in the browser's Address field.

   NOTE You can type http://localhost if the server and browser are running on the same computer.

5 Enter a Name and Password. The default Name and Password of a new system is Administrator and <blank>.

To run a system without connecting to the controllers

Use i-Vu CCN Pro in Design Mode to verify links between graphics and to set up properties, schedules, alarms, and trends before you connect to the network.

In i-Vu CCN Pro Server, select Server > Restart > In Design Mode.

NOTES

- Question marks and purple thermographic color indicates correct microblock paths. Missing data or dark yellow thermographic color indicate errors.

- If you do not have the Design and Normal Mode options, you are using a Tools Only installation of i-Vu CCN Pro.

To switch to a different system

Design engineers working on multiple projects can switch systems in i-Vu CCN Pro Server.

1 In i-Vu CCN Pro Server, select Server > Change Active System.
2 Select a different system (it must be in the webroot folder) and mode.
3 Click Select.

**To send a message to logged in operators**

Notification messages are delivered immediately to i-Vu CCN Pro client browsers. You can send multiple messages, but the operator must click **Ok** for the first message before the next message can be delivered. If the browser window is minimized, the message is not visible.

1 In i-Vu CCN Pro Server, click the **Current Users** tab.
2 Click the **Notify** button beside the user you want to send a message to. Or click **Notify All Users**.
3 Type a **Notification message**.
4 Click **OK**.

**NOTE** You can also type `notify [followed by the message]` in the manual command dialog box in i-Vu CCN Pro to send a message to all logged in operators.

**To log off an operator**

**NOTE** The operator will be logged off without warning.

1 In i-Vu CCN Pro, press Ctrl+M.
2 Type `whoson` in the manual command field.
3 Obtain the ID number of the operator you want to log off.
4 Press Ctrl+M.
5 Type `logoffuser x` (where x is the ID number).
6 Click **OK**.

**To shut down a system**

1 In i-Vu CCN Pro Server, select **Server > Shut Down**.
2 Optional: Select a delay option, then edit the **Notification message**.
3 Click **Shut Down**.

**NOTE** You can also type `shutdown` in the manual command dialog box in i-Vu CCN Pro to shut down the server.
Getting to know the i-Vu CCN Pro workspace

NOTES

- Use only the i-Vu CCN Pro interface to navigate through i-Vu CCN Pro; do not use the browser’s navigation buttons.
- Disable all popup blockers. IE > Tools > Turn Off Popup Blocker.

Navigating the system

NOTE Use only the i-Vu CCN Pro interface to navigate through i-Vu CCN Pro; do not use the browser’s navigation buttons.

To navigate in i-Vu CCN Pro

1. Select the item you want in the navigation tree.
2. Select the action buttons and their drop-down menus.
3. Use the tabs to filter the information further.

To show or hide the navigation pane

Click arrow on the left of the navigation pane to toggle between shown or hidden. When hidden, hover on the left edge and navigation pane will pop into view.
Click and drag the right edge of the navigation pane to adjust its width.

### Zooming and resizing contents of the action pane

- Hold down Ctrl while rolling your mouse wheel to zoom in or out on the contents of the action pane.
- Right-click the action pane and select **Scale to 100%** to restore the contents to their original size.
- If a graphic does not fit in the action pane, right-click it and select **Scale to Fit** to make it fit the action pane. Select **Scale to 100%** to return it to its original size.

### Using right-click menus

You can right-click the following items to select options:

<table>
<thead>
<tr>
<th>A tree item</th>
<th>The action pane</th>
<th>A property</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Carrier" /></td>
<td><img src="Image" alt="Help" /></td>
<td><img src="Image" alt="Help" /></td>
</tr>
</tbody>
</table>
Operating i-Vu CCN Pro

To print the action pane

Click to print the contents of the action pane. Set the print orientation to Landscape in the Print dialog box.

NOTE If you do not want to print the black background, in your browser's Internet Options dialog box, disable background printing.

Colors and status in i-Vu CCN Pro

The following colors indicate equipment status throughout i-Vu CCN Pro. These colors are visible in the zone color ovals on the graphic pages and in the setpoint graphics.

<table>
<thead>
<tr>
<th>Color</th>
<th>Color Name</th>
<th>Status Code</th>
<th>Condition Indicated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Purple</td>
<td>Purple</td>
<td>0 or 15</td>
<td>No communications</td>
</tr>
<tr>
<td>Charcoal</td>
<td>Charcoal</td>
<td>14</td>
<td>In equipment—a device has stopped</td>
</tr>
<tr>
<td>Coral</td>
<td>Coral</td>
<td>13</td>
<td>Error</td>
</tr>
<tr>
<td>Red</td>
<td>Red</td>
<td>2 or 9</td>
<td>Heating or cooling alarm</td>
</tr>
<tr>
<td>Orange</td>
<td>Orange</td>
<td>8</td>
<td>Maximum cooling</td>
</tr>
<tr>
<td>Dark blue</td>
<td>Dark blue</td>
<td>3</td>
<td>Maximum heating</td>
</tr>
<tr>
<td>Yellow</td>
<td>Yellow</td>
<td>7</td>
<td>Moderate cooling</td>
</tr>
<tr>
<td>Light blue</td>
<td>Light blue</td>
<td>4</td>
<td>Moderate heating</td>
</tr>
<tr>
<td>Gray</td>
<td>Gray</td>
<td>1</td>
<td>Unoccupied/inactive</td>
</tr>
<tr>
<td>White</td>
<td>White</td>
<td>10</td>
<td>Occupied/active</td>
</tr>
<tr>
<td>Light green</td>
<td>Light green</td>
<td>6</td>
<td>Free cooling</td>
</tr>
<tr>
<td>Green</td>
<td>Green</td>
<td>5</td>
<td>Comfortable</td>
</tr>
</tbody>
</table>

Colors and setpoints

The color of the equipment color control indicates how much a zone's actual temperature differs from its setpoints.

Five conditions may affect a zone’s thermographic color:

- Setpoint adjust
- Local override
- Deadband

In the examples below, a zone's heating occupied setpoint is 70° and its cooling occupied setpoint is 74°.
Operating i-Vu CCN Pro

If you normally see... | when the zone temp is... | but... | then you will see...
--- | --- | --- | ---
green | 72.5° | someone adjusts the setpoints (for example, with a **setpoint adjust** of two degrees, the new setpoints would be 68 and 72°) | yellow
gray (unoccupied) | 73° | someone presses the **Override** button on a sensor to use the occupied setpoints | green
green | 73.5° | cooling began when the temperature rose above 74° and the temperature has not yet dropped beyond the 1° deadband (to 73°) | yellow

Using System Setup

The **System Setup** page allows you to scan your network and discover your devices. As it scans your system, the program tables for each device are accessed and the navigation tree is populated.

During the scanning process, i-Vu CCN Pro automatically accesses tables and assigns a graphic from the **Library** for each device found on the bus.

Click **Main Menu**, then select **System Setup** to do the following:
- Scan the network to populate the system with equipment, graphics, and equipment tables
- Build, edit, and arrange the navigation tree
- Re-scan whenever equipment tables have been changed
- Download option for individual or multi-selected equipment
- Update **Library**
- Change addressing of a CCN controller or bridge device

Prepare to scan

**Prerequisites for a successful scan**

- Have a list of all the devices in your system you wish to scan, including the bus and element numbers and the locations
- Verify that the devices and your i-Vu CCN Pro are wired and communicating on the bus.
- Verify that each device has a unique element number because duplicates will not scan correctly!

**NOTE** Do not use Bus 0, Element 238. It is automatically assigned to the i-Vu CCN Pro device.

- i-Vu CCN Pro allows a maximum of unlimited controllers and device managers: (140 per i-Vu CCN Router, 70 per i-Vu Link).

**Time-saving tip:**

It is very advantageous to create the areas in your navigation tree **before** scanning. Then you can choose a specific area and scan your the equipment directly into that area. Otherwise, equipment will have to be
rearranged in the navigation tree by clicking and dragging or by using the arrows in the toolbar. See *Customizing the navigation tree* (page 16).

**Customize the navigation tree**

The navigation tree is a hierarchical view that represents the areas and the equipment in a system. An area is a logical group of areas or equipment. Arranging your navigation tree can be done before or after scanning for devices.

- If you set up your areas in the navigation tree *before scanning*, highlight the area you wish to populate with equipment, enter just the relevant bus and element numbers for the equipment in that area, and then scan. Those devices will automatically be listed under the area that was highlighted.
- If you set up your areas in the navigation tree *after scanning*, click and drag the equipment to the correct area, or use the arrows in the left menu bar.
- You could also scan for all devices at once (this will take awhile) and then click and drag them to their correct location in the tree.

To add an area:

1. Click the menu button 📈, then select **System Setup**, if you are not already there.
2. Right-click an area in the navigation tree and select **Add Area**, or click 🗺️ in the toolbar.
3. Type name.
4 Proceed to **Scan** or **Exit System Setup**.

**NOTE** Right-click to use drop-down menu or use toolbar to rename, move, copy, or delete areas.

---

**Scan for devices**

**Scan whenever**
- Equipment is added
- A specific equipment configuration has been altered

**To scan devices and discover their tables**

1 Click the menu button and then select **System Setup**, if you are not already there.
2 In the navigation tree, select the desired area. As devices are discovered, they will appear in the tree under the highlighted area. The tree can be manipulated later by dragging or using the arrows on the left toolbar.
3 To start scanning, enter the applicable **Bus** and **Element** numbers of a specific device or for a range of devices.
4 Verify that **Discover Tables** is checked.

**NOTE** The scanning time for discovering tables increases based on the number of devices. You may choose to discover tables at a later time for a faster scan.
5 Click **Start Scan**. When the process is complete, a message appears showing the number of equipment found.

**NOTE** If there is a missing gateway, the message will appear, "You must discover a device before adding an equipment."

---

**Update library and change addressing**

**Update Library** - The Library holds graphics and definitions for CCN devices. This link allows you to update your Library when you are notified that Carrier has new graphics available. After you have downloaded and saved the graphic to your computer, use this option to upload to your i-Vu CCN Pro. Be sure to re-scan the applicable piece of equipment after updating the Library.

**Change Addressing** - Enter new **Element** and **Bus** number to change the physical address of a device.

---

**Re-scan or download equipment**

Whenever a piece of equipment is changed or a specific equipment configuration has been altered:

1 Highlight the device or devices (CTRL-click) in the **System Setup** table.
2 Verify that **Discover Tables** is checked.
3 Click **Start Scan**.

If download has failed:
Operating i-Vu CCN Pro

1. Right-click the device or devices (CTRL-click) in the **System Setup** table.
2. Choose **Download** from drop down menu.

### Working with Universal and Comfort Controllers (CCN)

Universal Controllers (UC) and Comfort Controllers (CC) that are scanned into the system in **System Setup** will be assigned a generic equipment and view file, which have setpoint control, but no additional pre-mapped I/O. In order to have additional I/O points available for graphic display, you must use **ApplicationBuilder** to create the custom equipment files to support your application. These files will map the CCN variables to i-Vu BACnet points.

In **ApplicationBuilder**, you can create **CCN Values Only**, **Read Integration**, or **Link Integration** custom equipments for UC/CC that are tailored for your specific application.

**ApplicationBuilder** can also create some stand-alone applications for Consumable Reports for:

- **Energy Meters**
- **Non-linear flow meters**
- **Energy (BTU) consumption**
- **Equipment Runtime**

These options can also be added to **CCN Values Only** and **Link Integration** custom equipments and only require mapping of the points to be monitored.

Once the equipment files and the view file are uploaded to **i-Vu CCN Pro** (page 22), these points can be assigned to custom graphic elements, which are created in **ViewBuilder**.

Because CC’s will likely control multiple pieces of HVAC equipment, expansion controllers associated with CC’s must be added to i-Vu CCN Pro from **System Setup**. This allows separate setpoint and schedule control of these multiple physical equipments from a single CC. These expansion controllers support the additional equipment and view files required for these “separate” systems.

### Create custom equipment files for UC/CC’s that link only to CNN points

ApplicationBuilder creates an equipment file for the UC/CC, which maps the I/O points that are required for one or more applications. Once these files are created, these linked I/O points can then be associated with **ViewBuilder** graphics.

**NOTE** To have a **Prime Variable**, (a temperature that is displayed in a color oval when the CC or UC is shown in a site or area equipment list), the **Schedule and Setpoint** option must be selected when creating the equipment file.

1. Start **ApplicationBuilder**. (Windows **Start** > **All Programs** > **IVu Tools 4.2**)
2. Click **Create Equipment**.
3. Select equipment type: **Custom Equipment** > **CCN Values Only**.
4. Click **Next**.
5. Type a name for the custom equipment (i.e., Hot Water system) next to **Equipment Name**.
6. Enable **English** or **Metric** units.
7. Select options from the drop down menus.
8 Select **Schedule and Setpoint** in the first drop down menu:
- to use the setpoint slidebar graphic in i-Vu CCN Pro
- to have a **Prime Variable**, (a temperature that is displayed in a color oval when the UC/CC is shown in a site or area equipment list)

9 Click **Next**.

10 Choose the type of element, quantity and click the ![Add Element](image)

Add Elements to your application

**NOTE** Elements are a collection of input/output points that perform a specific operation. The input/output point that is reading or writing to the UC/CC is called a CCN point.

The available Elements that you can add to your custom equipment in ApplicationBuilder are:

<table>
<thead>
<tr>
<th>Point type</th>
<th>Used for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read CCN Point</td>
<td>Reading an analog or binary value from the UC/CC</td>
</tr>
<tr>
<td>Carrier Text Point</td>
<td>Read a text string from the UC/CC</td>
</tr>
<tr>
<td>Analog - Setpoint Write</td>
<td>Reading and writing individual variables</td>
</tr>
</tbody>
</table>

1 As you add Elements, enter the requested information for the CCN points:
- **Display Text** - the description of the point as it will appear in i-Vu CCN Pro (i.e., Pump status)
- **Reference Base** - the name of the point which will be used when linking the point to a graphic element. All points have a unique identifier (i.e.,input_pumpstat, trendPumpstat)
- **Input Address** - enter the CCN path to link to this point. In i-Vu CCN Pro, all CCN tables will have a **Copy Path** symbol ![Copy Path](image) at the far right of the display. Click on this symbol to place a copy of the path on the clipboard. In ApplicationBuilder, paste the path into the **Input Address** field, using Ctrl+V.

2 When you are finished adding Elements for your application, click **Next**.

3 **Equipment Name** - type a new equipment name, if desired.

4 **Save Location** - browse to a location where you would like to save the new custom equipment.

5 Click **Save**.

**Custom graphic**

Use ViewBuilder to edit the graphic that is created.

**Create custom equipment files for UC/CC's that link to TPI points**

In **ApplicationBuilder**, you can create an equipment file for the UC/CC, which maps the I/O points that are required for one or more applications. In this type of equipment, you can link CCN to TPI points in a UC/CC. Once these files are created, these linked I/O points can then be associated with ViewBuilder graphics.

**NOTE** To have a **Prime Variable**, (a temperature that is displayed in a color oval when the UC/CC is shown in a site or area equipment list), that comes from a TPI point, the **Link to Third Party to Prime Variable** option must be selected when creating the equipment file and the **Schedule and Setpoint** option must not be selected for this equipment.
1 Start ApplicationBuilder. (Windows Start > All Programs > iVu Tools 4.2)
2 Click Create Equipment.
3 Select equipment type: Custom Equipment > Link Integration Values to CCN.
4 Click Next.
5 Type a name for the custom equipment (i.e., Hot Water system) next to Equipment Name.
6 Enable English or Metric units.
7 Select options from the drop down menus.
8 Click Next.
9 Choose the type of element, quantity and click the +.

Add Elements to your application

**NOTE** Elements are a collection of input/output points that perform a specific operation. The input/output point that is reading or writing to the UC/CC is called a CCN point.

The available Elements that you can add to your custom equipment in ApplicationBuilder are:

<table>
<thead>
<tr>
<th>Point type</th>
<th>Used for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read CCN Point</td>
<td>Reading an analog or binary value from the UC/CC</td>
</tr>
<tr>
<td>Carrier Text Point</td>
<td>Read a text string from the UC/CC</td>
</tr>
<tr>
<td>Analog - Setpoint Write</td>
<td>Reading and writing individual variables</td>
</tr>
<tr>
<td>Analog - Link CC to Integration</td>
<td>Writes CCN variables to TPI</td>
</tr>
<tr>
<td>Analog – Link Integration to CCN</td>
<td>Writes TPI variables to CCN</td>
</tr>
<tr>
<td>Analog – Link CCN Passive to Integration</td>
<td>Writes CCN variables to TPI</td>
</tr>
<tr>
<td>Analog – Link Integration to CCN Passive</td>
<td>Writes TPI variables to CCN</td>
</tr>
<tr>
<td>Analog – BACnet to CCN</td>
<td>Writes BACnet variable to CCN</td>
</tr>
<tr>
<td>Binary – Link CC to Integration</td>
<td>Writes CCN variables to TPI</td>
</tr>
<tr>
<td>Binary – Link Integration to CCN</td>
<td>Writes TPI variables to CCN</td>
</tr>
<tr>
<td>Binary – Link CCN Passive to Integration</td>
<td>Writes CCN variables to TPI</td>
</tr>
<tr>
<td>Binary – Link Integration to CCN Passive</td>
<td>Writes TPI variables to CCN</td>
</tr>
<tr>
<td>Binary – BACnet to CCN</td>
<td>Writes BACnet variable to CCN</td>
</tr>
</tbody>
</table>

1 As you add Elements, enter the requested information for the CCN or TPI points:
   ○ **Display Text** - the description of the point as it will appear in i-Vu CCN Pro (i.e., Pump status)
   ○ **Reference Base** - the name of the point which will be used when linking the point to a graphic element. All points have a unique identifier (i.e., input_pumpstat, trendPumpstat)
Operating i-Vu CCN Pro

○ **Input Address** - enter the CCN path to link to this point. In i-Vu CCN Pro, all CCN tables will have a Copy Path symbol at the far right of the display. Click on this symbol to place a copy of the path on the clipboard. In ApplicationBuilder, paste the path into the Input Address field, using Ctrl+V.

2 When you are finished adding Elements for your application, click Next.

3 **Equipment Name** - type a new equipment name, if desired.

4 **Save Location** - browse to a location where you would like to save the new custom equipment.

5 Click Save.

Custom graphic
Use ViewBuilder to edit the graphic that is created.

---

**Use Global Modify to view and change the same property in multiple microblocks**

Use the Global Modify feature to:

- View a microblock's full path, control program name, and the roles or privileges required to change its properties.
- View or change a single property in several control programs at one time.

1 Browse to any page that displays the property you want to view or change.

2 Do one of the following to access Global Modify.
   - Right-click the property, then select Global Modify.
   - Alt+click the property.
   - Click the Main Menu button, select Global Modify, then click the property.

3 Make changes to the Control Program field, if needed.

**NOTES**

- Use wildcards in the Control Program field to broaden the search.
  - For example:
    - vav* matches vav, vav1, vavx, vav12345
    - vav*z matches vavz, vav1z, vavxz, vav12345z
    - vav*1*2 matches vav12, vavabcxyz2
    - vav?? matches vav11, vav12, vavzz, but does not match vav, vav1, vav123
    - * matches any control program
- Click Show Advanced to view the location, value, and privileges associated with this property.

4 Select the tree item under which you want to search for every occurrence of that microblock in other control programs.

5 Click Find All.

6 Select the properties in the list that you want to change.

7 Do one of the following:
   - Type a New Value to the right of each selected item (a).
   - Type a number in the Set All To field (b).
Operating i-Vu CCN Pro

8 Click **Set All To** or **Change All By**.

9 Click **Apply Changes**.

**NOTE** To modify several properties in multiple control programs at the same time, use the **Global Copy** feature.

---

**Create stand-alone applications**

In **ApplicationBuilder**, you can create some pre-engineered, stand-alone equipment applications with a view for **Consumable Reports** for **Energy Meters** (electric, gas, water, steam, generic), non-linear flow meters, energy (BTU) consumption, and equipment runtime.

These options can be added to **CCN Values Only** and **Link Integration** custom equipments. Mapping the points allows monitoring.

**NOTES**

- One meter and one Runtime may be added to equipment.
- There is an application for a CCN Vertical Pack unit. This is a CC with special software and BEST++. While this controller can be discovered in i-Vu CCN Pro in **System Setup** as a Vertical Pack, none of the possible selected options can be auto-discovered at this time, so only a base view will be generated. This application allows the Installer to generate a correct equipment and view file based on the selected options.

---

**Assign and download a custom UC/CC equipment file**

1 In the i-Vu CCN Pro navigation tree, right-click on the equipment and select **Configure** from the drop-down menu.
Enter the following information in the dialog box:

2 Under **Equipment**, click **Add**. A dialog window will appear.
3 Browse to the .equipment file that was generated in ApplicationBuilder.
4 Click **Continue**. When message appears "File uploaded successfully", click **Close**.
5 Click **Close** again.

**NOTE** If the **Graphics** tab is highlighted, a message indicating that a "Download is in progress will appear." This will clear at the completion of the download.

6 Click **OK** or **Apply**.
7 If the **Graphics** tab is highlighted, a message indicating "Download in progress" will appear. This will clear at the completion of the download.

For additional pieces of equipment controlled by your UC/CC (expansion controllers)

1 Click **Main Menu** button, then select **System Setup**.
2 In the navigation tree, right-click the area where you want to place the equipment. Select **Add Equipment** from the drop-down menu or click in the toolbar.
3 Enter a **Display Name**.
4 Under **Associate with**, click **CCN Device** and enter the Bus and Element number of the associated UC/CC.

**NOTE** You cannot change the association once you have clicked **Apply**. To change it, you would have to delete the equipment and start over.

5 Click **Apply**, then **Close**.
6 Exit **System Setup**.

**Map to Point procedures for the Universal and Comfort Controller**

I/O Points that are included in a custom equipment file will automatically be mapped to their associated CCN points once the file is uploaded to i-Vu CCN Pro. The following procedure is **not** required for those points.

This procedure is necessary for points associated with the **Setpoint Support** option, which must be mapped manually using the following procedure.

1 In the navigation tree, select the UC/CC and click + to expand **Tables**.
2 Click + next to the table headings (Setpoint, Status Display, Maintenance, etc.) to see additional tables.
3 Click on the table you wish to work with. The **Setpoint** table is used in this example.
Operating i-Vu CCN Pro

4 Select the drop down menu under **Map to Point** in the far right column.
5 Select the variable to be mapped.
   **NOTE** Not Mapped erases any previously selected information.
6 Click **OK**. The **Map to Point** entry will now change to the mapped point's description.
7 Repeat steps 1 through 5 for points that need to be mapped.

**Setpoint mapping**

1 In the navigation tree, select the device and click + to expand **Tables**.
2 Click + next to **Setpoint** to expand the table, and click on the desired setpoint table name.
3 Follow above **Map to Point procedures** (page 23).

**Working with Terminal System Managers**

A Terminal System Manager (TSM) that is scanned into the system through **System Setup** will be assigned an auto-generated equipment that represents Group 1 in the TSM. Group 1 is the default group which can control the setpoints and occupancy for all of the existing zones, or up to 16 specifically selected zones. This equipment is pre-mapped and requires no further action.

All other Groups or Zone equipment must be added as expansion equipments. You must use **ApplicationBuilder** to create the necessary additional Group or Zone equipment files. These files will map the CCN variables to i-Vu BACnet points and will replace the default equipment in the expansion equipments that have been added for the additional Groups or Zones.

Once the equipment files are created and uploaded to i-Vu CCN Pro, these points can be assigned to custom graphic elements, which are created in **ViewBuilder**. Expansion equipment associated with a TSM must be added to i-Vu CCN Pro from **System Setup** to support additional Groups and Zones. You must create separate equipment and view files in **ApplicationBuilder** for each expansion equipment.

**Important points when setting up your TSM in i-Vu CCN Pro**

- Each group or zone must be added as a new equipment
- TSM's can only be on Bus 0
- Only the gateway can be Bus 0
- The gateway can support 140 devices and 200 equipments
- A fully utilized TSM (12 Groups/64 Zones) would take 76 equipment files
   **NOTE** If you have 2 TSM's with 8 Groups and 37 Zones in each, it will take 45 equipment files for each TSM or a total of 90 equipment files from a possible 200. This would allow another 110 equipments for every other controller on Bus 0.

**Create custom equipment files in ApplicationBuilder for Terminal System Managers (TSM)**

ApplicationBuilder creates an equipment and view file for the TSM temperature zones and control groups. The
Assign and download a TSM equipment file in i-Vu CCN Pro

When you scan equipment into i-Vu CCN Pro, each TSM will be discovered with Group 1. You must add a new and separate equipment for each additional zone and group for which a graphic is desired, create the equipment file for each one in ApplicationBuilder, and then upload the equipment and view file to the new equipment that was added in i-Vu CCN Pro.

The Group or Zone that you create in ApplicationBuilder contains setpoint support, schedules, and the points configuration of a Group or Zone. The CCN path information is automatically configured. The automatic path configuration is incomplete and you must use a Search and Replace function to exchange the generic Groups or Zones for your specific Group or Zone number.

To upload an equipment file to a TSM group or zone that has already been scanned in or added to i-Vu CCN Pro

1 In the i-Vu CCN Pro navigation tree, right-click on the equipment and select Configure from the drop-down menu. Enter the following information in the dialog box:
   2 Under Equipment, click Add. A dialog window will appear.
   3 Browse to the .equipment file that was generated in ApplicationBuilder.
   4 Click Continue. When message appears "File uploaded successfully", click Close.
   5 Click Close again.

NOTE If the Graphics tab is highlighted, a message indicating that a "Download is in progress will appear." This will clear at the completion of the download.
To add expansion equipment for additional groups and zones controlled by your TSM (expansion controllers)

1. Click **Main Menu** button, then select **System Setup**.
2. In the navigation tree, right-click the area where you want to place the equipment. Select **Add Equipment** from the drop-down menu or click in the toolbar.
3. Enter a **Display Name**.
4. Click **CCN Device** and enter the Bus and Element number of the associated TSM. This allows the new equipment to inherit the tables from that TSM.

**NOTE** You cannot change the association once you have clicked **Apply**. To change it, you have to delete the equipment and start over.
5. Click **Apply**, then **Close**.
6. Exit **System Setup**.

---

**Configure the path to the source of the point for TSM Groups and Zones**

A generic list of points is created in i-Vu CCN Pro when the TSM Group or Zone is scanned in to the system or when you upload the equipment file.

**You must initially revise the address of the path for every point!**

1. Select the TSM Group or Zone in the navigation tree, then click **Properties > Network Points** tab.
2. To substitute the correct Group or Zone number where the double X (XX) is in each path, click the **Search/Replace** button under the **Address** column.
3. Enter "XX" in the **Search** field and enter the appropriate Zone or Group number in the **Replace** field. This will update all of the paths for that Zone or Group.

**IMPORTANT!**

**TSM Zone 1** requires an extra step because one point has a slightly different name than in Zones 2 thru 64. The setpoint offset point in Zone 1 is inadvertently named **STPOFF**, while it is named **SPTOFF** in the remaining Zones.

This will cause an error because the point is incorrectly mapped in the template for Zone 1, even though it is correctly mapped for Zones 2 through 64.

You must change **SPTOFF** to **STPOFF** for this one zone!

Example:

`CCN://LINK/TZDSP01/SPTOFFST` must be changed to `CCN://LINK/TZDSP01/STPOFFST`. 
Working with equipment

You can view and adjust equipment operation from the following pages:

**Graphics pages (page 28)**
You can view and adjust your essential building controls on most Graphics pages.

**Equipment drawings** show the current status of mechanical equipment.
Adjust **setpoints** (page 33) on a Graphics page.
To upload a graphic from ViewBuilder, right-click on the device in the navigation tree and select **Configure**.

**Property pages (page 31)**
You can monitor and control point sources.
1. Select the equipment in the navigation tree.
2. Click **Properties page > Equipment tab.**
3. Expand the plus sign next to the desired table.

**CCN equipment tables (page 43)**
1. In the navigation tree, select the equipment.
2. Click † next to the equipment to expand it.
3. Select the table you want to view.
These tables are not in the system database, but are dynamically generated from the tables in the device.
Point dialogs

Ctrl+click a value or point to open its popup dialog where you can view and change properties or force values.

Graphics pages

You can view and adjust your equipment from Graphics pages and change the setpoints for occupied and unoccupied hours.

NOTES

- Ctrl+click or right-click a value and select Microblock Properties from the drop-down menu to view and change properties in the popup.
- Alt-click or right-click a value and select Global Modify (page 21) from the drop-down menu to view and change the property in other equipment.
- Forced values are indicated by a yellow dashed line
- If a graphic is larger than the action pane, right-click the graphic and select Scale to Fit to see the whole graphic. Right-click and select Scale to 100% to return the graphic to its original size.

When using Scale to 100%, hold down Ctrl while rolling the mouse wheel to zoom in and out on a graphic.

To attach a graphic in i-Vu CCN Pro

1. On i-Vu CCN Pro's navigation tree, right-click the item that you want to attach a graphic to, then select Configure.

2. Do one of the following:

<table>
<thead>
<tr>
<th>If the graphic is...</th>
<th>In the Views Available list</th>
<th>1. Select the graphic, then click Attach.</th>
<th>2. Click OK or Apply.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Operating i-Vu CCN Pro

If the graphic is...

| Not in the Views Available list | 1. At the bottom of the Views section, click Add. |
|                               | 2. Browse to select the view file.             |
|                               | 3. Click Open.                                |
|                               | 4. Click Continue.                            |
|                               | 5. Click Close.                               |

NOTES

- Click a graphic in the Attached list to edit the graphic's:
  - Display Name - The name that appears in the Graphics button droplist
  - Category - See To organize multiple graphics for a single tree item (page 30).
  - Reference Name - The name that is used to create links to the graphic in ViewBuilder

- You can click Delete Unused at the bottom of the Views section to delete all unattached graphic files from your system.

To edit a graphic from i-Vu CCN Pro in ViewBuilder

NOTE Only the Installer role has access to the following.

To edit a graphic from i-Vu CCN Pro in ViewBuilder:

1. Select the piece of equipment in i-Vu CCN Pro navigation tree.
2. Right click on the equipment name and select Configure.
3. Click Edit button under Views.
4. Click Save to desktop or other appropriate folder.
5. Open ViewBuilder.
6. Select File > Open. Browse to your saved graphic and click to open.
7. Edit as desired.
8. Save with a new name - the original system name is locked and cannot be used for an edited graphic.

NOTE Names are case sensitive and should not have spaces and/or special characters.

To perform downloads from the Download page

1. Click Main Menu button, then select System Options.
2. On the tree, click Download.
3. On the Network tree on the right, select an item you want to download.
4. Select the types of download needed for that item. See table below.
5. Click Add to add the item to the Download Items list.
6. Add more items if necessary.
7 Select the item(s) you want to download in the **Download Items** list.

**TIP** Select the **Select all** checkbox to select all items in the list.

8 Click **Download Selected Items**.

<table>
<thead>
<tr>
<th>Download Type</th>
<th>Code</th>
<th>Downloads to the controller...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory</td>
<td>M</td>
<td>The control program and module driver</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>NOTE</strong> A memory download also:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Synchronizes the equipment’s time to i-Vu CCN Pro</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Overwrites trends in the controller</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Restarts the controller</td>
</tr>
<tr>
<td>Parameters</td>
<td>P</td>
<td>All parameters</td>
</tr>
<tr>
<td>Schedules</td>
<td>S</td>
<td>All schedules that are not set for automatic download</td>
</tr>
<tr>
<td>BBMD</td>
<td>B</td>
<td>BBMD tables</td>
</tr>
</tbody>
</table>

Items in the **Download Items** list may also display the following codes:

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>V</td>
<td>i-Vu CCN Pro detected a mismatch between a value in the equipment and i-Vu CCN Pro Server. See <em>To resolve a mismatch</em> (page 33).</td>
</tr>
<tr>
<td>U</td>
<td>Unsuccessful parameter upload from the equipment. Try again or delete the item from the <strong>Download Items</strong> list.</td>
</tr>
</tbody>
</table>

**To organize multiple graphics for a single tree item**

In i-Vu CCN Pro, you can create categories and assign graphics to them so that the **Graphics** button dropdown menu has the graphics arranged by category.

**To add or edit a Graphics category in i-Vu CCN Pro**

1 On i-Vu CCN Pro's **System Options** tree, click the plus sign (+) to the left of the **Categories** folder, then select **Graphic**.

2 Click **Add** or select a category to edit.

3 Type the **Category Name** and **Reference Name**.

4 Optional: Select a privilege so that only operators with that privilege can access graphics in the category.

5 Click **OK**.

**NOTE** To delete a category, select the category, click **Delete**, then click **OK**.

**To assign a graphic to a category in i-Vu CCN Pro**

1 On i-Vu CCN Pro's navigation tree, right-click the item that the graphic is attached to, then select **Configure**.

2 Under **Views**, select the graphic in the **Attached** list.

3 Select the category in the **Category** field.
Properties pages

Properties pages are automatically generated from control programs. Properties pages show the status of a piece of equipment and the properties currently stored in it. See Checkout input and output, alarms, trends, and network points for details.

Use Properties pages to:

- View the status of a piece of equipment. See Colors and status in i-Vu CCN Pro (page 14).
- View or change the equipment or microblock properties currently stored in the controller.
- Commission equipment

To view or change properties on a Properties page

1. Select a controller on the navigation tree, then click Properties.
2. Select the appropriate tab.
3. Click the plus icons to show point details.
4. Do one of the following to change a property:
   - Select or clear a checkbox
   - Select an item on a drop-down list
   - Change text in a text field
5. Click OK.

NOTES

- Click the bold, underlined point name to open the point’s editable Properties dialog
- Ctrl+click a value or point to open the point’s editable Properties dialog
- Alt+click a value on any page to view and change the same property in other control programs (Global Modify).
- Use Search/Replace on the Network Points tab to replace a term in the point address with another address.
- For the legend of status colors, see Colors and status in i-Vu CCN Pro (page 14).

Changing multiple microblock properties

Two i-Vu CCN Pro features, Global Modify and Global Copy, allow you to view and change multiple microblock properties at the same time.

TIP Click to copy a microblock’s reference path to the clipboard so you can paste it into another field or application.
Use Global Copy to copy changes to properties

Use Global Copy to copy changes made to a control program's trend graph properties, custom reports, or other editable properties to other controllers using the same control program.

1. On the navigation tree, right-click the controller that has the trend graph properties, custom reports, or properties you want to copy, then select Copy Properties.

2. In the Global Copy dialog box, select the embedded trends, custom trends, custom reports, or control program properties that you want to copy.

3. Select the area on the tree containing similar control programs that you may want to copy these properties to, then click Search.
   
   All instances at that level and below are listed in the expanded lower window.

4. Select or clear checkboxes as needed.

5. Do one of the following:
   
   o Select the Skip bad values checkbox to copy all values except a bad value (one that cannot be copied because you do not have the necessary privilege, a property to be copied is undefined, etc.).
   
   o Clear the checkbox to prevent any values from being copied if a bad value is found.

6. Click Apply Changes, then close the Global Copy dialog box.

Downloading system changes to device managers

If you make any of the following changes, you must download the new data from i-Vu CCN Pro Server to the device manager.

<table>
<thead>
<tr>
<th>In I-Vu CCN Pro</th>
<th>In Main Menu &gt; System Setup or in SiteBuilder</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Change or reload a control program</td>
<td>• Add a device</td>
</tr>
<tr>
<td>• Change or reload a driver</td>
<td>• Add equipment</td>
</tr>
<tr>
<td>• Change a schedule</td>
<td>• Change or reload a control program</td>
</tr>
<tr>
<td>NOTE A schedule change automatically downloads unless you clear its Automatically Download Schedules checkbox (on the schedule's Configure tab under Show Advanced).</td>
<td>• Set an object instance</td>
</tr>
<tr>
<td></td>
<td>• Change or reload a driver</td>
</tr>
<tr>
<td></td>
<td>• Assign or unassign equipment</td>
</tr>
</tbody>
</table>

Any property change you make automatically downloads while i-Vu CCN Pro is communicating with equipment. If the download fails, the Failures list on the Download page displays the equipment. See If an item fails to download (page 33).

CAUTION If you are trending critical information, use the storetrends manual command to upload all trends from equipment to the database before doing a memory download.
To perform downloads from a Properties page or a microblock pop-up

Downloading from a Properties page downloads memory, parameters, and schedules for the selected equipment.

1. Go to a Properties page or microblock pop-up for the equipment.
2. Click the Download button below the red download message at the top of the page.

   NOTE The Download button is visible only if a download is required.

If an item fails to download

All items that fail to download appear in the Failures list on the Download page. To attempt the download again:

1. Select the item from the Failures list.
2. Review the reason for the failure at the bottom of the page.
3. Correct the problem.
4. Click Add to add the failed item to the Download Items list.
5. Click OK.
6. Select the item(s) in the Download Items list.
7. Click Download Selected Items.

To resolve a mismatch

A mismatch occurs when a value in a controller does not match the value in i-Vu CCN Pro Server. You can use either of the following methods to handle mismatches in your system.

A. Select Always upload properties from controllers to i-Vu CCN Pro Server on mismatch on the Communications tab of the System Settings page to have i-Vu CCN Pro upload automatically.

B. Clear Always upload properties from controllers to i-Vu CCN Pro Server on mismatch so that you can evaluate every mismatch to determine the correct value.

If you use method B and a mismatch occurs:

1. Go to the Properties page for the equipment.
2. Click Details at the top of the page.
3. Do one of the following:
   - Click Upload to upload parameters from the controller to i-Vu CCN Pro Server.
   - Click Download to download parameters from i-Vu CCN Pro Server to the controller.

Setpoints

Use setpoints to set temperature values that control the HVAC equipment. i-Vu CCN Pro displays green when a zone is within the desired temperature range determined by the heating and cooling setpoints.

- Programmed setpoints are set and changed by operators.
Effective setpoints reflect the impact of other system conditions on the programmed setpoints, such as setpoint adjustments, and hysteresis. Effective setpoints control the equipment.

To change programmed setpoints:

1. Navigate to a setpoint control in one of the following places:
   - The Space Temperature Setpoints section of the Equipment tab of a Properties page
   - A Graphics page
2. On a programmed setpoint bar, click and drag the segment or the gap between segments you want to change.
3. Type new values in the Heating and Cooling fields.
   TIP You can click and drag a segment or a gap between segments to change setpoints.
4. Click OK.
Operator access

Privileges control the parts of a i-Vu CCN Pro system an operator can access. Privileges also control what an operator can do and what he can change.

To set up operator access to your system:

1. Log into i-Vu CCN Pro as the Administrator. See Operators and operator groups (page 39).
2. Define privilege sets by job function. See Privilege sets (page 38).
3. Enter each operator in the system by assigning him privilege sets and entering settings that apply only to him. If you need to assign the same privilege set to multiple operators, you can create an operator group and assign the privilege set to the group. See Operators and operator groups (page 39).

An operator can change many of his operator settings on the My Settings page (page 41).

To access i-Vu CCN Pro, an operator must enter his user name and password. This password requirement can be enhanced by using i-Vu CCN Pro’s configurable password policy.

Restricting operator access

To restrict access to your system, you can:

- Restrict an operator’s privileges
- Use location-dependent operator access
- Change a microblock’s Editing Privilege from Preset to a specific privilege. The microblock’s properties will be editable only by an operator that has that privilege.

**CAUTION** Each microblock property has a default Editing Privilege (represented by the Preset option) that is appropriate for that property. Changing Preset to a specific privilege changes every property in the microblock to the same privilege which may produce undesirable results.

### Privileges

| This Access privilege... | allows an operator to access (but not edit)...
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Access System Tree</td>
<td>the System Setup page.</td>
</tr>
<tr>
<td>Access Equipment Items</td>
<td>tables in the navigation tree or Properties pages.</td>
</tr>
<tr>
<td>Access Scheduling Groups</td>
<td>in the navigation tree.</td>
</tr>
<tr>
<td>Access System Options Items</td>
<td>under Main Menu.</td>
</tr>
<tr>
<td>Access Alarms</td>
<td>alarms.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This Parameter privilege...</th>
<th>allows an operator to edit properties such as...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Setpoint Parameters</td>
<td>occupied and unoccupied heating and cooling setpoints.</td>
</tr>
<tr>
<td>Edit Tuning Parameters</td>
<td>gains, limits, trip points, hysteresis, color bandwidths, design temperatures, and optimal start/stop.</td>
</tr>
</tbody>
</table>
### Operator access

<table>
<thead>
<tr>
<th><strong>This Parameter privilege...</strong></th>
<th><strong>allows an operator to edit properties such as...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Manual Override Parameters</td>
<td>locks on input, output, and network points.</td>
</tr>
<tr>
<td>Edit Point Setup Parameters</td>
<td>point number, type, range, and network source and destination.</td>
</tr>
<tr>
<td>Edit Restricted Parameters</td>
<td>properties the installer restricted with this privilege.</td>
</tr>
<tr>
<td>Edit Category Assignments</td>
<td>Alarm, Graphic, Trend, and Report category assignments.</td>
</tr>
<tr>
<td>Edit History Value Reset</td>
<td>elapsed active time and history resets, and runtime hours.</td>
</tr>
<tr>
<td>Edit Trend Parameters</td>
<td>enable trend logging, log intervals, and log start/stop times.</td>
</tr>
<tr>
<td>Edit Calibration Parameters</td>
<td>point calibration offsets.</td>
</tr>
<tr>
<td>Edit Hardware Device Parameters</td>
<td>module driver properties.</td>
</tr>
<tr>
<td>Edit Critical Configuration</td>
<td>critical properties the installer protected with this privilege.</td>
</tr>
<tr>
<td>Edit Area Name</td>
<td>area display names.</td>
</tr>
<tr>
<td>Edit Equipment Name</td>
<td>equipment display names.</td>
</tr>
<tr>
<td>Edit Alarm Configuration</td>
<td>enabling/disabling alarms and editing alarm messages, actions, categories, and templates.</td>
</tr>
<tr>
<td>Edit Status Display Tables</td>
<td>tables available under Status.</td>
</tr>
<tr>
<td>Edit Maintenance Tables</td>
<td>tables available under Maintenance.</td>
</tr>
<tr>
<td>Edit User Config Tables</td>
<td>tables available under User Config.</td>
</tr>
<tr>
<td>Edit Service Config Tables</td>
<td>tables available under Service Config.</td>
</tr>
<tr>
<td>Edit Setpoint Tables</td>
<td>tables available under Setpoint.</td>
</tr>
<tr>
<td>Edit Time Schedule data Tables</td>
<td>tables available under Time Schedule.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>This Functional privilege...</strong></th>
<th><strong>allows an operator to...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Alarm Messages and Actions</td>
<td>add, edit, and delete alarm messages and actions.</td>
</tr>
<tr>
<td>Maintain System Parameters</td>
<td>edit all properties on the System Settings page.</td>
</tr>
<tr>
<td>Maintain Schedules</td>
<td>add, edit, delete, and download schedules.</td>
</tr>
<tr>
<td>Maintain Schedule Group Members</td>
<td>add, edit, and delete schedule groups.</td>
</tr>
<tr>
<td>Maintain Categories</td>
<td>add, edit, and delete categories.</td>
</tr>
<tr>
<td>Maintain Trends Display and Print Setup</td>
<td>edit Trends Display Setup and Trends Print Setup on Main Menu &gt; System Options tree.</td>
</tr>
<tr>
<td>Acknowledge Non-Critical Alarms</td>
<td>acknowledge all non-critical alarms.</td>
</tr>
<tr>
<td>Acknowledge Critical Alarms</td>
<td>acknowledge all critical alarms.</td>
</tr>
</tbody>
</table>
### Operator access

<table>
<thead>
<tr>
<th>This Functional privilege...</th>
<th>allows an operator to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force Normal Non-Critical Alarms</td>
<td>force non-critical alarms to return to normal.</td>
</tr>
<tr>
<td>Force Normal Critical Alarms</td>
<td>force critical alarms to return to normal.</td>
</tr>
<tr>
<td>Delete Non-Critical Alarms</td>
<td>delete non-critical alarms.</td>
</tr>
<tr>
<td>Delete Critical Alarms</td>
<td>delete critical alarms.</td>
</tr>
<tr>
<td>Execute Audit Log Report</td>
<td>run the Audit Log Report.</td>
</tr>
<tr>
<td>Download Devices</td>
<td>mark equipment for download and initiate a download.</td>
</tr>
<tr>
<td>System Shutdown</td>
<td>issue the Shutdown manual command that shuts down i-Vu CCN Pro Server.</td>
</tr>
</tbody>
</table>
| Engineer System | • log in and make database changes in SiteBuilder.  
| | • use the copy, notify, reload, and revert manual commands.  
| | • access the navigation tree right-click menus in i-Vu CCN Pro.  
| | • Add text in the **Notes** field on an equipment's Properties page. |
| Access Commissioning Tools | access:  
| | • Equipment Checkout  
| | • Airflow Configuration  
| | • Trend, Report, and Graphic categories that require this privilege  
| | • Discovery tool |
| Maintain Graphs and Reports | add, edit, and delete trend graphs and reports. |
| Maintain Connections | edit Connections page properties. |
| Remote File Management | access files using a WebDAV utility. |
| Remote Data Access-SOAP | retrieve i-Vu CCN Pro data through an Enterprise Data Exchange (SOAP) application. |
| Do not audit changes made using SOAP (Web services) | not have his SOAP (Web services) changes recorded in the Audit Log. |
| Manual Commands/Console Operations | access the manual command dialog box and issue basic manual commands. |
| Manual Commands/File IO | execute manual commands that access the server's file system. |
| Manual Commands/Adv Network | execute manual commands that directly access network communications. |
| Manual Commands/Unrestricted | execute manual commands that bypass all safeguards and may cause unpredictable results if used incorrectly. |

### To create a custom privilege

You can assign a privilege to a Graphic, Property, Trend, or Report category so that only operators with that privilege can access the category. You assign a category privilege on the page where you create or edit categories.

If all the other privileges are too widely used to accomplish the results you want, you can assign one of the five Access User Category privileges to the operator(s) and category.
Operator access

For example, your system has two graphics categories, HVAC and Lighting/Security. You want HVAC technicians to see only the HVAC graphics and security personnel to see only the Lighting/Security graphics. To do this:

<table>
<thead>
<tr>
<th>Assign...</th>
<th>To...</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access User Category 1</td>
<td>HVAC graphics category and HVAC technicians only</td>
<td>The security personnel cannot see the HVAC graphics because they do not have Access User Category 1.</td>
</tr>
<tr>
<td>Access User Category 2</td>
<td>Lighting/Security Graphics category and Security personnel only</td>
<td>The HVAC technicians cannot see the Lighting/Security graphics because they do not have Access User Category 2.</td>
</tr>
</tbody>
</table>

Privilege sets

A privilege set is a group of one or more privileges (page 35). The Administrator creates privilege sets and assigns them to operators and operator groups.

Admin privilege set

i-Vu CCN Pro has a default privilege set called Admin that includes most of the privileges. Only an operator with the Admin privilege set can perform the following functions that are not controlled by privileges:

- Add, edit, and delete operators, operator groups, and privilege sets.
- Update i-Vu CCN Pro Server with service packs and patches.
- Register the i-Vu CCN Pro software. See To register your i-Vu CCN Pro software.
- Enable and set up advanced security features such as location-dependent operator access and a configurable password policy (if your system includes these optional features).

NOTE You cannot delete your own Admin privilege.

To add or edit a privilege set

1. Click Main Menu, then select System Options.
2. Click Security tab and select Privilege Sets.
3. Click Add to create a new privilege set, or select a privilege set to edit.
4. Type the Name and Reference Name for the privilege set.
5. Select the checkbox beside each privilege you want to include in the privilege set.
6. Click OK.

CAUTION Include all required access privileges in a privilege set. For example, if you add Acknowledge Non-Critical Alarms to a privilege set, also add Access Alarms to that privilege set.

TIP To create a privilege set that is similar to an existing set, select the existing set, then click Add. The privileges that are initially selected are identical to those of the existing set.
To delete a privilege set

1. Click the menu button , then select System Options.
2. Select Privilege Sets in the tree.
3. Select the privilege set to be deleted.
4. Click Delete.
5. Click OK.
6. Click OK again.

Operators and operator groups

The Administrator (see "Default operators" below) sets up each operator in i-Vu CCN Pro by entering the necessary settings and assigning one or more privilege sets to the operator.

Operator groups give you the ability to assign privilege sets to a group of operators instead of the individual operators. Operator groups are useful if you have multiple operators who need the same privilege set or you have positions with high turnover rates.

You can assign an operator to a group when you enter the operator or when you create the operator group.

**NOTE** When using hierarchical servers, you must create identical operators on each server in order to navigate across servers.

Default operators

**CAUTION** i-Vu CCN Pro is installed with the following default operators:

<table>
<thead>
<tr>
<th>Operator...</th>
<th>Has ...</th>
<th>To log in...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>The Admin privilege set (page 38) that contains almost all privileges</td>
<td>Type Administrator in the Name field, then click Log In.</td>
</tr>
<tr>
<td>Anonymous</td>
<td>The Standard privilege set that contains only viewing privileges</td>
<td>Click Log In.</td>
</tr>
</tbody>
</table>

To ensure system security, log in as the Administrator, then do one of the following:
- Assign the Admin privilege set to another operator, then delete the Administrator operator
- Assign a password to the Administrator operator

**CAUTION** Passwords can be forgotten. To ensure access to the administrative functions of i-Vu CCN Pro, assign the Admin privilege set to at least two operators.

If you want to prevent Anonymous access to your system, delete the Anonymous operator.
Operator access

To add or edit an operator

1. Click Main Menu button , then select System Options.
2. On the tree, click Operators.
3. Click Add to enter a new operator, or select an operator to edit his settings.
4. Enter information on this page as needed. The only required fields are Name and Login Name. See table below.
5. Click OK.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Login Name</td>
<td>The name the operator must type to log in to the system. This name must be unique within the system.</td>
</tr>
<tr>
<td>Change password</td>
<td>Enable this field, then type the current and new passwords.</td>
</tr>
<tr>
<td><strong>NOTE</strong> An operator can change his password on the <em>My Settings</em> page (page 41).</td>
<td></td>
</tr>
<tr>
<td>Force User to Change Password at login?</td>
<td>Forces the operator to change his password immediately after his next login.</td>
</tr>
<tr>
<td><strong>NOTE</strong> Use this field with the Change Password field to create a temporary password that the operator must change after his next login.</td>
<td></td>
</tr>
<tr>
<td>Exempt From Password Policy</td>
<td>If the advanced password policy is enabled in System Options&gt;System Settings on the Security tab, select this option if you do not want the policy to apply to this operator.</td>
</tr>
<tr>
<td>Logoff options</td>
<td>If the automatic logoff feature is enabled in System Options&gt;System Settings on the Security tab, select one of the 3 logoff options.</td>
</tr>
<tr>
<td>Personal Information</td>
<td>You can enter contact information for this operator.</td>
</tr>
<tr>
<td><strong>NOTE</strong> An operator can enter contact information on the <em>System Options</em>&gt;My Settings page (page 41).</td>
<td></td>
</tr>
<tr>
<td>Starting Location and Starting Page</td>
<td>The location and page i-Vu CCN Pro will display after the operator logs in.</td>
</tr>
<tr>
<td>System-wide Privilege Sets</td>
<td>To assign a privilege set to the operator, select the privilege set's checkbox.</td>
</tr>
<tr>
<td><strong>NOTES</strong></td>
<td>Click Show current privileges only to see only the selected privilege sets.</td>
</tr>
<tr>
<td>• Click Show current privileges only</td>
<td>A grayed out privilege set with a group name beside it indicates the operator is inheriting that privilege set from the group.</td>
</tr>
<tr>
<td>Groups</td>
<td>To add the operator to a group, select the group's checkbox.</td>
</tr>
<tr>
<td><strong>NOTE</strong> Click Show current privileges only to see only the selected groups.</td>
<td></td>
</tr>
</tbody>
</table>

To delete an operator

1. Click Main Menu button , then select System Options.
2. On the tree, click Operators.
3. Select the operator.
4. Click Delete.
5. Click OK.
To add or edit an operator group

1. Click **Main Menu** button, then select **System Options**.
2. On the tree, click **Operator Groups**.
3. Click **Add** to create a new operator group, or select an operator group to edit it.
4. Type the **Display Name** and **Reference Name** for the operator group.
5. Under **Members**, select the operators and/or groups that you want to add to the new group.
6. Under **Privilege Sets**, select the privilege sets that you want to assign to the new group.
7. Click **OK**.

**TIP** i-Vu CCN Pro has a permanent default group called **Everybody** that every operator is automatically a member of. You can assign privilege sets to this group.

To delete an operator group

1. Click **Main Menu** button, then select **System Options**.
2. On the tree, click **Operator Groups**.
3. Select the operator group.
4. Click **Delete**.
5. Click **OK**.

**CAUTION** When you delete an operator group, its individual members lose the privilege sets that were assigned to the group.

My Settings

To change your settings:

1. Click **Main Menu** then select **System Options > My Settings** tab.
2. See table below for explanation of settings.
3. Click **OK** or **Apply**.
4. Changes become effective when operator logs in again.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Login</td>
<td>To change your password. Limit is 40 characters of any type.</td>
</tr>
</tbody>
</table>
Operator access

<table>
<thead>
<tr>
<th><strong>Starting Location and Starting Page</strong></th>
<th>The location and page i-Vu CCN Pro will display after you log in.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatically collapse trees</strong></td>
<td>Expands only one tree branch at a time.</td>
</tr>
<tr>
<td><strong>Non-critical alarms</strong></td>
<td>The system audibly notifies you when one of the selected alarms is received.</td>
</tr>
<tr>
<td>and</td>
<td></td>
</tr>
<tr>
<td><strong>Critical alarms</strong></td>
<td></td>
</tr>
</tbody>
</table>

If you want to use a custom sound file (.au or .wav):

- Put the file in the `webroot\common\vl5\sounds` folder.
- In the Sound File field, replace `warning_bell.au` or `critical_bell.au` with the name of your sound file.

**NOTE** You can put your sound file anywhere under the i-Vu CCN Pro.x folder, but be sure to change the path in the Sound File field.

**Contact Info tab**

Fill in personal information.
Monitor and control equipment

You can monitor and control equipment from:

- The equipment's points shown under Properties (page 31)
- The equipment graphic (page 28) (if the device has an equipment graphic)
- The equipment's CCN tables (page 43)

If a point's value is editable, changing the value sends the new value only to the device.

If the point has a Force checkbox, you can force the value to a new value that you specify. The new value is sent to the device. Forced values are indicated in the graphics by a dashed yellow line.

To view an equipment's CCN tables

1. In the navigation tree, select the equipment.
2. Click next to the equipment to expand it.
3. Select the table you want to view.

To force a CCN point value

You can force certain editable point values to a specified setting:

- In the equipment's tables - to see tables, click next to the equipment
- From a graphic - hold down Ctrl key on your keyboard and, using your mouse, click on the point value on the graphic. A Properties dialog will be displayed.

Forced values are indicated by a dashed yellow line on graphics.

1. Select the Force checkbox.
2. Type the value you want to send to the device.
3. Click OK or Apply.
Monitor and control equipment

Manage setpoints

The Setpoint area, as shown on a standard equipment graphic, indicates the base setpoint values (Occupied High/Low, Unoccupied High/Low). i-Vu CCN Pro reads these values back periodically, typically within 10 seconds. The timing can vary based on bus traffic, the number of controllers in the database, and several other variables. Setpoints that are changed in the field via another user interface (Network Service Tool, ComfortVIEW, etc.) are displayed in i-Vu CCN Pro as soon as they are detected.

You can, at any time, change the setpoints from i-Vu CCN Pro graphics by using the slider or by entering numeric values directly. Updated setpoints are transmitted to the controller when you Accept the changes. Setpoints can also be changed via the setpoint tables that are discovered when a controller is scanned.

The various color bars are used to indicate adherence to or deviation from the setpoint. You can change the current default settings for setpoint deviation.

<table>
<thead>
<tr>
<th>Color</th>
<th>Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Green</strong></td>
<td>Temperature is within the Occupied Low and High Setpoint</td>
</tr>
<tr>
<td><strong>Grey</strong></td>
<td>Temperature is within the Unoccupied Low and High Setpoint</td>
</tr>
<tr>
<td><strong>Light Blue</strong></td>
<td>Temperature is less than 2°F below the Occupied Low Setpoint</td>
</tr>
<tr>
<td><strong>Dark Blue</strong></td>
<td>Temperature is more than 2°F below the effective Low Setpoint but less than 4°F below the effective Low Setpoint</td>
</tr>
<tr>
<td><strong>Yellow</strong></td>
<td>Temperature is less than 2°F above the effective High Setpoint</td>
</tr>
<tr>
<td><strong>Orange</strong></td>
<td>Temperature is more than 2°F above the effective High Setpoint but less than 4°F above the effective High Setpoint</td>
</tr>
<tr>
<td><strong>Red</strong></td>
<td>Temperature is more than 4°F above or below the effective setpoints</td>
</tr>
</tbody>
</table>
Monitor and control equipment

Setpoints

- **Programmed setpoints** are set and changed by operators.
- **Effective setpoints** reflect the impact of other system conditions on the programmed setpoints, such as setpoint adjustments, and hysteresis. Effective setpoints control the equipment.

To change programmed setpoints:

1. Navigate to a setpoint control in one of the following places:
   - The **Space Temperature Setpoints** section of the **Equipment** tab of a **Properties** page
   - A **Graphics** page
2. On a programmed setpoint bar, click and drag the segment or the gap between segments you want to change.
3. Type new values in the **Heating** and **Cooling** fields.
   - **TIP** You can click and drag a segment or a gap between segments to change setpoints.
4. Click **OK**.

To display or change driver or set driver properties

**NOTE** Only the **Installer** role has access to the following.
To display driver
1. Right-click an equipment in the navigation tree.
2. Select **Driver Properties** from the drop-down menu.

To change driver
1. Right-click an equipment in the navigation tree.
2. Select **Driver Properties** from the drop-down menu.
3. Right-click **Driver** in navigation tree and select **Configure**.
4. Browse to desired driver and click **Add**.

To set driver properties
1. Right-click an equipment in the navigation tree.
2. Select **Driver Properties** from the drop-down menu.
3. Expand **Protocols** and select desired protocol.
4. Select **Port, Timing, and Protocol Configuration**.
   **NOTE** Refer to the Integration Guide documentation for your specific protocol for detailed instructions.

i-Vu CCN Pro CCN schedules

There are two types of CCN schedules:

- 1 – 64 are local schedules that reside within the equipment
- 65 – 99 are network or global schedules, which are sent over a CCN network and received by controllers that contain network schedules

i-Vu CCN Pro supports both local and global schedules.

Most CCN equipment is shipped with the default schedule of **64.** See exceptions below.

<table>
<thead>
<tr>
<th>Equipment</th>
<th>i-Vu CCN Pro's default schedule number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comfort Controller/UC/Expansion Controllers</td>
<td>0</td>
</tr>
<tr>
<td>Any controllers using a custom equipment file (*.equip) created with ApplicationBuilder</td>
<td>0</td>
</tr>
<tr>
<td>Gen III VVT, 48/50EJ (Conquest), FSM, CSM</td>
<td>1</td>
</tr>
<tr>
<td>All PICs</td>
<td>64</td>
</tr>
</tbody>
</table>

**CAUTION!** Confirm the actual schedule numbers that are in use in the controller, as they may have been changed from their programmed default settings.

In order to utilize i-Vu CCN Pro schedules, the i-Vu CCN Pro schedule number must match the CCN schedule number at the controller. This can be set in i-Vu CCN Pro by selecting the equipment in the navigation tree.
Monitor and control equipment

and clicking Schedules > CCN tab. It is also accessible at the area or site level.

**NOTE** To reduce start-up labor on a retrofit project, existing network schedules can be used by i-Vu CCN Pro. However, switching to local schedules allows for schedule retention after a power failure and local schedule maintenance tables.

If a controller uses a different schedule number, complete the following steps.

**CAUTION!** Failure to follow these steps may result in unexpected equipment operation.

1. On the navigation tree, select the controller.
2. Click the Schedules page, then CCN tab.
3. Adjust the following fields:
   - **Schedule number** - enter the CCN schedule number in use at the controller.
   - **Override time (optional)** - enter the number of minutes of the desired override and verify that the controller override time is greater than or equal to this number.
   - **Override group (page 48)** - enter the number of the group, if you have established one.

**To view schedules**

1. Select a navigation tree item (site, area, or equipment).
2. Click Schedules page > View tab.
3. Optional: Click an Effective bar to view all the schedules that contribute to the resulting schedule.

**NOTES**
- When multiple schedules affect a single area or piece of equipment, i-Vu CCN Pro sorts the schedules by priority—the higher the priority, the closer the schedule is to the Effective bar. You set a schedule's priority when you add a schedule.
- You can also view schedules on the following detailed, printable schedule reports. These reports are accessible from the Schedules page > Reports tab or from the Reports button drop-down list.

<table>
<thead>
<tr>
<th>This report...</th>
<th>allows you to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schedule Instances</td>
<td>Find every schedule with its location that is entered at and below a selected tree item. This report can help you discover newly added and conflicting schedules.</td>
</tr>
<tr>
<td>Effective Schedules</td>
<td>View all equipment that may be scheduled and the net result of all schedules in effect for a selected date and time.</td>
</tr>
</tbody>
</table>

**Create and modify an i-Vu schedule**

You can define schedules that automatically keep occupants comfortable and equipment running efficiently.

In the navigation tree, you can apply a schedule to a single tree item or to a group.

- When you apply a schedule to a single equipment, the schedule affects equipment at and below the area or equipment where the schedule was added.
- When you apply a schedule to an area, the schedule affects all pieces of equipment in that area.
- When you apply a schedule to a schedule group, the schedule affects all pieces of equipment in the group.
To create a group override CCN time schedule

When a group of controllers is assigned a matching Override Group number, an override from a single controller in the group can cause all of the controllers in the Override group to be to overridden. The override duration is set in i-Vu CCN Pro, even though i-Vu CCN Pro supports push-button override.

In order for a controller to initiate a remote override request:

- Set the actual duration of the override in i-Vu CCN Pro.
- Do not set the controller’s local override hours to 0.
- The controller's setting must be greater-than or equal-to the i-Vu CCN Pro override duration.

NOTES

- It is recommended that the local override value at the controller be set to its maximum possible setting.
- Equipment activation, when using PBOR's, is normally instantaneous, but varying delays are possible.
- Do not press the button a second time, as this could cause the override to be cancelled.

In order to have a specific controller initiate a group override, the override duration in its local database must not be zero.

1. On the navigation tree, select the equipment or area that you want to schedule for a group override.
2. Click the Schedules page, then CCN tab.
3. Enter the number of minutes in Override Time.
   NOTE The override setting in the controller must not be set to 0.
4. Assign a number to Override group.

To apply a schedule to single equipment or to all equipment in an area

Schedules in i-Vu CCN Pro are typically based on zone occupancy.

1. On the navigation tree, select the equipment you want to schedule.
   NOTE To schedule all equipment in a specified area, select the area you want.
2. Click the Schedules page > Configure tab.
3. Click Add.
4. Select a Priority. (Normal is low priority; Holiday is medium; Override is high.)
5. Select a Type. See table below.
6. Type a schedule name in the Description field.
7. Enter desired values in the fields below Description.
8. Change the default time segment (shown as a colored bar) for the schedule by doing one of the following:
   - Click the segment, then type Start and End times in the fields above the segment.
   - Click and drag either end of the segment or the entire segment.

Optional: Click Show Advanced below the schedule bar to add one or more separate segments to the schedule.
Monitor and control equipment

9. Click OK.

<table>
<thead>
<tr>
<th>Type</th>
<th>Schedule runs</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weekly</td>
<td>Every week on the specified days</td>
</tr>
<tr>
<td>Date</td>
<td>On a single, specified date</td>
</tr>
<tr>
<td>Date Range</td>
<td>Between two specified dates</td>
</tr>
<tr>
<td>Date List</td>
<td>On multiple, specified dates</td>
</tr>
<tr>
<td>Wildcard</td>
<td>According to a repeating pattern (For example, the second Tuesday of every month)</td>
</tr>
<tr>
<td>Continuous</td>
<td>Continuously between specified times on two separate dates</td>
</tr>
<tr>
<td>Dated Weekly</td>
<td>Weekly between a start date and an end date (For example, the summer break in the school year)</td>
</tr>
</tbody>
</table>

To apply a schedule to a group of equipment

You must create a group, then add members (equipment) to the group before you can apply a schedule.

1. In the **User** view, on the navigation tree, select **Scheduling Groups**.
2. Click **Add**.
3. Type a name for the new schedule group in the **Name** field.
   Optional: Change the default **Reference name**.
4. Click **OK**.
5. On the tree, click the plus sign (+) next to **Scheduling Groups**.
6. In the navigation pane, select the group you want to add items to.
7. Click the **Members** button at the top of the action pane.
8. On the selection tree at the right, select a piece of equipment.
9. Click **Add**.
   TIP Use the **Raise** and **Lower** buttons to reorder items in the group list. Changing the order is for your viewing convenience and does not affect the system.
10. Click **OK**.
11. Click **Schedules**, then **Configure**.

Using schedule categories

Occupancy is i-Vu CCN Pro’s only default schedule category. Occupancy is a binary schedule category that allows a zone or piece of equipment to be defined as On when a space is occupied and Off when it is unoccupied.

You can add custom schedule categories to handle other conditions if the equipment’s control program includes a Time Clock microblock. For example, you can add a multi-state schedule category to control lights:
Monitor and control equipment

on during work hours, off at night, and dim for janitorial work.

**To add a custom schedule category in i-Vu CCN Pro**

**TIP** Study the default Occupancy category to understand the various properties you need to set when adding a new schedule category.

**PREREQUISITES**

1. On the i-Vu CCN Pro **System Options** page tree, click the plus sign (+) to the left of the **Categories** folder, then click **Schedule**.
2. Click **Add Category**.
3. Enter values or add items for the fields in each section of the page. See table below.

**NOTE** The fields that you see depend on selections you made in previous sections. **Category Details** fields.
4. Click **OK**.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Name</td>
<td>Must be unique in the database, be lowercase, and not contain any spaces.</td>
</tr>
<tr>
<td>Schedule Category Description</td>
<td>The name used in the i-Vu CCN Pro interface</td>
</tr>
<tr>
<td>Allowed Type</td>
<td>Replace <strong>Undefined</strong> with one of the following:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Boolean</strong>: binary (on/off, true/false) condition</td>
</tr>
<tr>
<td></td>
<td>• <strong>Multi State</strong>: list of integer-defined states. For example, 1=off, 2=on, 3=dim</td>
</tr>
<tr>
<td>Default Value</td>
<td>Displays what schedule value is in effect for times not specified by the schedule. To set this value, in the <strong>Allowed Values</strong> table, select the value that you want to use as the default, then click the <strong>Make Default</strong> <strong>OK</strong> button.</td>
</tr>
<tr>
<td>Allowed Values</td>
<td>If you selected <strong>Boolean</strong> above, select <strong>True Value</strong> or <strong>False Value</strong>.</td>
</tr>
<tr>
<td></td>
<td>If you selected <strong>Multi State</strong>, click the <strong>Add Value</strong> button to create each schedule state.</td>
</tr>
<tr>
<td>Allowed Value Description</td>
<td>The name used in the i-Vu CCN Pro interface.</td>
</tr>
</tbody>
</table>
| Pattern                       | Type none, dark, or 
|                               | /_common/1v15/graphics/patterns/xxx.gif, where xxx.gif is any .gif file in the 
|                               | webroot\_common\MS\graphics\patterns folder.                         |
| Priority Description          | The name used in the i-Vu CCN Pro interface.                           |
Monitor and control equipment

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index</td>
<td>Represents this priority’s relative level of importance within this schedule category. i-Vu CCN Pro automatically assigns the priority</td>
</tr>
<tr>
<td></td>
<td>index, which is zero for the first priority level. The higher the index value, the higher the priority of the schedule type relative to other</td>
</tr>
<tr>
<td></td>
<td>schedules. BACnet limits the number of priority indices to sixteen.</td>
</tr>
<tr>
<td>Color</td>
<td>Color of the schedule bar on the Schedules page.</td>
</tr>
<tr>
<td>Schedule Types</td>
<td>The Weekly type is available for Index 0 only. The Allow Wildcards and Partial Day options affect all selected schedule types.</td>
</tr>
<tr>
<td>Default Schedule</td>
<td>The default schedule used when this category is selected. Create the schedule as you would create any other schedule.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> Add segments for each state until every hour in the 24-hour schedule is covered by a segment.</td>
</tr>
</tbody>
</table>

**To view, edit, or delete a schedule category**

1. Click **Main Menu** then select **System Options**.
2. Click the plus sign (+) to the left of the **Categories** folder, then click **Schedule**.
3. In the **Schedule Categories** table, select the category you want to edit or delete.
4. Edit the fields in the **Category Details** section or click **Delete**.
5. Click **OK**.

**Graphics pages**

You can view and adjust your equipment from Graphics pages and change the setpoints for occupied and unoccupied hours.

**NOTES**

- Ctrl-click or right-click a value and select **Microblock Properties** from the drop-down menu to view and change properties in the popup.
- Alt-click or right-click a value and select **Global Modify** (page 21) from the drop-down menu to view and change the property in other equipment.
- Forced values are indicated by a yellow dashed line.
- If a graphic is larger than the action pane, right-click the graphic and select **Scale to Fit** to see the whole graphic. Right-click and select **Scale to 100%** to return the graphic to its original size.

When using **Scale to 100%**, hold down Ctrl while rolling the mouse wheel to zoom in and out on a graphic.
To edit a graphic from i-Vu CCN Pro in ViewBuilder

**NOTE** Only the Installer role has access to the following.

To edit a graphic from i-Vu CCN Pro in ViewBuilder:

1. Select the piece of equipment in i-Vu CCN Pro navigation tree.
2. Right click on the equipment name and select **Configure**.
3. Click **Edit** button under **Views**.
4. Click **Save** to desktop or other appropriate folder.
5. Open ViewBuilder.
6. Select **File > Open**. Browse to your saved graphic and click to open.
7. Edit as desired.
8. Save with a new name - the original system name is locked and cannot be used for an edited graphic.

**NOTE** Names are case sensitive and should not have spaces and/or special characters.

To upload your graphic to i-Vu CCN Pro

1. Login to i-Vu CCN Pro. You must have Installer role to upload graphics.
2. Select the area or equipment in the navigation tree.
3. Right-click and select **Configure**.
4. Click the **Add** button under **Views**.
5. Browse to your .view graphic file that you created in ViewBuilder.
6. Click **Continue**.
7. Click **Close** when message appears **File uploaded successfully.**
8. Click **Close** again. The graphic should appear on your i-Vu CCN Pro screen.

Alarms

A message is sent from an alarm source to i-Vu CCN Pro to notify you that certain conditions exist, such as a piece of equipment that has stopped running or a temperature that is too high. When i-Vu CCN Pro receives an alarm, it displays information about the alarm on the **Alarms** page. i-Vu CCN Pro can also perform alarm actions to inform personnel of the condition. An alarm source can also send a return-to-normal message when the alarm condition returns to its normal state.

Alarm sources and the alarms they generate are assigned to categories, such as HVAC Critical or HVAC Maintenance, to help you work with related alarms.

In i-Vu CCN Pro, you:

- **View, acknowledge, and delete alarms received by i-Vu CCN Pro** (page 53)
- **Set up the alarm actions that i-Vu CCN Pro performs** (page 56)
- **Set up new alarm sources to generate alarms** (page 71)
NOTE Besides the alarms that you set up, i-Vu CCN Pro has built-in system and equipment alarms.

View, acknowledge, and delete alarms

You can view, acknowledge, and delete alarms received by i-Vu CCN Pro. Alarms are hierarchical and can be applied to an area, which then affects all equipment in that area.

To view all alarms, you must be at the system level in the navigation tree.

The color of the system-wide alarms button signifies one of the following conditions:

- **Red**—Critical alarms need to be acknowledged.
- **Yellow**—Non-critical alarms need to be acknowledged.
- **Grey**—No alarms need to be acknowledged.

Click the system-wide alarms button to view all alarms in the system.

You must acknowledge alarms that have been set up to require acknowledgement. Right-click alarm message to print, acknowledge, or delete.

i-Vu CCN Pro closes an alarm when all of the following have occurred:

- You acknowledge the alarm (if required)
- i-Vu CCN Pro receives a return-to-normal (if required)
- i-Vu CCN Pro performs all alarm actions

To save alarm information before deleting, select **Alarms > Reports** tab > **Alarms** > click **Run** button.

To view alarms in i-Vu CCN Pro

1. On the navigation tree, select the system level, an area, or a piece of equipment.
2. Click **Alarms**, then select the **View** tab.
3. Select the alarm categories that you want to view. CTRL+click to select multiple categories, or select the **Select All** checkbox.

   The alarms list displays all alarms received for the selected location and below. See table below.

4. Double-click an alarm to see more information. Double-click again to hide this information. Right-click to print, acknowledge or delete.

   **NOTE** This information includes a path to the alarm source.
Monitor and control equipment

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>View By</td>
<td>Select one of the following system options to sort the alarms list:</td>
</tr>
<tr>
<td>Date</td>
<td>Displays all alarms based on the time the alarm was generated.</td>
</tr>
<tr>
<td>To Do</td>
<td>Displays only alarms that are waiting on one or more actions to complete before they are closed.</td>
</tr>
<tr>
<td>Incident Group</td>
<td>Groups the alarms in an alarm incident group with a bracket to the left of the icons.</td>
</tr>
<tr>
<td>Alarm incident group</td>
<td>All alarms related to a particular incident. For example, an alarm and its return-to-normal form an alarm incident group.</td>
</tr>
</tbody>
</table>

Status table
Gives the status of alarms at the current location (Here) and in the entire system (Total). This table shows the number of alarms that need a return-to-normal, need to be acknowledged, or are closed.

Alarm icon
Indicates the alarm category.

- Critical alarms: The category icon plus . For example, ![Critical Alarm Icon]
- Maintenance alarms: The category icon plus . For example, ![Maintenance Alarm Icon]

Occurred
The date and time the alarm was generated.

ToDo
*Acknowledge* indicates the alarm needs to be acknowledged.
*Waiting for normal* indicates the alarm requires a return-to-normal. A checkmark indicates the alarm is closed.

Alarm Report
The alarm message.
Monitor and control equipment

### Field Notes

<table>
<thead>
<tr>
<th>Navigation buttons</th>
<th>Use these buttons to move through the alarm list.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Navigation Buttons" /></td>
</tr>
<tr>
<td></td>
<td>To the end of the list</td>
</tr>
</tbody>
</table>

### Additional Actions

You can:

- acknowledge or delete multiple alarms simultaneously
- search for an alarm generated on a particular date and time

### NOTE

Alarms generated by i-Vu CCN Pro appear at the system level.

---

**To acknowledge alarms**

**To acknowledge a single alarm:**

1. On the Alarms page, select the View tab.
2. Select an alarm that shows Acknowledge in the To Do column.
3. Click the Acknowledge button beneath the list.

**To acknowledge all alarms in the selected categories:**

1. On the Alarms page, select the View tab.
2. Click Additional Actions.
3. Click All under Acknowledge alarms in selected categories.

   **TIP** Acknowledging many alarms simultaneously can take a long time. Acknowledge alarms as they occur to avoid long waits.

---

**To delete alarms**

**To delete a single alarm:**

1. On the Alarms page, select the View tab.
2. Select an alarm.
3. Click Delete.

**To delete multiple alarms in the selected categories:**

1. On the Alarms page, select the View tab.
2. Click Additional Actions button.
3. Click the appropriate button under Delete alarms in selected categories.
Monitor and control equipment

- Closed Incidents deletes all closed incident groups. An incident group is considered closed when all alarms in the group are closed.
- All System deletes all system alarms.
- All deletes all alarms at the selected location and below.

**NOTE**
- To have i-Vu CCN Pro automatically delete alarm incident groups a specified number of days after the groups close, select this option on the Scheduled Tasks tab in System Options > System Settings.
- Also on the Scheduled Tasks tab in System Settings, you can set i-Vu CCN Pro to archive alarm information to a text file as alarms are deleted.
- An alarm source may be set up to generate an alarm and a return-to-normal. If an alarm occurs but i-Vu CCN Pro never receives the return-to-normal, you can click Force so that i-Vu CCN Pro can close the alarm. Force has no affect on the alarm condition that generated the alarm.

**To receive audible notification of alarms**

You can set up i-Vu CCN Pro to play an audio file on your workstation when it receives a critical or non-critical alarm.

1. Click Main Menu, then select System Options > My Settings.
2. Under Preferences, select Non-critical alarms or Critical alarms to be notified of them.

When an alarm triggers the audio file to play, you can temporarily silence the sound by clicking the menu button and selecting Silence. The alarm is silenced for a period of about five minutes or until another alarm that triggers a sound is received.

**Set up alarm actions**

**Alarm Action** An action that i-Vu CCN Pro performs to notify personnel of an alarm or to record information about the alarm. You can assign alarm actions to an alarm source, a category of alarm sources, alarm sources from a certain location, or a combination of these criteria.

i-Vu CCN Pro can perform the following alarm actions:
- Alarm Popup
- Print
- Run External Program
- Send Alphanumeric Page
- Send E-Mail
- Write to File
- Send SNMP Trap
- Write Property
- Write to Database

See the following topics for a description of each alarm action.
**To assign alarm actions to alarm sources**

**To assign alarm actions to multiple alarm sources**

Although you can assign an alarm action to a single alarm source, you typically assign an action to multiple alarm sources at the area or equipment level. The alarm action applies to all instances of the alarm sources at the selected location and below. Click an action’s **Edit** button to make any changes.

To assign an alarm action to alarm sources:

1. On the navigation tree, select the area or equipment containing the alarm sources.
2. Click **Alarms**, then select the **Actions** tab.
3. Follow the 3 steps on the screen.
   
   **NOTE** Use Ctrl+click, Shift+click, or both to select multiple items.
4. Click **Add**.
5. Set up the alarm action by editing the fields on the alarm action page. See the appropriate alarm action below for field descriptions.
6. Click **OK**.

If an alarm action fails, i-Vu CCN Pro receives an alarm for the failed action.

**NOTE** Click **View Selected Sources** to view or change settings for each alarm.

**To assign an alarm action to a single alarm source**

1. On the navigation tree, select the alarm source.
2. Click **Alarms**, then select the **Actions** tab.
3. Click the drop-down arrow to select an alarm action, then click **Add**.
4. Set up the alarm action by editing the fields on the alarm action page. See the appropriate alarm action below for field descriptions.
5. Click **OK**.

**Alarm Popup**

The **Alarm Popup** alarm action pops up a message on any networked computer that is running the i-Vu CCN Pro Alarm Notification Client application.

<table>
<thead>
<tr>
<th><strong>Field</strong></th>
<th><strong>Notes</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>To Operator</strong></td>
<td>Select individual operators or operator groups who should receive alarm notification.</td>
</tr>
<tr>
<td><strong>To Group</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Generate alarm if delivery fails</strong></td>
<td>Select this checkbox to send a System Info alarm to i-Vu CCN Pro Server if the popup recipient is not currently running the Alarm Notification Client application.</td>
</tr>
<tr>
<td><strong>Message text</strong></td>
<td>Use punctuation, spaces, or returns after the entries to format the text.</td>
</tr>
<tr>
<td></td>
<td>To add live data to the text, select field codes from the Append Field Code list.</td>
</tr>
<tr>
<td><strong>Append Field Code</strong></td>
<td>Add field codes to the message text if desired.</td>
</tr>
</tbody>
</table>
Monitor and control equipment

**Run Conditions**
By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under **Perform Action** you can choose to:

- Run the alarm action only when the alarm source generates an alarm or when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *
- Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group.

*EXAMPLE:* To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a schedule group (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Occupied**.

Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Unoccupied**.

---

**Using the i-Vu CCN Pro Alarm Notification Client application**

The i-Vu CCN Pro Alarm Notification Client application must be running on each client computer that should receive popup notifications. Keep the application minimized to right side of the Windows task bar. The window will pop up with a message whenever an alarm occurs.

Select an alarm message, then click ![Button](image) to open a browser window displaying the piece of equipment that generated the alarm.

**Button** | **Notes**
--- | ---
![Open a browser window](image) | Opens a browser window that displays the equipment that generated the alarm.
![Copy the selected alarm information](image) | Copies the selected alarm information to the clipboard.
![Remove the alarm information from the alarm popup list](image) | Removes the alarm information from the alarm popup list. Removing items from this list has no effect on the alarms list in i-Vu CCN Pro.
Monitor and control equipment

### Button Notes

- **View information about the server connection.**

### On this tab... You define...

<table>
<thead>
<tr>
<th>Button</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server Connection</strong></td>
<td>The i-Vu CCN Pro server and port, and the i-Vu CCN Pro operator name and password</td>
</tr>
<tr>
<td><strong>Browse To</strong></td>
<td>Which page you want to see first in i-Vu CCN Pro when browsing to the equipment</td>
</tr>
<tr>
<td><strong>Internet Explorer</strong></td>
<td>Whether or not browsing to the equipment opens a new browser window</td>
</tr>
<tr>
<td><strong>Notification Sounds</strong></td>
<td>Whether or not you want to hear an alarm and which sound file to use</td>
</tr>
</tbody>
</table>

### To install the i-Vu CCN Pro Alarm Notification Client application

Follow the steps below on each client computer that should receive alarm popups.

**PREREQUISITE** Enable support for Alarm Popup client in System Settings. See above topic.

1. Click Main Menu > System Options > Client Installs.
2. Click Alarm Popup Application.
3. Click Run, then follow the on-screen instructions to install the i-Vu CCN Pro Alarm Notification Client application. After you click Done, the application starts automatically.
4. In the Settings dialog box, enter appropriate values. You can also click to open this box. See information above for a description of the settings.
5. Click OK.
6. Minimize the i-Vu CCN Pro Alarm Notification Client window.

### Print

The Print alarm action prints alarm information.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text Printing</strong></td>
<td>Select to use the i-Vu CCN Pro server's local dot-matrix printer. Text Printing will not print to a network printer.</td>
</tr>
<tr>
<td></td>
<td>In the Printer Name field, type the computer port that the printer is connected to.</td>
</tr>
<tr>
<td></td>
<td>In the Line Width field, type the number of characters to be printed per line.</td>
</tr>
<tr>
<td></td>
<td>Prints multiple alarms per page.</td>
</tr>
<tr>
<td><strong>Graphics Printing</strong></td>
<td>Select to use the i-Vu CCN Pro server's default printer (local or network printer). Prints one alarm per page to the i-Vu CCN Pro server's default printer.</td>
</tr>
<tr>
<td><strong>Text to Print</strong></td>
<td>Use punctuation, spaces, or returns after the entries to format the text. To add live data to the text, select field codes from the Append Field Code list.</td>
</tr>
</tbody>
</table>
Monitor and control equipment

### Run Conditions

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
</table>

By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm **and** when it returns to normal. Under **Perform Action** you can choose to:

- Run the alarm action only when the alarm source generates an alarm **or** when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *
- Run if the alarm occurs during the occupied hours defined for a schedule group **or run if** the alarm occurs during the unoccupied hours defined for a schedule group. *

**EXAMPLE:** To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a schedule group (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Occupied**.

Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Unoccupied**.

---

### Run External Program

The **Run External Program** alarm action starts a program or batch file on the server.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
</table>

**Command Line**

The path of the executable file on the i-Vu CCN Pro server followed by the path of the output file.

**Example:**

`c:\windows\notepad.exe c:\i-Vu CCN Pro\webroot\alarms.txt`

**Append Field Code**

Add field codes to the **Command Line** field.

**Example:**

`c:\reports\run_report.bat $Generation_time$$To_State$`

This starts a batch file on the server and uses the alarm’s generation time and state as values.

**Synchronize**

Tells i-Vu CCN Pro to wait for the external program to finish running before initiating the next **Run External Program** alarm action.
Monitor and control equipment

By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under **Perform Action** you can choose to:

- Run the alarm action only when the alarm source generates an alarm or when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal.
- Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group.

**EXAMPLE:** To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a schedule group (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Occupied**.

Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Unoccupied**.

### Send Alphanumeric Page

The **Send Alphanumeric Page** alarm action sends a page to one or more alphanumeric pagers or sends text messages to cell phones. The pager or phone must be able to accept e-mail.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td>Type the address(es) that you want to send the alarm to. To enter multiple addresses, type a space or press Enter after each address.</td>
</tr>
<tr>
<td>From</td>
<td>Enter a valid address if required by your mail server.</td>
</tr>
<tr>
<td>Mail Host</td>
<td>Your Simple Mail Transfer Protocol (SMTP) mail server’s address.</td>
</tr>
<tr>
<td><strong>TIP</strong></td>
<td>This can be either an IP address or a system name, such as mail.mycompany.com.</td>
</tr>
<tr>
<td>Specify Mail User</td>
<td>Select if your mail server requires a username and password.</td>
</tr>
<tr>
<td>Send mail as MIME attachment</td>
<td>Select if your mail server allows only MIME attachments.</td>
</tr>
<tr>
<td>Message Text</td>
<td>Use punctuation, spaces, or returns after the entries to format the text. To add live data to the text, select field codes from the <strong>Append Field Code</strong> list.</td>
</tr>
</tbody>
</table>
Monitor and control equipment

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
</table>
| Run Conditions | By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under Perform Action you can choose to:  
• Run the alarm action only when the alarm source generates an alarm or when it returns to normal.  
• Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *  
• Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group. *  
EXAMPLE: To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:  
1. Create a schedule group (page 49), but do not assign members to it.  
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.  
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under Run Conditions, select Run if schedule group <your new group> is Occupied.  
Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under Run Conditions, select Run if schedule group <your new group> is Unoccupied.   |

**NOTE** You should not assign this alarm action to frequently-occurring alarms as this may cause problems on your network or the Internet.

To set up a dial-up networking connection

i-Vu CCN Pro can use a dial-up internet connection through a modem to deliver e-mail for the Send E-mail or Send Alphanumeric Page alarm action.

To set up the dial-up connection:

1 Set up your modem to dial out to your Internet Service Provider. See your modem documentation.
2 On the i-Vu CCN Pro server, open Internet Explorer.
3 Select **Tools > Internet Options**.
4 On the **Connections** tab, click **Setup**.
5 Follow the instructions in the wizard. See Windows Help for assistance.
6 In a text editor such as Windows Notepad, open i-Vu CCN Pro `webroot\<system>\system.properties`
7 At the end of the file, type the following line:
   ```
   repactions.connection.name=<name of connection>
   ```
   where <name of connection> is the ISP name you entered in the wizard in step 2.
8 Open Internet Explorer, then select **Tools > Internet Options > Connections** tab.
9 If the box under **Dial-up and Virtual Private Network settings** shows more than one connection, select the connection you just created, then click **Set Default**.
10 Select **Always dial my default connection**.
**Send E-mail**

The **Send E-mail** alarm action sends a message to one or more e-mail accounts. The alarm action can also run a report and attach it to the e-mail as a PDF, HTML, or Excel file.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>To</strong></td>
<td>Type the address(es) that you want to send the alarm to. To enter multiple addresses, type a space or press Enter after each address.</td>
</tr>
<tr>
<td><strong>From</strong></td>
<td>Enter a valid address if required by your mailserver.</td>
</tr>
<tr>
<td><strong>Mail Host</strong></td>
<td>Your Simple Mail Transfer Protocol (SMTP) mailserver’s address.</td>
</tr>
<tr>
<td><strong>Mail Host Port</strong></td>
<td>The port that will be receiving your email.</td>
</tr>
<tr>
<td><strong>Mail Host Security Options</strong></td>
<td>Choose your appropriate security option. Contact your network administrator for this information if necessary.</td>
</tr>
<tr>
<td><strong>Specify Mail User</strong></td>
<td>Select if your mailserver requires a username and password.</td>
</tr>
<tr>
<td><strong>Send mail as MIME attachment</strong></td>
<td>Select if your mailserver allows only MIME attachments.</td>
</tr>
<tr>
<td><strong>Message Text</strong></td>
<td>Use punctuation, spaces, or returns after the entries to format the text. To add live data to the text, select field codes from the <strong>Append Field Code</strong> list.</td>
</tr>
<tr>
<td><strong>Attach Report</strong></td>
<td>Select to attach a i-Vu CCN Pro report to the e-mail, then select the <strong>Report</strong> and the <strong>Format</strong>. <strong>NOTE</strong> The Report Name field shows a custom report only if it was created at the current system level. <strong>Run as</strong> shows the name and login name of the operator creating the alarm action. The report will be run using the privileges and report options of this operator. <strong>TIP</strong> You may want to create a new operator with limited privileges for this purpose.</td>
</tr>
</tbody>
</table>
Monitor and control equipment

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run Conditions</td>
<td>By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under Run Conditions you can choose to:</td>
</tr>
<tr>
<td></td>
<td>• Run the alarm action only when the alarm source generates an alarm or when it returns to normal.</td>
</tr>
<tr>
<td></td>
<td>• Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal.</td>
</tr>
<tr>
<td></td>
<td>• Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group.*</td>
</tr>
<tr>
<td></td>
<td>EXAMPLE: To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:</td>
</tr>
<tr>
<td></td>
<td>1. Create a schedule group (page 49), but do not assign members to it.</td>
</tr>
<tr>
<td></td>
<td>2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.</td>
</tr>
<tr>
<td></td>
<td>3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under Run Conditions, select Run if schedule group &lt;your new group&gt; is Occupied.</td>
</tr>
<tr>
<td></td>
<td>4. Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under Run Conditions, select Run if schedule group &lt;your new group&gt; is Unoccupied.</td>
</tr>
</tbody>
</table>

NOTES

• You should not assign this alarm action to frequently-occurring alarms as this may cause problems on your network or the Internet.

• This alarm action uses SMTP TCP Port 25 to send emails. To use a different port, open i-Vu CCN Pro.x.x\webroot\<system_name>\system.properties in a text editor such as Notepad. In the line #mail.server.port = 25, delete # at the beginning of the line and change 25 to the port you want to use. If you make this change while i-Vu CCN Pro Server is running, you must restart it to have the change take effect.

To secure mailserver communication using Secure Sockets Layer (SSL)

By default, the Send E-mail alarm action uses the SMTP protocol to send the email as clear text over TCP/IP. You can switch to one of the following protocols to secure email communication between the i-Vu CCN Pro server and the mailserver.

SMTPS           Sends email using SSL, a communication protocol that provides data encryption.
STARTTLS        Sends email using SSL, but does not begin encryption until i-Vu CCN Pro issues STARTTLS command.

To use one of these protocols:

1. Open i-Vu CCN Pro.x.x\webroot\<system_name>\system.properties in a text editor such as Notepad.

2. In the line #mail.transport.protocol = SMTP, delete # at the beginning of the line and change SMTP to SMTPS or STARTTLS. If you make this change while i-Vu CCN Pro Server is running, you must restart it to have the change take effect.

Before i-Vu CCN Pro sends an email using SSL, i-Vu CCN Pro requests an SSL certificate from the mailserver.
Monitor and control equipment

If the certificate that i-Vu CCN Pro receives is in its list of trusted certificates, i-Vu CCN Pro sends the email. If the certificate is not in the list, i-Vu CCN Pro generates a system alarm indicating that the email alarm action failed. If this occurs, you will need to add the mailserver’s certificate to i-Vu CCN Pro’s list of trusted certificates.

1. Get a copy of the certificate file from the mailserver. Ask your Network Administrator for help.
2. Put the file on the i-Vu CCN Pro server.
3. From the i-Vu CCN Pro server’s Start menu, select Run.
4. In the Open field, type the following command:
   
   C:\i-Vu CCN Pro<x.x>\java<operating_system>\jre\bin\keytool.exe -import
   -trustcacerts -alias smtpserver -keystore webserver\keystores\certkeys -
   file <file_path>
   
   replacing:
   <x.x> with the system's version number
   <operating_system> with the i-Vu CCN Pro folder name for the operating system you are running
   <file_path> with the full path and file name of the certificate file
5. The information for the smtpserver key is displayed and you are prompted to trust this certificate. Type yes.

To set up a dial-up networking connection

i-Vu CCN Pro can use a dial-up internet connection through a modem to deliver e-mail for the Send E-mail or Send Alphanumeric Page alarm action.

To set up the dial-up connection:

1. Set up your modem to dial out to your Internet Service Provider. See your modem documentation.
2. On the i-Vu CCN Pro server, open Internet Explorer.
3. Select Tools > Internet Options.
4. On the Connections tab, click Setup.
5. Follow the instructions in the wizard. See Windows Help for assistance.
6. In a text editor such as Windows Notepad, open i-Vu CCN Pro x.x\webroot\<system>\system.properties.
7. At the end of the file, type the following line:
   
   repactions.connection.name=<name of connection>
   
   where <name of connection> is the ISP name you entered in the wizard in step 2.
8. Open Internet Explorer, then select Tools > Internet Options > Connections tab.
9. If the box under Dial-up and Virtual Private Network settings shows more than one connection, select the connection you just created, then click Set Default.
10. Select Always dial my default connection.

Send SNMP Trap

The Send SNMP Trap alarm action sends an SNMP trap in response to receiving an alarm. Traps contain the text created in the Text to send as the SNMP Trap field in the alarm action dialog box. You can configure up to
Monitor and control equipment

five SNMP servers to receive traps.

NOTES

- i-Vu CCN Pro supports SNMP v1.
- Each SNMP server you want to receive these traps must have SNMP monitoring equipment installed. If problems arise with your SNMP connection or receiving traps, contact your IS department.
- This alarm action uses Port 162 to send SNMP traps. To use a different port, open `i-Vu CCN Pro\webroot\<system_name>\system.properties` in a text editor such as Notepad. In the line `#snmp.trap.port = 162`, delete `#` at the beginning of the line and change 162 to the port you want to use. If you make this change while i-Vu CCN Pro Server is running, you must restart it to have the change take effect.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Address*</td>
<td>The network address of the SNMP server receiving the SNMP trap.</td>
</tr>
<tr>
<td>Community Name*</td>
<td>The community name that the SNMP server belongs to.</td>
</tr>
<tr>
<td>Comment</td>
<td>The physical location of the SNMP server. This field is optional.</td>
</tr>
<tr>
<td>Trap number*</td>
<td>If the network administrator has configured trap numbers, type a unique number from 1 to 127.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> The same trap number is used for all messages from this alarm action.</td>
</tr>
<tr>
<td>Text to send as the SNMP Trap</td>
<td>255 character limit. Type punctuation, spaces, or returns after the entries to format the message. You can customize this text by selecting field codes from the <code>Append Field Code</code> list.</td>
</tr>
</tbody>
</table>

Run Conditions

By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under **Perform Action** you can choose to:

- Run the alarm action only when the alarm source generates an alarm or when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *
- Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group. *

**EXAMPLE:** To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a `schedule group` (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under **Run Conditions**, select **Run If schedule group `<your new group>` is Occupied.**

Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under **Run Conditions**, select **Run If schedule group `<your new group>` is Unoccupied.**

* Ask your network administrator for this information.
**Write Property**

The **Write Property** alarm action writes a specified value to a microblock property. You typically set up 2 alarm actions, the first writes a value when the alarm occurs and the other writes a value when the return-to-normal occurs.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Expression</strong></td>
<td>Type the target property’s expression.</td>
</tr>
<tr>
<td><strong>Value to Write</strong></td>
<td>Type the value you want to write to the microblock property. Type 0 or 1 for a binary property.</td>
</tr>
<tr>
<td><strong>Append field code to value</strong></td>
<td>Select field codes to add this information to the Value to Write field.</td>
</tr>
</tbody>
</table>

**Run Conditions**

By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under **Perform Action** you can choose to:

- Run the alarm action only when the alarm source generates an alarm or when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *
- Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group. *

**EXAMPLE:** To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a schedule group (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Occupied**.

Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Unoccupied**.

**Write to Database**

The **Write to Database** alarm action stores alarm information in a table in the i-Vu CCN Pro alarm database or in a custom database. Third-party applications can access the alarm information for building maintenance management or alarm analysis. For example, an application can perform actions such as triggering a stored procedure or running a report.

**Writing to the i-Vu CCN Pro alarm database**

When you add the **Write to Database** alarm action, by default i-Vu CCN Pro writes alarm information to the **write_db_ra** table in the i-Vu CCN Pro alarm database. The following table describes the information that i-Vu CCN Pro writes to the database and gives the column name and data type you will need in order to access the alarm information from a third-party application.
Monitor and control equipment

<table>
<thead>
<tr>
<th>Description</th>
<th>Column Name</th>
<th>Data type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm generation time</td>
<td>EVENT_TIME_</td>
<td>Datestamp</td>
</tr>
<tr>
<td>Path to the alarm source</td>
<td>SOURCE_PATH_</td>
<td>String</td>
</tr>
<tr>
<td>Display name path to the alarm source</td>
<td>DISPLAY_NAME_</td>
<td>String</td>
</tr>
<tr>
<td>Alarm state</td>
<td>EVENT_STATE_</td>
<td>String</td>
</tr>
<tr>
<td>Alarm text as defined in the Text to write to the database field on the alarm action page. You can add live data to the text by selecting field codes from the Append Field Code list.</td>
<td>RA_TEXT_</td>
<td>String</td>
</tr>
</tbody>
</table>

**Perform Action**

By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under **Perform Action** you can choose to:

- Run the alarm action only when the alarm source generates an alarm or when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *
- Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group. *

EXAMPLE: To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a schedule group (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Occupied**.
4. Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under **Run Conditions**, select **Run if schedule group <your new group> is Unoccupied**.

**NOTES**

- To keep the database table from growing too large, you must delete old entries using a third-party database application. You cannot view, edit, or delete entries from i-Vu CCN Pro.
- If your system uses an Access or MSDE database, you cannot open the database in a third-party application while i-Vu CCN Pro or SiteBuilder is running.

**Writing to a custom database**

i-Vu CCN Pro can write alarm information to the following types of custom databases. The custom database does not have to be the same type as the i-Vu CCN Pro database.

- SQL Server
- MySQL
- PostgreSQL
You may create a table in an existing third-party database or create a new database.

Using your database management tool, create a table in your custom database that includes fields for each alarm field code to be written to the table. Each field length in the table should be as long as the longest value to be written to that field.

To set up i-Vu CCN Pro to write to a custom database instead of the i-Vu CCN Pro alarm database, select the **Specify Custom Database** checkbox on the Alarms page **Actions** tab, then enter information in the remaining fields. See table below.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
</table>
| **Text to write to the database** | The text is made up of field codes that add live data to the text. You can select additional field codes from the **Append Field Code** list.  
   **NOTE** To write the text in this field to the custom database, you must include the Report Text field code ($report_text$) in the **Database Insert String** field described below. |
| **Database Connect String**  | For database type...  
   SQL Server          | jdbc:odbc:<odbc_alias>  
   MySQL               | jdbc:mysql://<host>[:<port>]/<instance>  
   PostgreSQL          | jdbc:postgresql://<host>[:<port>]/<instance>  
   where:              | <host> is the database server name/IP address  
   <port> is the port number for the database  
   <instance> is the database name in the database server  
   <odbc_alias> is the name of the ODBC data source |
| **Database Login and Password** | The login and password to connect to the database. |
| **Database Insert String**  | Use the following format:  
   Insert into <TABLE_NAME> (<column1_name>, <column2_name> ...) values  
   ($field_code1$, $field_code2$, ...)  
   Example:  
   Insert into i-Vu CCN Pro_ALARMS (TIME_, LOCATION_, TO_STATE_, TEXT_) values  
   ($generation_time$, $location_path$, $to_state$, $report_text$)  
   **NOTES**  
   You can add field codes to the Insert String using the **Append Field Code** list.  
   If you add a timestamp type field code (for example, $generation_time$), you should have the data go into a timestamp data type field in the custom database. Otherwise, you must use field code formatting to format the time. |
Perform Action

By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under Perform Action you can choose to:

- Run the alarm action only when the alarm source generates an alarm or when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *
- Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group. *

EXAMPLE: To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a schedule group (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under Run Conditions, select Run if schedule group <your new group> is Occupied.
4. Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under Run Conditions, select Run if schedule group <your new group> is Unoccupied.

Write to File

The Write to File alarm action can do either of the following:

- Record alarm information in a standard ASCII text file that you can view and edit using a text editor such as Windows® Notepad.
- Write a i-Vu CCN Pro report to a file.

File Name

Path name for the file you want to write to such as \c:\i-Vu CCN Pro\webroot\alarms.txt.

- If you do not specify a path, the file is written to the system folder.
- If you type a path that does not exist, i-Vu CCN Pro will create the necessary folders.
- You can write to one of the following:
  - a file on the server
  - a networked computer if you map the network drive. Use the drive mapping in the path from the server to the computer.
- The path name may contain field codes.

Write as File

Select to record alarm information in a text file.

Append

Select to append new alarm information to the end of the file instead of writing over existing data.

NOTE Because you can append new alarm information to the end of the file, this file can become very large. You must back up and delete this file frequently if you are using this alarm action with many alarms.
Monitor and control equipment

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text to write to the file</strong></td>
<td>Use punctuation, spaces, or returns after the entries to format the text. To add live data to the text, select field codes from the Append Field Code list.</td>
</tr>
<tr>
<td><strong>Write as Report</strong></td>
<td>Select to write a i-Vu CCN Pro report to a file, then select the Report and the Format.</td>
</tr>
<tr>
<td><strong>NOTE</strong></td>
<td>The Report Name field shows a custom report only if it was created at the current system level.</td>
</tr>
<tr>
<td><strong>Run as</strong></td>
<td>Shows the name and login name of the operator creating the alarm action. The report will be run using the privileges and report options of this operator.</td>
</tr>
<tr>
<td><strong>TIP</strong></td>
<td>You may want to create a new operator with limited privileges for this purpose.</td>
</tr>
</tbody>
</table>

**Run Conditions**

By default, i-Vu CCN Pro performs an alarm action when the alarm source generates an alarm and when it returns to normal. Under Perform Action you can choose to:

- Run the alarm action only when the alarm source generates an alarm or when it returns to normal.
- Wait for the specified amount of time, then run the alarm action if the alarm has not been acknowledged or has not returned to normal. *
- Run if the alarm occurs during the occupied hours defined for a schedule group or run if the alarm occurs during the unoccupied hours defined for a schedule group. *

**EXAMPLE:** To have i-Vu CCN Pro perform one alarm action during work hours and a different alarm action after work hours:

1. Create a schedule group (page 49), but do not assign members to it.
2. Create a schedule for the group. Set the occupied hours to be the same as the work hours.
3. Create the alarm action that you want i-Vu CCN Pro to perform during work hours. Under Run Conditions, select Run if schedule group <your new group> is Occupied.

Create the alarm action that you want i-Vu CCN Pro to perform during after hours. Under Run Conditions, select Run if schedule group <your new group> is Unoccupied.

---

**Set up an alarm source in i-Vu CCN Pro**

In i-Vu CCN Pro you can:

- Edit an alarm source’s settings or set up a new alarm source to generate alarms
- Select Properties page > Alarm Sources tab to set up all alarms associated with a particular piece of equipment

---

**To set up, edit, or disable alarm sources**

**To set up, edit, or disable a single alarm source:**

1. On the navigation tree, select the alarm source.
2. Click Alarms, then select the Enable/Disable tab.
Monitor and control equipment

3 Make changes to the fields as needed. See table below.
4 Click View Selected Sources, then click the selected alarm source on the Web Page Dialog.
5 Make changes to the fields as needed. The fields can vary for different types of alarm sources.
6 Click OK or Apply.
7 Click Close.

**TIP** To set up all the alarms for a piece of equipment at once, select Properties page > Alarm Sources tab.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Potential alarm source</td>
<td>Select the checkbox to enable the alarm source to generate alarms. Clear the checkbox to disable the alarm source.</td>
</tr>
<tr>
<td>Alarm</td>
<td>Select to have the alarm source generate an alarm when the specified conditions occur.</td>
</tr>
<tr>
<td></td>
<td>• For a binary input, enter the conditions for generating an alarm.</td>
</tr>
<tr>
<td></td>
<td>• For an analog input, type the low and high limits that, when exceeded, will generate an alarm.</td>
</tr>
<tr>
<td>Deadband</td>
<td>The amount inside the normal range by which an alarm condition must return before a return-to-normal notification is generated.</td>
</tr>
<tr>
<td>NOTE</td>
<td>If the Status checkbox is selected, the alarm condition currently exists.</td>
</tr>
<tr>
<td>Return to Normal</td>
<td>Select to have the alarm source generate a return-to-normal when the alarm condition returns to a normal state.</td>
</tr>
<tr>
<td>Fault</td>
<td>Select to have an alarm generated if the alarm source is not configured correctly.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> If the Status checkbox is selected, the alarm source is currently misconfigured.</td>
</tr>
<tr>
<td>Alarm requires acknowledgement</td>
<td>Select to have i-Vu CCN Pro require that an operator acknowledge the alarm.</td>
</tr>
<tr>
<td>Return requires acknowledgement</td>
<td>Select to have i-Vu CCN Pro require that an operator acknowledge the return-to-normal.</td>
</tr>
<tr>
<td>Classified as Critical</td>
<td>This property determines the color of the system-wide alarm button when the alarm comes in.</td>
</tr>
<tr>
<td></td>
<td>![Critical] = Critical ![Non-critical] = Non-critical</td>
</tr>
<tr>
<td>Event State</td>
<td>The current state of the alarm source can be:</td>
</tr>
<tr>
<td></td>
<td>• Normal—value is normal</td>
</tr>
<tr>
<td></td>
<td>• Off normal—the value is not normal (binary only)</td>
</tr>
<tr>
<td></td>
<td>• Fault—the alarm source microblock may be misconfigured</td>
</tr>
<tr>
<td></td>
<td>• High Limit—the value exceeds the normal range (analog only)</td>
</tr>
<tr>
<td></td>
<td>• Low Limit—the value is below the normal range (analog only)</td>
</tr>
<tr>
<td>Notification Class</td>
<td>Do not change this field.</td>
</tr>
</tbody>
</table>

To set up, edit, or disable multiple alarm sources simultaneously:

1 On the navigation tree, select the area or equipment containing the alarm sources you want to change.
2 Click Alarms, then select the Enable/Disable tab.
3 In step 1, select the categories that contain the alarm sources.
   \textbf{NOTE} In step 1 and step 2, CTRL+click to select multiple items or select the \textit{Select All} checkbox.

4 In step 2, select the alarm sources.

5 Make appropriate changes in step 3.

6 Click \textit{OK}.
   \textbf{NOTE} Click \textit{View Selected Sources} to view or change settings for each alarm.

\textbf{To view all instances of an alarm source}

To find all instances of an alarm source at and below a selected area:

1 On the navigation tree, select an area.

2 Click \textit{Alarms} and select the \textit{Actions}, \textit{Enable/Disable}, or \textit{Category} tab.

3 Select an alarm source from the list in step 2.

4 Click \textit{View Selected Sources}.
   \textbf{NOTE} You may be able to change settings that relate to the tab you selected.

\textbf{Alarm categories}

Alarm categories sort related alarm sources and their alarms into groups such as HVAC Critical and Access Control General. Alarm categories let you:

- \textit{View}, \textit{acknowledge}, or \textit{delete alarms} (page 53) received by i-Vu CCN Pro
- \textit{Assign alarm actions} (page 57) to selected categories of alarm sources
- \textit{Set up alarm sources} (page 71) in selected categories

i-Vu CCN Pro has a number of default alarm categories, but you can create custom categories, if needed.

\textbf{To assign alarm sources to a different category:}

1 On the navigation tree, select the area, equipment, or controller containing the alarm sources.

2 Click \textit{Alarms}, then select the \textit{Category} tab.

3 In step 1, select the category that currently contains the alarm sources.
   \textbf{NOTE} In step 1 and step 2, CTRL+click to select multiple items, or select the \textit{Select All} checkbox.

4 In step 2, select the alarm sources whose category you want to change.

5 In step 3, select a category from the drop-down list, then click \textit{Change}.

6 Click \textit{OK}.

\textbf{To add a custom alarm category or edit an existing alarm category}

1 Click \textit{Main Menu} button, then select \textit{System Options}.

2 On the tree, click the plus sign (+) to the left of \textit{Categories}. 
Monitor and control equipment

3 Click Alarms.

4 To edit an existing alarm category, select the alarm under Select Category and edit the Category Name, Reference Name, or Icon. See table below.

5 To add a new category, click Add. See table below.

6 Click OK.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference Name</td>
<td>Must be unique in the database, be lowercase, and not contain any spaces.</td>
</tr>
</tbody>
</table>
| Icon          | • Find or create a 32 x 32 pixel icon (.gif file) that represents the new category. For example, 🏛️
|               | • Store the .gif file in the i-Vu CCN Pro|x\webroot\_common\vl5\ graphics\event_categories folder.
|               | • Type /_common/lvl5/graphics/event_categories/<file_name>.gif in the Icon field.|

**Trends**

i-Vu CCN Pro can read and store equipment status values over time and then display this information in a graph to help you monitor the equipment’s operation.

Trends are automatically enabled for points that appear on equipment graphics (if the graphic was generated from the i-Vu CCN Pro Library). Samples are automatically collected every 20 minutes.

An unlimited amount of trend data can be collected for any input or output point in i-Vu CCN Pro. Trends can be generated for individual points or multiple points on one graph.

**To collect trend data for a point**

Before you can look at a trend graph for a point, you must enable trending for that point and then tell i-Vu CCN Pro how you want the controller to collect the point's data.

1 On the navigation tree, select the equipment that has the point you want to trend.
2 Click the Trends button drop-down arrow, select Enabled or Disabled Points, then select the point.
3 Click the Enable/Disable tab, then verify that Enable Trend Log is checked.
4 Enter information in the appropriate fields. See table below.
5 Click OK.

**TIP** You can set up all trends for a piece of equipment at once on the Trend Sources tab of the equipment's Properties page.
<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample every <code>_:_:</code> (hh:mm)</td>
<td>This method records (samples) the point’s value at the time interval you define in this field.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> Be sure to set trend intervals to one minute or greater.</td>
</tr>
<tr>
<td>Sample on COV (change of value)</td>
<td>This method records the point’s value only when the value changes by at least the amount you enter in the <strong>COV Increment</strong> field.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> Use this method for a binary point or for an analog point that has infrequent changes in value.</td>
</tr>
<tr>
<td>Allocate memory for __ samples in the module</td>
<td>Type the maximum number of samples to be stored in the equipment.</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE</strong> Trending consumes memory in the equipment. The amount of memory available depends on the type of module. Each trended point consumes 48 bytes of memory plus 10 bytes for each trend sample. Each trend microblock consumes 416 bytes of memory plus 10 bytes for each trend sample. Click <strong>Reset</strong> to delete all samples currently stored in the equipment. The sample and memory allocation fields together define trend data storage in the controller in terms of hours. <strong>EXAMPLE</strong> If you set these fields so that samples are collected every 5 minutes for a maximum of 120 samples, the controller will store 600 minutes (5 x 120) or 10 hours of trend data.</td>
</tr>
<tr>
<td>Stop When Full</td>
<td>Select this field to stop trend sampling when the maximum number of samples is reached.</td>
</tr>
<tr>
<td>Enable trend log at specific times only?</td>
<td>Collects trend data for the specific period of time you define in the <strong>time</strong> and <strong>date</strong> fields.</td>
</tr>
<tr>
<td>Enable Trend Historian</td>
<td>Archives trend data to the system database.</td>
</tr>
<tr>
<td>Store Trends Now</td>
<td>Writes all trend data in the controller to the system database without having to enable trend historian.</td>
</tr>
<tr>
<td>Every __ trend samples write to historian</td>
<td>Writes all trend data in the equipment to the system database each time the equipment collects the number of samples that you enter in this field. This number must be greater than zero and less than the number entered in the field <strong>Allocate memory for __ samples in the module</strong>. The number of trends specified must be accumulated at least once before the historical trends can be viewed.</td>
</tr>
<tr>
<td>Trend samples accumulated since last notification</td>
<td>Shows the number of samples stored in the controller since data was last written to the database.</td>
</tr>
<tr>
<td>Last Record Written to Historian</td>
<td>Shows the last two times that trend data was written to the database.</td>
</tr>
<tr>
<td>Keep historical trends for __ days</td>
<td>This is based on the date that the sample was read. Set this field to 0 to use the system default defined in System Settings</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes all trend samples stored in the database for the item selected in the navigation tree.</td>
</tr>
</tbody>
</table>
Monitor and control equipment

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>BACnet Configuration</td>
<td>The <strong>Object Name</strong> is a unique alphanumeric string that defines the BACnet object. Although the <strong>Object Name</strong> field can be edited, it is not recommended. The <strong>Notification Class</strong> is set to 1 to receive alarms generated by Carrier controllers.</td>
</tr>
</tbody>
</table>

**NOTES**
- Run a **Trend Usage** (page 83) report to view trend data.
- You can use **Global Copy** (page 32) to copy trend properties to other pieces of equipment that use the same control program.

**Graphing data for multiple points**

You can graph multiple trend points simultaneously to help monitor and troubleshoot your system.

A comparison trend graph can display up to four graphs on the page. Each graph can display up to 4 similar points - 4 binary points or 4 analog points.

**NOTE** Before you create a comparison trend graph, verify trending for the individual points you want to include in the graph. See To collect trend data for a point.

**To create a comparison trend graph**

You can select up to 16 trends to view, then save them for graphing again later.

1. In the navigation tree, select the area or equipment where you want to view the graph.
2. Click the **Trends** button drop-down arrow, then select **New Graph**.
3. Select up to 16 trends from the selection tree. Use Ctrl+click, Shift+click, or both to select multiple items.
To edit a comparison trend graph

To add another graph to a trend graph page
1. Select the navigation tree item where the trend was created.
2. Click the Trends drop-down arrow, then select the trend graph.
3. On the Configure tab, click the Add button below the Graphs list.
4. Type a Y-axis label.
5. Add up to 4 points. (See below.)
6. Click OK.

To add a point to a trend graph
1. Select the navigation tree item where the trend was created.
2. Click the Trends drop-down arrow, then select the trend graph.
3. On the Configure tab, select a graph in the Graphs list.
4. Click the Add button below the Points list.
5. Select a point from the navigation tree to define the Data source.

   **NOTE** Each graph can display up to 4 similar type points (all binary or all analog).
6. Click OK.

To delete a graph from a comparison trend graph page
1. Select the navigation tree item where the trend was created.
2. Click the Trends drop-down arrow, then select the trend graph.
3. On the Configure tab, select the graph you want to delete in the Graphs list.
4. Click the Delete button below the Graphs list.
5. Click OK.

To delete a comparison trend graph
1. On the navigation tree, select the equipment.
2. Click the Trends button drop-down arrow, then select the custom graph.
3. Click **Main Menu** then select **Delete**.
Monitor and control equipment

**Using trend graphs**

In i-Vu CCN Pro, you can view and print trend graphs. You can also copy the trend data to a spreadsheet program.

**To view a trend graph**

1. On the navigation tree, select the equipment whose trend(s) you want to view.
2. Click the **Trends** button drop-down arrow, then select the graph you want to view.
3. Select the **View** tab.

**NOTES**

- A large marker indicates a point that is in alarm, in fault, out of service, or has been overridden. Ctrl+click the marker to view details.
- A dotted vertical line indicates:
  - Trend Historian has been enabled or disabled.
  - The trend object ID of a third-party trend source has been changed. For information only, you do not need to do anything.
  - controller received a time synchronization from its network router or from i-Vu CCN Pro. Ctrl-click the line to view the time correction.
  - Trend Log has been enabled or disabled.
- Ctrl-click a dotted vertical line to view details.

**Tools for viewing trends**

Right-click anywhere on a trend graph to access most of the tools described below.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Tool</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow keys</td>
<td><strong>Pan</strong></td>
<td>If you display more than one graph, panning up and down affects only one graph at a time. Panning left to right affects all graphs. You can also Alt+click and drag inside the graph.</td>
</tr>
<tr>
<td>Page Down</td>
<td><strong>Zoom In</strong></td>
<td>You can also use the + key on the numeric keypad, the X key, or drag a rectangle around area.</td>
</tr>
<tr>
<td>Page Up</td>
<td><strong>Zoom out</strong></td>
<td>You can also use the - (minus) key on the numeric keypad or the Z key.</td>
</tr>
<tr>
<td>Home</td>
<td><strong>Zoom to extents</strong></td>
<td>Shows all the data you have viewed in the current session of a particular trend graph.</td>
</tr>
<tr>
<td>End</td>
<td><strong>Reset view</strong></td>
<td>Resets the display to its default setting. You can also use the Enter or R key.</td>
</tr>
<tr>
<td>Esc</td>
<td><strong>Undo</strong></td>
<td>Undo up to 10 changes to your view.</td>
</tr>
<tr>
<td>Shortcut</td>
<td>Tool</td>
<td>Notes</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------</td>
<td>-------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>J</td>
<td>Set start date</td>
<td>Enter the date you want the trend to jump to. The trend displays the same time range for the new date. Press the J key again to hide the date fields.</td>
</tr>
<tr>
<td>H</td>
<td>History Only</td>
<td>Displays only the historical data on the graph.</td>
</tr>
<tr>
<td>U</td>
<td>Auto Update</td>
<td>The trend graph polls for data every 10 seconds. Press U again to stop updating.</td>
</tr>
<tr>
<td>M</td>
<td>Point Markers</td>
<td>Shows a marker for each data point in the graph.</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy</td>
<td>Copies only the data from the time range that is currently displayed.</td>
</tr>
<tr>
<td></td>
<td>Refresh the display</td>
<td>Click Trends.</td>
</tr>
<tr>
<td></td>
<td>(gather trend data)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Display a specific</td>
<td>Ctrl+click a sample to view the point name, time and date the sample was read, the exact point value, and if the point is in alarm, is in fault, out of service, or has been overridden. Click anywhere to clear the details.</td>
</tr>
<tr>
<td></td>
<td>sample’s data</td>
<td></td>
</tr>
</tbody>
</table>

**To print a trend graph**

1. On the navigation tree, select the equipment that has the trend(s) you want to print.
2. Click the Trends button drop-down arrow, then select the point graph or custom graph you want to print.
3. Select the View tab to display the graph.
4. Click the print button.

**To transfer trend data to a table format**

You can copy the trend data currently displayed in the graph and paste it into a spreadsheet application, such as Microsoft® Excel.

**NOTE** If you want to transfer a few points in the system, this procedure may be sufficient. If you want trend data for the entire database, you can export to a .xml file in SiteBuilder to then import into a spreadsheet application.

1. On the navigation tree, select the equipment.
2. Click the Trends button drop-down arrow, then select the graph.
3. Select the View tab to display the graph.
4. Click somewhere in the graph, then press Ctrl+C to copy the data.
5. Click OK.
Monitor and control equipment

6 Start your spreadsheet program and paste the trend data into your spreadsheet.

7 Convert the trend data in the **Time** column to a readable date/time format using the spreadsheet application’s formatting System Options. For example, in Microsoft Excel, highlight the cells you want to format and choose **Format > Cells**. On the **Number tab**, choose **Time** from the **Category** list, and select the type of format you want to see.

### Customizing graph appearance

**To edit graph properties**

Each point trend graph has a standard format. However, you can change the format and how much data is displayed on the graph.

1. On the navigation tree, select the equipment that has the trend graph properties you want to configure.
2. Click the **Trends** button drop-down arrow, then select the trend you want to change.
3. Click the **Configure** tab.
4. Edit the graph properties as needed. See table below.
5. Click **OK**.
Monitor and control equipment

### Field | Notes
--- | ---
**Font size** | Lets you change the font size of the graph's title and other text.

**Enable Grid?** | Show or hide the graph's grid.

**Autoscale x-axis** | Gathers the most recent 2000 data samples and then autoscales the x-axis to include the complete time range of all the samples.

**X Initial range** | If you do not autoscale the x-axis, type in this field how far back i-Vu CCN Pro should go to display data. For example, if you want to see trend data from a week ago, type 7 in the **Days** field.

**Autoscale y-axis** | Gathers the trend data from the controller and then autoscales the y-axis to include the complete range of values.

**Y-axis minimum and maximum** | If you do not autoscale the y-axis, type the minimum and maximum value that you want the graph to display.

**Graphs** | Add or delete graphs from the page.

**Points** | Add or delete points from the graph selected in the **Graphs** table.

* for custom graphs only

---

**To change colors, line styles, and marker types**

You can change colors, line styles, and marker types for both point trend graphs and custom trend graphs. The changes you make apply to all graphs in the system, and become the default settings for future trend graphs.

1. Click the **Main Menu** button, then select **System Options**.
2. On the tree, click **Trends Display Setup** to change the settings for displaying trend graphs or select **Trends Print Setup** to change the settings for printing trend graphs.
3. Follow the appropriate instructions below.
4. Click **OK**.

**To change a color**

Click the colored box to the right of the graph element that you want to change, then select the new color in the color palette. Or, you can type the hexadecimal value in the **RGB** field.
Monitor and control equipment

To change line styles and marker types

For a point trend graph, select the new line style and marker type under *Graph 1, Data Series 1.*

For a custom trend graph:

1. Click the plus sign (+) to the left of the graph you want to change.

The four *Data Series* refer to the 4 points that you can include on a custom trend graph. Under the appropriate *Data Series,* select the new line style and marker style you want.

**To copy a trend graph's properties**

You can use *Global Copy* (page 32) to copy trend properties to other pieces of equipment that use the same control program.

**To add, edit, or delete a trend category**

A point trend graph is in the *Enabled* or *Disabled* category in the *Trends* button drop-down menu.

You can add categories for your custom trend graphs.

1. Click *Main Menu* button, then select *System Options.*
2. Click the plus sign (+) to the left of the *Categories* folder, then select *Trend.*
3. Click *Add* or select a category to edit.
4. Type the *Category Name* and *Reference Name.*
5. Select a privilege so that only operators with that privilege can access trends in the category.
Click **OK**.

**NOTE** To delete a category, select the category, click **Delete**, then click **OK**.

### Reports

Use i-Vu CCN Pro reports to gather and view information to monitor and troubleshoot your system. Select report options to define the layout and content that serve your needs. The list of available reports changes depending on your navigation tree location.

**NOTE** The *Send E-mail alarm action* (page 63) can run any i-Vu CCN Pro report and attach it to the email. The *Write to File alarm action* (page 70) can run any i-Vu CCN Pro report and save it as a file. For both alarm actions, the report can be a PDF, HTML, Excel, or CSV file.

### i-Vu CCN Pro reports

<table>
<thead>
<tr>
<th>This report...</th>
<th>allows you to...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alarms</strong></td>
<td></td>
</tr>
<tr>
<td>Alarms</td>
<td>View, sort, and filter the information on the Alarms View (page 53) tab.</td>
</tr>
<tr>
<td>Alarm Sources</td>
<td>Create a summary of potential alarm sources as configured on the Alarm Enable/Disable (page 71) tab.</td>
</tr>
<tr>
<td>Alarm Actions</td>
<td>Create a summary of the information configured on the Alarms Actions (page 57) tab.</td>
</tr>
<tr>
<td><strong>Schedules</strong></td>
<td></td>
</tr>
<tr>
<td>Schedule Instances</td>
<td>Find every schedule with its location that is entered at and below a selected tree item. This report can help you discover newly added and conflicting schedules.</td>
</tr>
<tr>
<td>Effective Schedules</td>
<td>View all equipment that may be scheduled and the net result of all schedules in effect for a selected date and time.</td>
</tr>
<tr>
<td><strong>Equipment</strong></td>
<td></td>
</tr>
<tr>
<td>Point List</td>
<td>View the details of all points. Verify that all points have been checked out during commissioning. Also, create custom lists for other contractors. For example, create a list of BACnet IDs or Web services links.</td>
</tr>
<tr>
<td>Network IO</td>
<td>Verify the programming and status of all network points—especially useful for commissioning controllers used for third-party integration.</td>
</tr>
</tbody>
</table>
Monitor and control equipment

<table>
<thead>
<tr>
<th>This report...</th>
<th>allows you to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trend Usage</td>
<td>Creates a summary of the information configured on the Trends Enable/Disable tab.</td>
</tr>
<tr>
<td>Parameter Mismatch</td>
<td>Discover where your system has parameter mismatches that need to be resolved.</td>
</tr>
</tbody>
</table>

**Commissioning**

| Equipment Checkout | View the information on the Equipment Checkout tab of the Properties button during commissioning. Also, find equipment that has not been fully commissioned. |

**Security**

| Audit Log | Create chronological lists of operators, property changes they have made, and the reasons for those changes. |

**New Reports**

<table>
<thead>
<tr>
<th>Equipment Summary</th>
<th>An Equipment Summary report can provide the following information for equipment at or below the location where the report is created.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equipment Values</td>
<td>An Equipment Values report allows you to compare point information.</td>
</tr>
<tr>
<td>Trend Samples</td>
<td>A Trend Samples report provides trend values for a particular time frame.</td>
</tr>
</tbody>
</table>

**To run a report**

1. Select an item on the navigation tree.
   
   **NOTE** A report shows data for the selected tree item and all its children.

2. Click the Reports button drop-down arrow, then select a report.

3. On the Options tab, define the layout and content of the report.
   
   **NOTES**
   
   o Changing the size and orientation of the printed page also changes the report layout on the View tab.
   
   o To create a CSV (Comma Separated Values) file after you run the report, select Support CSV text format. See To create a PDF, Excel spreadsheet, or CSV file (page 84).
   
   o i-Vu CCN Pro saves report options for the current operator. When that operator logs in again, i-Vu CCN Pro uses the same options.

4. Click Run.

5. Click PDF if you want to print the report.

**To create a PDF or Excel spreadsheet**

**PREREQUISITE FOR CSV TEXT** You must enable CSV text before you run the report. Click the Reports tab and choose a report from the drop-down menu. Click the Options tab > Support CSV text format.

Run a report
1. Select **Reports** page > **View** tab.
2. Click **Run** button.
3. Choose **PDF**, **Excel**, or **CSV Text**.

For Excel or CSV Text, click **Open** to view the file or **Save** to save it.

### Custom reports

You can create custom reports to collect and display specific information. For example, you can create environmental and power consumption reports for a building.

In i-Vu CCN Pro, you can create the following reports:

- **Equipment Summary** (page 85)
- **Equipment Values** (page 86)
- **Trend Samples** (page 87)

### Equipment Summary

An **Equipment Summary** report can provide the following information for equipment at or below the location where the report is created:

- Color
- Active alarm
- Locked values
- Current value of selected points
- Effective schedule

To create an **Equipment Summary** report:

1. On the navigation tree, select the location where you want to view the report.
2. Click the **Reports** button drop-down arrow, then select **New Report**.
3. Select **Equipment Summary**.
4. Type a name for the report.
5. Click **Create**.
6. On the **Design** tab, define the layout and the **Maximum number of rows**.
7. To create a CSV (Comma Separated Values) file after you run the report, select **Support CSV text format**. See To create a PDF, Excel spreadsheet, or CSV file (page 84).
8. Select or clear the **Optional Sections** checkboxes as needed.
9. Select **Available Points** that you want to include in the report. (Use Ctrl+click, Shift+click, or both to select multiple points.)
10. Click **Add**.
11. Click **OK**.
12. Click **Run**.

**NOTE** To run this report later, go to the location where the report was created. Click the **Reports** button drop-down arrow, select the report, then click **Run**.
Equipment Values

An Equipment Values report allows you to compare point information.

To create an Equipment Values report:

1. On the navigation tree, select the location where you want to view the report.
2. Click the Reports button drop-down arrow, then select New Report.
3. Select Equipment Values.
4. Type a name for the report.
5. Click Create.
6. On the Design tab, click the plus sign next to Page to verify or change the page size and orientation.
   NOTE Changing the size and orientation of the printed page also changes the report layout on the View tab.
7. Click the plus sign next to Rows.
8. Do one of the following:
   - On the selection tree, select the pieces of equipment you want to view in the report. (Use Ctrl+click, Shift+click, or both to select multiple items.) Then click Add.
     Optional: Select the Highlight alternate rows checkbox to make the report easier to analyze.
9. Click Next or the plus sign next to Columns.
10. Verify or change the report Title, Page units of measure for defining column widths, and Outer border characteristics.
11. Select a column in the report preview.
   NOTE The selected column is light purple.
12. Under Column Header, define how you want the column header to look.
13. Under Column Data, define the data you want in the column and how you want it to look. See table below.
14. Optional: Use the Add, Delete, and arrow buttons below the report preview to manipulate the columns.
15. Click OK.
16. Click Run.

NOTE To run this report later, go to the location where the report was created. Click the Reports button drop-down arrow, select the report, then click Run.

<table>
<thead>
<tr>
<th>Type of Column Data</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point</td>
<td>Displays point data in the column.</td>
</tr>
<tr>
<td></td>
<td><strong>Display</strong> Select the property to show in this column.</td>
</tr>
<tr>
<td></td>
<td><strong>Data is named differently in some equipment</strong> Select this checkbox if similar points have different names in different equipment. Then add each of the names to the Name to use list. For example, if a point is named Zone Temp in one equipment and Zone Temperature in different equipment, add both names to the list.</td>
</tr>
<tr>
<td></td>
<td><strong>Point to use</strong> Select the name of the point to show in the column.</td>
</tr>
</tbody>
</table>
## Type of Column Data

<table>
<thead>
<tr>
<th>Trend Sample</th>
<th>Display</th>
<th>Select <strong>First</strong>, <strong>Minimum</strong>, <strong>Maximum</strong>, or <strong>Last</strong> recorded trend value.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data is named differently in some equipment</strong></td>
<td></td>
<td>Select this checkbox if similar points have different names in different equipment. Then add each of the names to the <strong>Name to use</strong> list. For example, if a point is named Zone Temp in one equipment and Zone Temperature in different equipment, add both names to the list.</td>
</tr>
<tr>
<td><strong>Trend to use</strong></td>
<td></td>
<td>Select the name of the point to show in the column.</td>
</tr>
<tr>
<td><strong>Set</strong></td>
<td></td>
<td>Click to have all columns in the report use the same time range.</td>
</tr>
<tr>
<td><strong>Time Range</strong></td>
<td></td>
<td>Select the time range to run the report for.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Trend Calculation</th>
<th>Display</th>
<th>Select the type of calculation to show in the column, <strong>Average</strong> or <strong>Total</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data is named differently in some equipment</strong></td>
<td></td>
<td>Select this checkbox if similar points have different names in different equipment. Then add each of the names to the <strong>Name to use</strong> list. For example, if a point is named Zone Temp in one equipment and Zone Temperature in different equipment, add both names to the list.</td>
</tr>
<tr>
<td><strong>Trend to use</strong></td>
<td></td>
<td>Select the name of the point to show in the column.</td>
</tr>
<tr>
<td><strong>Set</strong></td>
<td></td>
<td>Click to have all columns in the report use the same time range.</td>
</tr>
<tr>
<td><strong>Time Range</strong></td>
<td></td>
<td>Select the time range to run the report for.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Equipment</th>
<th>Display</th>
<th>Select <strong>Color</strong>, <strong>Display Name</strong>, <strong>Display Path</strong>, <strong>Notes</strong>, <strong>Prime Variable</strong>, or <strong>Reference Name</strong> to show in the column.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Expression</th>
<th><strong>Data is named differently in some equipment</strong></th>
<th>Select this checkbox if similar points have different names in different equipment. Then add each of the names to the <strong>Name to use</strong> list. For example, if a point is named Zone Temp in one equipment and Zone Temperature in different equipment, add both names to the list.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Expression</strong></td>
<td></td>
<td>Type the GQL expression relative to the current control program. The GQL expression must return a string value. To display the <strong>Notes</strong> on an equipment's <strong>Properties</strong> page, type <code>.notations</code> in this field.</td>
</tr>
</tbody>
</table>

### Trend Samples

**A Trend Samples** report provides trend values for a particular time frame.

To create a **Trend Samples** report:
Monitor and control equipment

1. On the navigation tree, select the location you wish to view on the report.
2. Select the **Reports** button drop-down arrow, then select **New Report**.
3. Select **Trend Samples**.
4. Type a name for the report.
5. Click **Create**.
6. On the **Design** tab, click the plus sign next to **Page** to verify or change the page size and orientation.
   **NOTE** Changing the size and orientation of the printed page also changes the report layout on the **View** tab.
7. Click the plus sign next to **Rows**.
8. Select a **Time Range** from the drop-down list, then refine that option by selecting an option from the drop-down list(s) to the right.
9. Define the trend data.
   **NOTES**
   - **Calculate values for missing samples** calculates a value based on the two closest values to the time interval.
   - **Find the closest sample** displays the value closest to the time interval selected.
10. Optional: Select the **Highlight alternate rows** checkbox to make the report easier to analyze.
11. Click **Next** or the plus sign next to **Columns**.
12. Verify or change the report **Title**, **Page units** of measure for defining column widths, and **Outer border** characteristics.
13. Select a column in the report preview.
   **NOTE** The selected column is light purple.
14. In the top 2 boxes, define the **Column Header** and the **Column Data**.
15. In the bottom 2 boxes, define the appearance of the header and data cells.
   **NOTE** Select **General** from the **Format** drop-down list unless you want to define the number of places to the right of the decimal point for the displayed value.
16. Optional: Use the **Add**, **Delete**, and arrow buttons below the report preview to manipulate the columns.
17. Click **OK**.
18. Click **Run**.
   **NOTE** To run this report later, go to the location where the report was created. Click the **Reports** button drop-down arrow, select the report, then click **Run**.

**To view a custom report**

1. Select the item in the navigation tree where the report was created.
2. Click the **Reports** button drop-down arrow, then select the report you want to view.
3. Click **Run**.

**To create a PDF or Excel spreadsheet**

**PREREQUISITE FOR CSV TEXT** You must enable CSV text before you run the report. Click the **Reports** tab and
Monitor and control equipment

choose a report from the drop-down menu. Click the **Options** tab > **Support CSV text format**.

Run a report

1. Select **Reports** page > **View** tab.
2. Click the **Run** button.
3. Choose **PDF**, **Excel**, or **CSV Text**.

For Excel or CSV Text, click **Open** to view the file or **Save** to save it.

---

**To edit or delete a custom report**

1. Select the item in the navigation tree where the report was created.
2. Click the **Reports** button drop-down arrow, then select the report you want to edit or delete.
3. Do one of the following:
   - Edit the report, then click **OK**.
   - Click **Main Menu**, then select **Delete**.

---

**To organize custom reports**

You can organize your custom reports by creating report categories that appear in the **Reports** button drop-down list.

**To add or edit a report category**

1. Click **Main Menu** button then select **System Options**.
2. On the tree, click **Categories** folder, then click **Report**.
3. Click **Add** or select a category to edit it.
4. Type the **Category Name** and **Reference Name**.
5. Select a privilege so that only operators with that privilege can access reports in the category.
6. Click **OK**.

**NOTE** To delete a category, select the category, click **Delete**, then click **OK**.
To backup your system

The type of database your system uses determines the method you use to back up the system.

If using MS Access or MSDE

1. Shut down i-Vu CCN Pro Server and SiteBuilder.
2. In the i-Vu CCN Pro x.x\webroot folder, copy your system folder.
3. Paste the copy to a new location.
   **TIP** Zip the copy before transporting it over a network or to a CD.

If using MySQL, MS SQL Server, or PostGreSQL

**NOTE** If any of i-Vu CCN Pro's 4 databases exceed 2 GB, use the database management system's backup method instead of the following procedure.

1. Shut down i-Vu CCN Pro Server and SiteBuilder.
2. In the i-Vu CCN Pro x.x\webroot folder, copy your system folder.
3. Paste the copy into the \webroot folder.
4. Rename of the copy to remove spaces and capital letters.
5. In SiteBuilder, open the copy, then migrate it to MS Access or MSDE. This step creates the Access or MSDE databases in the system folder.
6. Move the copy's folder to a new location.
   **TIP** Zip the copy before transporting it to a CD or over a network.

Updating the Library

i-Vu CCN Pro is equipped with a complete library. Library updates will be announced via a Controls Bulletin. In the bulletin, there will be a link to a website where you can go to download the new .sal Library file to your computer.

**Note** Keep copies of the latest Libraries in a safe place. In the event of a system restore, the updated Library must be reapplied.

1. Save the updated .sal file to your computer.
2. Click the menu button , then select *System Setup*.
3. Select *Update Library* to open a dialog box.
4. Browse to the updated .sal file that you have saved on your computer, select the file and click *Open*.
5. Select *Continue*.
6. When process is complete, the dialog box will say *File uploaded successfully*.
7. Click *Close*. 
8 Re-scan all devices in System Setup to automatically instantiate the latest graphics.

NOTE Removing the check by Discover Tables will speed up the process.
Troubleshooting i-Vu CCN Pro

Manual commands

To run a manual command:

1. Click **Main Menu** then select **Manual Command**.
2. Type the manual command in the dialog box, then click **OK**.

**TIP** Ctrl+M also opens the dialog box.

You must have the **Installer Role** to access the manual commands dialog box.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>bbmd commands:</strong></td>
<td>You must have the Manual Commands/Adv Network privilege to run bbmd commands.</td>
</tr>
</tbody>
</table>
| bbmd read <IP address> | Reads the BBMD table of the controller at the given IP address. For example, to display the BBMD table in the BACnet device router at IP address 154.16.12.101, type: `bbmd read 154.16.12.101`
| bbmd update <network number> | Selects BBMDs on the specified network and marks them for download. If no network is entered at the end of the command, all networks in the system are scanned. For example, if the network number is 888, type: `bbmd update 888`
| bbmd view <network number> | Views the list of BBMDs that have been selected for the network number at the end of the command. Assumes the update has been run. For example: `bbmd view 888`
| bbmd write <table file> <IP address> | Writes the BBMD table into the controller at the given IP address. See To set up BBMDs using i-Vu CCN Pro. For example, to write the BBMD table in dallasbbmd.bdt into the BACnet device router at IP address 154.16.12.101, type: `bbmd write dallasbbmd.bdt 154.16.12.101`
| bbmd clear <IP address> | Clears the BBMD for the specified controller. For example: `bbmd clear 154.16.12.101`
| bbmd dump <network> <file> | Writes to a file the BBMD from the specified controller. For example: `bbmd dump 888 dallasbbmd.bdt`
<p>| commstat          | Gives a complete set of diagnostic information for all defined connections.  |</p>
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>copy</td>
<td>Displays a global copy utility that allows you to selectively copy trend graphs, custom reports and all editable properties from the selected equipment to other equipment in the system with the same control program.</td>
</tr>
<tr>
<td>debug</td>
<td>Displays information for advanced technical support</td>
</tr>
</tbody>
</table>
| go <refname or path> | Goes to the point in the system that is referenced. For example:  
>   go #oa_conditions  
> or  
>   go vav_1/m28                                                                                                                                 |
| logoffuser       | Logs off a user (without warning the user). Type a whoson manual command to view the IDs of logged in operators, then type logoffuser x, where x is a the user's ID. |
| modstat          | Displays status of the controller at the current location, including:  
>   - Hardware components of the device  
>   - Software components of the device  
>   - Error conditions that may exist in the device  
>   - Date and time the device is using |
| notify           | Sends a message to all operators currently logged in to the system. For example, "The server is going to shut down in 5 minutes. Please log off." To run this command, type: notify your message. The message must use only alphanumeric characters. |
| ping             | Ping to verify communication between two IP devices. You cannot ping devices on non-IP networks. To run this command type: ping <hostname> where <hostname> is the IP address or device name. For example:  
>  ping 192.168.168.1  
> (will ping the IP address 4 times)  
> or  
>  ping 192.168.168.1 -t  
> (will ping the IP address constantly) |
| rebootserver     | Restarts i-Vu CCN Pro server. You must have the Installer or Administrator role to run this command.                                           |
| whereami         | For the current location, displays the full path and gives the reference names of the action button, category, item and tab. You use these reference names when you create links in ViewBuilder. |
| whoson           | Shows the list of users currently logged in to the i-Vu CCN Pro system, the IP addresses from where they are logged on, what kind of interface they are using (for example, lvl5 for an Internet browser on a computer), and how long it has been since they have actively interfaced with the i-Vu CCN Pro system. |
## TCP/UDP Port Usage

<table>
<thead>
<tr>
<th>Port</th>
<th>Protocol/User</th>
</tr>
</thead>
<tbody>
<tr>
<td>tcp*:80</td>
<td>http (Web Server)</td>
</tr>
<tr>
<td>tcp *:443</td>
<td>https (Web Server)</td>
</tr>
<tr>
<td>udp *:68</td>
<td>DHCP Client daemon</td>
</tr>
<tr>
<td>udp *:137</td>
<td>nmbd (netbios/tcp requests)</td>
</tr>
<tr>
<td>udp *:138</td>
<td>nmbd (netbios/tcp responses)</td>
</tr>
<tr>
<td>udp *:47808</td>
<td>Bacnet/IP</td>
</tr>
<tr>
<td>udp *:47812</td>
<td>CCN/IP</td>
</tr>
<tr>
<td>Udp *:50005 to 50008</td>
<td>Firmware CCN/IP</td>
</tr>
<tr>
<td>udp *:47806</td>
<td>Alarm Pop-up Client</td>
</tr>
</tbody>
</table>

**NOTE**
- These ports are used by the i-Vu Server. i-Vu CCN Pro listens through these ports.
- SOAP uses the HTTP port.
- The alarm pop-up is defined through System Options > General.
- All CCN/IP and BACnet/IP ports have to be exposed if the connection between the i-Vu Server and the device managers contain a firewall.
- All other ports are not configurable.

## FAQ - Frequently Asked Questions

*How do I set up the CCN Time Broadcaster?*

i-Vu CCN Pro defaults as the CCN Time Broadcaster. You must set the clock in i-Vu CCN Pro in Main Menu > System Options > System Settings > General tab.

*Where do I find out the details of the capabilities of the different privileges available for Login?*

Refer to System Options > Privilege Sets (page 35) for details.

*I noticed that the back/forward buttons in the browser don’t work.*

You must use the navigation inside the i-Vu CCN Pro interface.

*Can I use Firefox?*

At this time, i-Vu CCN Pro only supports the use of the Internet Explorer v6 and later web browser.

*Can I Ctrl-select Alarms to acknowledge them?*

No, you can either select a single alarm or all alarms.

*I’ve noticed that my settings for a Comfort Controller or UC disappeared.*

The default graphic for a Comfort Controller and UC is a tabular display of points that have been enabled in i-
Vu CCN Pro. Once a custom graphic is assigned to this controller, it is not possible to revert to the default view without deleting and rescanning the controller. This will cause you to lose all currently mapped points.

**"How do I change the time in a controller?"**
You must use Comfort View or Network Service Tool or select **Time Sync** on the **Main Menu > System Options > System Settings > General** tab.

**"I've noticed the Navigation buttons sometimes do not work. What is wrong?"**
This will occur when you start editing a page or changing a value in i-Vu CCN Pro. This will require you to Accept or Cancel the action which appears at the top of the open window. Navigation is disabled until you Accept or Cancel the change.