Snap v7.0
Help

CARRIER CORPORATION ©2018
A member of the United Technologies Corporation family · Stock symbol UTX · Catalog No. 11-808-679-01 · 7/3/2018
Verify that you have the most current version of this document from www.hvacpartners.com or your local Carrier office.

Important changes are listed in Document revision history at the end of this document.

CARRIER CORPORATION © 2018. All rights reserved throughout the world. i-Vu is a registered trademark of Carrier Corporation. All other trademarks are the property of their respective owners.

The contents of this guide and the associated Carrier software are property of Carrier Corporation and its respective licensors, and are protected by copyright. For more information on the software and licensing, see the About section in the software's Help menu.

The content of this guide is furnished for informational use only and is subject to change without notice. Carrier Corporation assumes no responsibility or liability for any errors or inaccuracies that may appear in the informational content contained in this guide. This document contains no technical data controlled by the EAR or ITAR.
# Contents

What is Snap? ................................................................. 1
What’s new in the Snap v7.0 application ................................. 2
Getting to know Snap ....................................................... 3
Developing the logic ........................................................ 5
  - To begin a control program ............................................. 5
  - To place microblocks ..................................................... 6
  - To draw wires and labels ................................................ 7
  - To view errors ............................................................ 9
  - To add text .................................................................. 9
  - To add lines and shapes ................................................. 10
  - To add an image ........................................................ 12
  - To select properties for ViewBuilder graphics ................. 12

Formatting Properties pages ............................................. 13
  - To reorder items on the Properties page ......................... 13
  - To use the Text microblock to format text ....................... 14
  - Operators .................................................................. 17
  - Editing Properties page text using special characters ....... 18
  - Formatting a microblock property ................................... 19

To use custom alarm and schedule categories ..................... 24

Simulating a control program .......................................... 25

Snap productivity tools .................................................... 27
  - To create and use symbols ............................................. 27
  - To view or edit microblock common properties ............... 28
  - To find a microblock, label, or text in the workspace ......... 29
  - To find and replace text in a microblock, label, or text entry field ................................................................. 30
  - To find identical labels .................................................. 30
  - To show a logical path .................................................. 31
  - To show a wire’s source microblock ................................ 31

Defining options for sensors ............................................. 32
  - To set the order of information displayed on a ZS sensor ................................................................. 32
  - To create custom Rnet tags ............................................ 33

Miscellaneous Snap menu commands and features ............. 34

Working with control programs for non-English systems ....... 35
  - Creating control programs and translation files for a non-English system ................................................................. 35
    - To enter a key term in the Snap application ................................................................. 35
    - Translation files ................................................................ 36
    - To create and implement a translation file ................................................................. 36
  - Editing translation files, control programs, or graphics for a non-English system ................................................................. 38
    - To edit a bundled resource ................................................................. 38
    - Editing a control program in the Snap application ................................................................. 38
    - Copying translation files to another system ................................................................. 39

Creating Snap programs to use in I-Vu® Open Controllers .... 40
  - Create a control program ................................................................. 40
  - Example: Limit heating stages ................................................................. 43
  - UPC Open control program ................................................................. 45

Document revision history .................................................. 50
You can use the Snap application to create control programs to control equipment, from single pieces of equipment to complex functions.

You build control programs using individual blocks of programming code called microblocks. You determine the properties for each microblock and connect the microblocks with graphical wires to create a sequence of operation.

A control program is assigned to a piece of equipment in the i-Vu®/Field Assistant application, then downloaded into the controller that will directly control and monitor the equipment. You can change editable properties and view non-editable properties of control programs in the i-Vu®/Field Assistant interface.

Use the following steps to create a control program:

1. Develop the logic (page 5).
2. Format Properties pages (page 13).
3. Simulate the control program (page 25).
### What's new in the Snap v7.0 application

<table>
<thead>
<tr>
<th>Feature</th>
<th>Improvement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Support for the following new optional features has been added to Snap. When released, you can download them from <a href="https://accounts.ivusystems.com/tsaplctrackweb.nsf/download">https://accounts.ivusystems.com/tsaplctrackweb.nsf/download</a> under Technician Tools Software and Updates &gt; v7.0 installs and updates or <a href="http://hvacpartners.com/Pages/PS/Software/ControlsDownloads/aspx">http://hvacpartners.com/Pages/PS/Software/ControlsDownloads/aspx</a> under I-Vu SAL Files and Updates.</td>
<td></td>
</tr>
<tr>
<td>Improved Edit Order</td>
<td>Provides more flexibility and reduces the time needed to create property pages for equipment.</td>
</tr>
<tr>
<td>Translation Assistance Tool</td>
<td>Simplifies the process of creating non-English control programs.</td>
</tr>
</tbody>
</table>
Getting to know Snap

- If the **Property Editor** is not visible, double-click an object in the workspace, unless it is a restricted microblock.
• A restricted microblock has been added by the factory and has a red outline and line through it. Your ability to interact with these microblocks is limited. You cannot add inputs or outputs, though you can re-wire them. If you remove or delete a restricted microblock, you cannot add it back once you exit Snap.

• You can use the Property Editor as a free-standing window, or you can select Options > Dock Property Editor to dock it in the Snap window.

• Keyboard shortcuts are shown beside their corresponding commands in the menus.

• Press Ctrl + an arrow key to nudge selected objects. Press Shift+Ctrl while using the arrow keys to increase the size of the nudge.

• Click 🔄 to undo 1 action, or click the drop-down arrow next to it to undo multiple actions at one time. Click 🔄 or its drop-down arrow to redo actions. The number of actions you can undo or redo depends on the size of your computer's memory.

• The workspace size has no limit.

• Press Home to position the upper left corner of the workspace in the upper left corner of the window.

• Press End to jump to the bottom of the control program.

• Use the arrow keys or your mouse's scroll wheel to scroll through the workspace.

• From the Options menu you can:
  ○ Hide or show the workspace grid
  ○ Enable Snap Figures and Text to Grid to constrain movement to 8 pixels for quick alignment; disable this feature for 1-pixel movement
  ○ Zoom the view to 50, 100, or 200%
Developing the logic

Use the following procedures to develop your control program.

NOTES

• Make sure a control program broadcasts a single color by using one of the following:
  ○ 1 Setpoint microblock
  ○ 1 Set Color microblock
  ○ 1 or more Set Color If True microblocks
• Each Time Clock microblock in a control program must have a unique schedule category.
• To use one or more ZS or Wireless Sensors, the control program must have one Sensor Binder microblock and one of the following microblocks for each value type that will be read from the sensor network:
  ○ BACnet Analog Sensed Value Input microblock – For values such as temperature or humidity
  ○ BACnet Binary Sensed Value Input microblock – For values such as occupied/unoccupied
• To use an SPT sensor, the control program must have an RS Zone Sensor microblock.

To begin a control program

The Snap application creates a .equipment file that is the control program that you download into a controller.

1 In the application, select one of the following in the Control Program menu:
  ○ CCN for downloading into an i-Vu® CCN Router or i-Vu® Link.
  ○ i-Vu® Integrator for downloading into an i-Vu® Integrator
  ○ Open (non-PIC) for downloading into:
    ▪ AppController (OPN-APP)
    ▪ Carrier® ChillerVu™ (OPN-PSM-MPCXPE and OPN-PSM-SIM)
    ▪ i-Vu® Open Link (OPN-OL)
    ▪ MPC Open XP (OPN-MPCXP)
    ▪ UC Open (OPN-UC)
    ▪ UC Open XP (OPN-UCXP)
    ▪ UPC Open (OPN-UPC)
  ○ PSM for downloading into a Carrier® ChillerVu™ controller

2 Select File > Save As.
  ○ i-Vu® Standard/Plus - browse to a convenient location.
  ○ i-Vu® Pro - browse to the i-Vu_Pro_xx\webroot\<system_name>\programs folder.
3 Name the .equipment file. The name must:
- Begin with a letter.
- Not contain spaces or periods.
- Be unique throughout a i-Vu®/Field Assistant system.

4 Click **Save**.

**NOTES**

- A Carrier® ChillerVu™ (PSM) control program from EquipmentBuilder may contain custom microblocks that are locked and cannot be edited. These blue microblocks are outlined in red with a line drawn through them.
- Select **File > Info** to view the file's name, location, and dates.
- To use °C for setpoint microblocks, select **Control Program > Metric** before making the control program. If you change the **Metric** option for an existing control program, you must delete and reinsert all setpoint microblocks.

To enable **Metric** for all future control programs, select **Options > Preferences**, then select **Create new control programs as metric**.

---

**To place microblocks**

1 Right-click the microblock palette.

2 Click the icon of the microblock you want to use.

3 Move the cursor into the workspace.

**NOTE** Press and hold **Shift** if you want to place 2 or more of the selected microblocks.
4. Click to place the microblock.
5. Edit the microblock’s properties in the Property Editor.

NOTES
- If the Property Editor is not open, double-click the microblock.
- Red text in a field indicates an invalid value.
- You can right-click some properties and select Make Editable or Make Read-Only to determine that property's functionality in the i-Vu®/Field Assistant interface.

TIPS
- Place all input microblocks on the left side of the workspace and all output microblocks on the right.
- Arrange microblocks so that logic flows from left to right and the sequence of operation can be easily followed.
- Hold Ctrl as you move a microblock to detach it from its wire.
- Use the Microblock Common Properties Editor (page 28) to view, compare, and edit common properties of I/O microblocks.
- You determine the appearance of items on the i-Vu®/Field Assistant Property Page > Equipment tab by how you order the microblocks in your control program in Snap. To change the order, see To reorder items on the Properties page (page 13).

To draw wires and labels

Wires are special lines in a control program that transmit values from one microblock to another. Solid wires transmit analog data; dashed wires transmit binary data. Wires connect microblock inputs and outputs. They can also connect to other wires.

Output and input labels connect items just as wires do. Use labels when a value is needed in several places within a control program or when wires would clutter or complicate the control program.
To draw wires

1. Hold your cursor over a microblock nib until the cursor changes to crosshairs, then click and drag in the direction you want the wire to go.

   **NOTE** A wire automatically makes a 90° turn if you drag away from a straight line. To create additional 90° turns, right-click while continuing to hold down the left mouse button.

2. Release the left mouse button to end the wire.

   **NOTES**
   - The red error indicator at the microblock's nib disappears if the wire connected properly.
   - When drawing wires between closely placed microblocks, you can temporarily disable the snap-to feature by pressing Ctrl while drawing a wire.

To change an existing wire

**NOTE** If you move a microblock, connected wires move with it.

1. Right-click the wire, then select *Edit Shape*.

2. Do one of the following:
   - Click and drag any wire segment in the direction of the move icon.
   - Right-click where you want to add a joint on a wire, then select *Add Joint*.
   - Right-click a green wire joint, then select *Remove Joint*.
   - Click a wire, then select a different wire from the *Type* drop-down list.

To add labels

1. Select the *Label* tool.

2. Move the cursor to the nib of a microblock or to the end of a wire, then click the workspace.

   **TIP** To quickly change the label's direction, press I (for Input label) or O (for Output label) while moving the label.

3. Type a name in the *Label Text* field of the *Property Editor*.

   **NOTE** If the *Property Editor* is not open, double-click the label.

4. Optional: Change the *Direction* of the label in the *Property Editor*. 
To change a label’s text

1. Select the label.
   
   **NOTE** To locate the label, see *To find a microblock, label, or text* (page 29).

2. Edit the **Label Text** field.
   
   **NOTE** If the **Property Editor** is not open, double-click the label.

3. Optional: Click **Rename all labels named ‘...’** to change all labels that have the same label text.

To view errors

The Snap application checks for errors as you build your control program and indicates errors with red dots, wires, and boxes.

1. Click in the lower right corner or select **Control Program > Errors** on the menu bar to view the errors.

2. Click an error in the list to highlight its location in the workspace.

   **NOTE** You cannot download a program that has errors.

To add text

Use the Text tool to add descriptive text to the control program.

1. Select the Text tool.

2. Click in the workspace where you want the text to begin.
3 Edit the text and its properties in the Property Editor. See table below.

**NOTE** If the Property Editor is not open, double-click the text.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Type the comment you want to add to the control program.</td>
</tr>
<tr>
<td>Font</td>
<td>Select a font. Be sure that all system computers have the font installed.</td>
</tr>
<tr>
<td>Size</td>
<td>Choose a point size from the drop-down list.</td>
</tr>
<tr>
<td>Style</td>
<td>Check <strong>Bold</strong>, <strong>Italics</strong>, or both.</td>
</tr>
<tr>
<td>Foreground</td>
<td>Click the color swatch to select the color of the text.</td>
</tr>
<tr>
<td>Transparent Background</td>
<td>Check to remove the background color and pattern.</td>
</tr>
<tr>
<td>Background</td>
<td>Click the color swatch to select the color of the box behind the text.</td>
</tr>
</tbody>
</table>

**NOTE** To change the default settings for all text that you will add to the control program, select Options > Palette. Change the settings on the Font tab.

**To arrange text blocks**

1 Select 1 or more text blocks.

2 Right-click one of the text blocks, then select 1 of the following:
   - **Bring Forward**
   - **Bring to Front**
   - **Send Backward**
   - **Send to Back**

**To add lines and shapes**

Use lines and shapes to organize and clarify the control program.

![Line, Rectangle, Ellipse, Arc, Dot, Polygon](image)
To draw a line or polygon

1 Select the line or polygon tool.

   NOTE To draw multiple similar figures, press and hold Shift as you draw them.

2 To begin drawing the figure in the workspace, click and hold the left mouse button as you move the mouse.

3 While holding down the left mouse button, right-click to add angles.

4 Release the left mouse button to complete the line or polygon.

   NOTE To change the shape of an existing figure, right-click the figure, then select Edit Shape. Click and drag a green point to move it.

To draw a rectangle or ellipse

1 Select the rectangle or circle tool.

   NOTE To draw multiple similar figures, press and hold Shift as you draw them.

2 Click and drag in the workspace to begin drawing the figure.

3 Release the mouse to complete the rectangle or ellipse.

   NOTE Hold Ctrl while you drag to draw a square or a circle.

To change the color or pattern of figures

To change:

- The color or pattern of a selected figure, click the appropriate rectangle in the Property Editor, and then make your selection. If the Property Editor is not open, double-click the figure.

   NOTE Select the red cross-hatch pattern for no fill.

- The color or pattern of multiple selected figures, select Options > Palette.

   NOTE Select the red cross-hatch pattern for no fill.

- The default color or pattern for all figures that you will draw, select Options > Palette.

To arrange figures

1 Select 1 or more figures.

2 Right-click 1 of the figures, then select 1 of the following:

   • Bring Forward
   • Bring to Front
   • Send Backward
   • Send to Back
To add an image

Select Edit > Insert Image to add a .gif, .png, .jpg, or .bmp image to your control program.

**NOTE** Your image must be created with a standard 256 color palette. Anything greater will be reduced to 256 colors and may not display correctly in i-Vu®/Field Assistant.

To select properties for ViewBuilder graphics

The Snap application lets you select the microblock property values that you want to appear on a i-Vu®/Field Assistant graphic. This allows the graphics creator to see the property values and quickly obtain their paths in ViewBuilder. These microblock property selections are saved when you save the control program.

1. Right-click a microblock in the workspace, then choose Select Properties For Graphics.
2. Check any property whose value you want to display on a graphic.
   **NOTE** To see all properties, clear the checkbox Show properties typically shown on graphics.
3. Optional: To add a comment for a property such as "Do not include units", select the property and then click , or you can double-click the property.

   **NOTE** Select Control Program > Properties For Graphics to see all the properties that you selected in the control program. In the Comments box, you can type a comment that is not for a specific property. To delete a property, select it and then click .
Making a control program automatically creates a i-Vu®/Field Assistant Properties page. The initial properties displayed on a Properties page are defined in the Snap Property Editor.

i-Vu® Pro only - To preview Properties pages in the i-Vu® interface without connecting to the controllers, run i-Vu Pro Design Server instead of i-Vu Pro Server.

In the control program, you can change the way text appears on the Properties page by using a Text microblock or by editing a microblock's Property Page Text field in the Property Editor.

NOTE If you change a control program after downloading it to the controller, you must:

1. Save the .equipment file.
2. Reload the control program. See "Working with control programs" in i-Vu®/Field Assistant Help.
3. Download the control program. See "Downloading to controllers" in i-Vu®/Field Assistant Help.

To reorder items on the Properties page

1. Select Reorder > Edit Order.
2. Select the microblock(s) you want to move. Ctrl+click or Shift+click to select and move multiple microblocks.
3. Use the buttons at the right to move, cut, or paste microblocks.
4. Click OK.
NOTES

- To find a single microblock in the Edit Order dialog box, do one of the following:
  - Right-click the microblock in the workspace, then select Show in Edit Order.
  - In the Edit Order dialog box, click to search for the microblock.

- To edit a microblock's Property Page Text from the Edit Order dialog box, do one of the following:
  - Double-click the microblock.
  - Select it and then click.

To use the Text microblock to format text

The Text microblock allows you to format text, add horizontal lines, and arrange items on the Properties page. Text microblocks placed in a control program in the Snap application are not visible on the Field Assistant Logic page.

1. Place a Text microblock in the workspace to the right of the microblock logic.
2. In the Property Editor, select a format option from the Type drop-down list. See table below.
   
   NOTE: If the Property Editor is not open, double-click the microblock.
3. Type text in the Property Page Text field.

<table>
<thead>
<tr>
<th>Text Type</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plain</td>
<td>For creating plain text.</td>
</tr>
<tr>
<td>Separator</td>
<td>To create a horizontal line on the Properties page, often used to offset or group information, choose Separator as the Text Type. If you would like text to appear on the separator line, type the text in the Property Page Text field.</td>
</tr>
<tr>
<td>Bold</td>
<td>For creating bold text.</td>
</tr>
<tr>
<td>Expand Begin Closed</td>
<td></td>
</tr>
<tr>
<td>Expand Begin Opened</td>
<td></td>
</tr>
<tr>
<td>Expand End</td>
<td>To format a section using expanded formatting, first insert a Text microblock with the Text Type set as Expand Begin Closed or Expand Begin Opened, depending on how you want the area to display when first viewed. If you would like text to appear on your expandable line, type the text in the Property Page Text field.</td>
</tr>
</tbody>
</table>

Expand Begin Closed

Expand Begin Opened

You must also insert a Text microblock with the Text Type set as Expand End at the end of the section you wish to group together.
To align data in a table, insert a Text microblock with the Text Type set as Table Begin. To complete the table, insert a Text microblock with the Text Type set as Table End after the last item you want to include in the table.

**Zone Setpoint Control**

<table>
<thead>
<tr>
<th>Zone Temp</th>
<th>(RS)</th>
<th>72.4 °F</th>
<th>Lock at value:</th>
<th>90.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demand Level</td>
<td>(ANI) 0</td>
<td>Lock at value:</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>AHU RA CO2</td>
<td>(ANI) 400</td>
<td>Lock at value:</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>AHU SA Temp</td>
<td>(ANI2) 60.2</td>
<td>Lock at value:</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>OA Temp</td>
<td>(ANI2) 71.8</td>
<td>Lock at value:</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE** When working with a table within an expanded section, make sure the table begins after the Expand Begin and ends before the Expand End.

You can hide part of the Properties page based on a value from a specific microblock. For example, you can specify that the Properties page text from an Analog Input microblock will only appear on the Properties page if the value is above 85. The expression is evaluated relative to the entire control program, not at that particular microblock.

Place a Text microblock with the Text Type set as Conditional Hide Begin before the microblock to be evaluated and another set to Conditional Hide End after it. Type a conditional expression in the Properties Page Text field of the Text microblock. Microblock properties may be referenced between the dollar signs ($), and the expression must be Boolean. For example, to show the microblock Properties page text only when the present value of the point named Zone Temp is greater than 85, the expression would be "$Zone_Temp/present_value$ >85".

See Operators (page 17) for more information.

**NOTES**

- When referring to the name of a point, use the RefName rather than the Display Name.
- Technical Support does not provide assistance with writing and editing Javascript. See Javascript textbooks, available in most bookstores, for help with Javascript.

**TIP** If you are adding the Conditional Hide formatting after the control program has been designed or would prefer to group all of the Text microblocks within the control program, use the Reorder menu to correctly place the Text microblocks.

These options are currently not used.
**To correctly order Begin/End Text microblocks**

When adding Text microblocks in the Snap application that have a **Begin** or **End** text type, you must define the correct order for the microblocks so that the text appears correctly on a Properties page. Each **Begin** microblock must be followed by an **End** microblock, and you can have a set of **Begin/End** microblocks inside of another set of **Begin/End** microblocks. The initial order of the Properties page text is the order in which you add microblocks to the workspace. Moving the microblocks will not correct the Properties page order. If the microblocks are outlined in yellow, your **Begin/End** microblocks are out of order. In the example below, the order of the first and fourth microblocks are reversed.

![Diagram showing the order of Begin/End microblocks](image)

**Begin/End order based on intial placement:**

1. **Expand End**
2. **Table Begin**
3. **Table End**
4. **Expand Begin Opened**

To correct the order, you can either change the microblocks' **Type** selection in the Property Editor, or select **Reorder** > **Edit Order**. See *To reorder items on the Properties page* (page 13).
Operators

An operator defines how each piece of an expression is to be handled. For example, an operator can compare or perform an action between the value of a microblock property, a literal value, or the result of an expression. The following table lists operators that can be used in expressions.

### Path Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>$path$</td>
<td>Get value</td>
<td>Gets the value of the path</td>
</tr>
<tr>
<td>??path??</td>
<td>Check for presence</td>
<td>Checks for the existence of the path. If it exists, the expression is true. If it does not, the expression is false.</td>
</tr>
</tbody>
</table>

### Operators that return true/false

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>Compares numeric data. Returns true if the value to the left of the operator is smaller than the value to the right.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>Compares numeric data. Returns true if the value to the left of the operator is larger than the value to the right.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>Compares numeric data. Returns true if the value to the left of the operator is smaller than or equal to the value to the right.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>Compares numeric data. Returns true if the value to the left of the operator is larger than or equal to the value to the right.</td>
</tr>
<tr>
<td>!</td>
<td>Not</td>
<td>Evaluates the expression and returns the opposite. Example: !$zone_temp/locked$; if zone_temp/locked is true, the expression is false. If zone_temp/locked is false, the expression is true.</td>
</tr>
<tr>
<td>==</td>
<td>Equal to</td>
<td>Compares data. Returns true if the value on both sides of the operator are equal.</td>
</tr>
<tr>
<td>!=</td>
<td>Not equal to</td>
<td>Compares data. Returns true if the value to the left of the operator does not match the value to the right.</td>
</tr>
<tr>
<td>&amp;&amp;</td>
<td>And</td>
<td>Combines expressions. Returns true if the expressions on both sides of &amp;&amp; result in true. For example: $zone_temp/locked$==false &amp;&amp;$zone_temp/present_value$&gt;75 ?&quot;#FF0000&quot;:&quot;#FFF660&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Operators that return a numeric value

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Add</td>
<td>Adds numeric data, expressions, or values.</td>
</tr>
<tr>
<td>-</td>
<td>Subtract</td>
<td>Subtracts numeric data, expressions, or values.</td>
</tr>
<tr>
<td>*</td>
<td>Multiply</td>
<td>Multiplies numeric data, expressions, or values.</td>
</tr>
<tr>
<td>/</td>
<td>Divide</td>
<td>Divides numeric data, expressions, or values.</td>
</tr>
<tr>
<td>%</td>
<td>Modulus</td>
<td>Finds the remainder in the division of numeric data, expressions, or values.</td>
</tr>
</tbody>
</table>

### Other operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>( )</td>
<td>Parentheses</td>
<td>Use to nest expressions. Operations in parentheses are evaluated before those outside parentheses.</td>
</tr>
</tbody>
</table>
## Editing Properties page text using special characters

For many microblocks, you can edit or format Properties page text in the microblock's Property Page Text field using special characters described below.

<table>
<thead>
<tr>
<th>To...</th>
<th>In the Property Page Text field, type...</th>
<th>Example</th>
</tr>
</thead>
</table>
| Display a microblock property | The microblock property between 2 dollar signs<br>See Microblock Reference Help for property reference names.<br>See Formatting a microblock property (page 19). | The value is $Present_Value$
Displays: The value is 69. |
| Make a column-aligned table | \{ to begin a table, then \} to end the table<br>[ to begin a row, then ]^[ to end a row.<br>Exception: Type ] to end last row in table.<br>\| (a pipe) to align cells | \{[[History Recorder: Current cycle = $Current/Latched_Value$] on $Current/Latched_Time$|$Current/Latched_Date$]<br>[since|$Current/Reset_Time$|$Current/Reset_Date$]^$<br>\{[[Previous cycle = $Previous/Latched_Value$] on $Previous/Latched_Time$|$Previous/Latched_Date$]<br>[since|$Previous/Reset_Time$|$Previous/Reset_Date$]}<br>Displays: |
| Hide default text | ^## if Property Page Text field is empty.<br>If the Property Page Text field shows the default text, delete the text. | |
| Display two microblock properties on the same line | ^$ at the end of the text for the first microblock | MB#1: Enable when Supply Temp is more than $Constant$ (F) ^$<br>MB#2: Disable when $Hyst$ (F) below Zone Temp.<br>Displays: |
| Enable when Supply Temp is more than \[ (°F) Disable when \[ (°F) below Zone Temp. | |
| Begin a new line of text | ^\ where you want a new line to begin | Time for daily trend report:^\ ___ hh:mm 24 hr<br>Displays: Time for daily trend report:<br>02:00 hh:mm 24 hr |
## Formatting a microblock property

To add a microblock property in a microblock’s **Properties Page Text** field, type the property between 2 dollar signs. For example, `$current_Value$`. This is called an expression.

Each microblock property has default formatting that determines how it looks on the Properties page. You can change the way it looks by adding a control and one or more parameters to the expression.

**EXAMPLES**

- To display the present value of Duty cycle in a time format that shows minutes and seconds, type
  
  `$Present_Value:control="minsec"$`

- To display the Period microblock property in a time format that shows minutes and seconds and make it editable, type `$Period:control="minsec" editable="true"$`.

### Breakdown of an expression

1. `$Period:control="minsec" editable="true"$
2. `$\$\{\}\$`
3. `\` at the beginning of the text and
4. `\` at the end
5. `$x`, where x is the character you want to display

*NOTE* Must be enabled for... Displays:

*NOTE* Must be enabled for...
The entire expression is between 2 dollar signs.

1. **A microblock property**  Example:  Period

2. **A colon**
   Type a colon after the microblock property to add a control.

3. **control=**
   A control determines how a property is displayed on the Properties page. Include a `control=` statement in the expression only if you want to use a control other than the default. Type `control=` followed by the control name.

4. **A control**  Example:  "minsec"
   Type the control between quotation marks. See table below.

5. **A space**
   Type a space after a control statement or a parameter statement.

6. **A parameter**  Example:  `editable=`
   You can add one or more parameters to the expression. To specify a control, type the name of the parameter (see table below), an equal sign, and then a value.

7. **A parameter value**  Example:  "true"
   See table below.
Controls and parameters

A microblock property data type determines the type of control that can be used.

<table>
<thead>
<tr>
<th>To display a...</th>
<th>Data must be.</th>
<th>4 Control</th>
<th>6 Parameter</th>
<th>7 Parameter value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Checkbox</td>
<td>Boolean</td>
<td>button</td>
<td>type</td>
<td>WidgetImageButton.TOGGLE</td>
</tr>
<tr>
<td></td>
<td>Example: A binary parameter's present value</td>
<td></td>
<td>editable</td>
<td>true or false (Default value is true.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>truewhendown</td>
<td>Check mark appears when the value is false instead of true.</td>
</tr>
<tr>
<td>Radio button</td>
<td>Boolean</td>
<td>button</td>
<td>type</td>
<td>WidgetImageButton.RADIO</td>
</tr>
<tr>
<td></td>
<td>Example: A binary parameter's present value</td>
<td></td>
<td>editable</td>
<td>true or false (Default value is true.)</td>
</tr>
<tr>
<td></td>
<td>or</td>
<td></td>
<td>truewhendown</td>
<td>Button is selected when the value is false instead of true.</td>
</tr>
<tr>
<td></td>
<td>Integer</td>
<td></td>
<td></td>
<td>true or false (Default value is true.)</td>
</tr>
<tr>
<td></td>
<td>Example: An analog parameter's present value</td>
<td></td>
<td>index</td>
<td>any integer (Default value is null.)</td>
</tr>
<tr>
<td></td>
<td>or</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Enumerated</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Example: A binary, analog, or multi-state parameter's present value</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Text</td>
<td>Character string</td>
<td>charstring</td>
<td>editable</td>
<td>true or false (Default value is true.)</td>
</tr>
<tr>
<td></td>
<td>Example: A point's display name</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>Date</td>
<td>date</td>
<td>editable</td>
<td>true or false (Default value is true.)</td>
</tr>
<tr>
<td></td>
<td>Example: A wire lock's begin date/end date</td>
<td></td>
<td>hasdayofweek</td>
<td>Displays the day of the week with the date.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>true or false (Default value is true.)</td>
</tr>
<tr>
<td>To display a...</td>
<td>Data must be.</td>
<td>4 Control</td>
<td>6 Parameter</td>
<td>7 Parameter value</td>
</tr>
<tr>
<td>----------------</td>
<td>--------------</td>
<td>-----------</td>
<td>-------------</td>
<td>------------------</td>
</tr>
<tr>
<td><strong>Number</strong></td>
<td>Integer</td>
<td>number</td>
<td>editable</td>
<td>true or false</td>
</tr>
<tr>
<td></td>
<td>(no decimal)</td>
<td></td>
<td></td>
<td>(Default value is true.)</td>
</tr>
<tr>
<td></td>
<td>Example: An analog parameter's present value</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>or</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Real</td>
<td></td>
<td></td>
<td>number of digits</td>
</tr>
<tr>
<td></td>
<td>(has decimal)</td>
<td></td>
<td></td>
<td>(Default value is null.)</td>
</tr>
<tr>
<td></td>
<td>Example: An analog parameter's present value</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>or</td>
<td></td>
<td></td>
<td>number of digits</td>
</tr>
<tr>
<td></td>
<td>Unsigned</td>
<td></td>
<td></td>
<td>(Default value is null.)</td>
</tr>
<tr>
<td></td>
<td>Example: Any point's expander number</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Droplist</strong></td>
<td>Enumerated</td>
<td>droplist</td>
<td>editable</td>
<td>true or false</td>
</tr>
<tr>
<td></td>
<td>Example: A binary, analog, or multi-state parameter's present value</td>
<td></td>
<td></td>
<td>(Default value is true.)</td>
</tr>
<tr>
<td><strong>Time</strong></td>
<td>Time</td>
<td>time</td>
<td>editable</td>
<td>true or false</td>
</tr>
<tr>
<td></td>
<td>Example: A wire lock's begin time/end time</td>
<td></td>
<td></td>
<td>(Default value is true.)</td>
</tr>
</tbody>
</table>

- **digits_right_of_decimal**
  - (real number only)
  - number of digits
  - (Default value is null.)
- **digits_left_of_decimal**
  - number of digits
  - (Default value is null.)
- **showplussign**
  - true or false
  - (Default value is false.)
- **scalingfactor**
  - Multiplies the actual value by the scalingfactor value.
  - Example: to convert watts to kilowatts, use .001 as the scaling factor value.
  - any floating point number except 0
  - (Default value is 1.)
- **displaywhat**
  - One of the following:
    - ControlTimeInput.HMSD
    - ControlTimeInput.HMS
    - ControlTimeInput.MSD
    - ControlTimeInput.HM
    - ControlTimeInput.SD
    - ControlTimeInput.MS
    - ControlTimeInput.H
    - ControlTimeInput.M
    - ControlTimeInput.S
    - ControlTimeInput.D
  - where H=hour, M=minutes, S=seconds, D=milliseconds
  - (Default value is ControlTimeInput.HMSD.)
<table>
<thead>
<tr>
<th>To display a...</th>
<th>Data must be...</th>
<th>4 Control</th>
<th>6 Parameter</th>
<th>7 Parameter value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timer</td>
<td>Unsigned numbers used as a timer</td>
<td>control</td>
<td>sec</td>
<td>true or false (Default value is true.)</td>
</tr>
<tr>
<td>60 00 mm:ss</td>
<td>Example: A duty cycle's time</td>
<td></td>
<td></td>
<td>scalingfactor</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>showhours</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>showseconds</td>
</tr>
</tbody>
</table>
To use custom alarm and schedule categories

A i-Vu®/Field Assistant system has pre-defined alarm and schedule categories. But, you can add custom categories in the Snap application, then add the same custom category in the i-Vu®/Field Assistant interface. See "Using schedule categories" and "Alarm categories" in i-Vu®/Field Assistant Help.

To add a custom category in the Snap application

1. Select Options > Preferences.
2. On the Alarm/Schedule Categories tab, select the Alarm Category tab to create a custom alarm category, or select one of the following Sched. Category tabs.

<table>
<thead>
<tr>
<th>Select this tab...</th>
<th>To create a schedule category for this microblock...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Clock Sched. Category</td>
<td>Carrier Schedule</td>
</tr>
<tr>
<td></td>
<td>Carrier Schedule with TLO and Override Status</td>
</tr>
<tr>
<td></td>
<td>BACnet Time Clock with TLO and Override Status</td>
</tr>
<tr>
<td>Modeled Schedule Sched. Category</td>
<td>BACnet Modeled Schedule</td>
</tr>
</tbody>
</table>

NOTES
- The Multi-state Time Clock Sched. Category tab is not used.
- Ignore any of the existing categories on these tabs except Occupancy.

3. Click .
4. Type the category name.

NOTES
- This name must be identical to the reference name that you give the category when you add it in the i-Vu®/Field Assistant interface.
- Do not use occupancy as the custom category name.
- The name can contain lowercase letters, numbers, hyphens, and underscores (no spaces); it cannot begin with a number.

5. Click OK twice.

The new category will now appear in a microblock's Category dropdown.

NOTE To copy all custom category information to another computer, click Export below the category tabs, then save the file. On the other computer, click Import, then select the exported file.
Simulating a control program

In simulation mode, you can specify microblock properties and define an operating environment to see how a control program will operate.

To simulate a control program:

1. Select Control Program > Simulate.
2. In the Simulator window, select Options > Setup.
3. Define the simulation conditions. See table below.
4. Do one of the following:
   - Click to run the simulation continuously until you click to stop it. Set the Time Increment fields (see table below) to define how fast the simulation will run.
   - Click to run the simulation one step at a time.
   - Click to run the simulation as fast as possible.
5. Click a microblock, then select its Simulation tab to enter values that will help you check the programming. See NOTES below.
6. Verify that the logic performs the desired sequence of operation.
7. Close the simulation window to return to the workspace.

<table>
<thead>
<tr>
<th>Field</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar</td>
<td>Enter the starting Time and Date for the simulation.</td>
</tr>
<tr>
<td>Communications</td>
<td>Check Communications Ok to simulate normal communication. Uncheck this field to simulate lost communication.</td>
</tr>
</tbody>
</table>
| Time Increment| The Step Every value determines how often the simulation recalculates values in real time. The One Step = value determines how much simulation time passes between each step. For example, to see 30 minutes of simulation in 1 second of real time, use the following settings:  
   - Step Every 00:01 (mm:ss)  
   - One Step = 30:00 (mm:ss)  
   TIP Set your One Step = shorter than the shortest delay in your control program to avoid stepping over the delay in the simulation. |

NOTES

- For simulation only, decimal values smaller than hundredths are rounded to the nearest hundredth. For example .025 is rounded to .03.
- The Simulator has the same options as the main Snap workspace for locating items in the control program. See:  
  To find a microblock or label (page 29)  
  To find identical labels (page 30)  
  To show a logical path (page 31)  
  To show a wire's source microblock (page 31)
• Hold the cursor over a wire or label to see its value.
Snap productivity tools

Use the following features to work efficiently.

To create and use symbols

You can reuse a sequence of programming by exporting it to a .logicsymbol file that you can import into other control programs.

You can add frequently-used symbols to your Favorites list and organize them for ease of use.

To export a symbol

1. Select the items in a control program that you want in the symbol.
2. Select Edit > Export Symbol.
3. Type a File Name. The application will automatically add the .logicsymbol file extension.
4. Check Selected Items Only.
5. Click Save.

To import a symbol

1. Open the control program you want to paste a symbol into.
2. Select Edit > Import Symbol.
3. Browse to the symbol, then double-click it.
4. Click in the workspace to place the symbol.

NOTE You can drag a .logicsymbol from Windows Explorer to the Snap workspace. Select multiple items to drag them simultaneously. Hold down Ctrl as you drag and drop the .logicsymbol into the workspace to have it open as a separate file.

To add symbols to your Favorites list

1. Select the items in a control program that you want in the symbol.
2. Right-click one of the items, then select Add to Favorites.
3. Type a Name and a Description.
4. Click Ok.
To put a Favorites item in a control program

1. Click Favorites.
2. Select the name of the symbol.
3. Click in the workspace to place the symbol.

To organize favorites

1. Select Favorites > Organize.
2. Use the buttons on the right to:
   - Add new favorite
   - Remove favorite
   - Edit favorite's name or description
   - Move up
   - Move down
   - Open selected favorite in main view for editing

To view or edit microblock common properties

The Microblock Common Properties Editor lets you view or edit common properties for the Carrier, I/O, Network, and BACnet microblocks in a control program.

1. To see the common properties of:
   - All Carrier, I/O, Network, and BACnet microblocks in the control program, click on the toolbar.
   - Selected microblocks, shift+click the microblocks, click then click Selected Microblocks.
2. Select the tab for the properties you want to see.
NOTES

- Select File > Export to write the data to a CSV (Comma Separated Values) text file so that you can edit the file in a spreadsheet program. Click File > Import to import the CSV file back into the Microblock Common Properties Editor.

⚠️ CAUTION Do not change any column header name or microblock reference name in the spreadsheet program.

- To undo changes made in the Editor, close the Editor, then use the Undo feature.
- See Microblock Reference Help for a description of each property.

To find a microblock, label, or text in the workspace

NOTE This feature will not search:
- Date, time, or duration fields
- Multi-State text fields

1 Select Edit > Find/Replace.
2 Enter the text you are looking for in the Find What field. Snap will search Property Editor text fields for this text.
3 Check Case Sensitive if you want to find items that exactly match the uppercase or lowercase text you typed in step 2.
4 Check the type of items you want to find in the Search box.
5  Click **Find**.
6  Select an item in the **Found Items** list. That item is highlighted in the workspace.
7  Click **Close**.

---

**To find and replace text in a microblock, label, or text entry field**

Follow the steps below to find and replace text in Property Editor text fields.

**NOTE** This feature will not search:
- Date, time, or duration fields
- Multi-State text fields

1  Select **Edit > Find/Replace**.
2  Enter the text you are looking for in the **Find What** field.
3  Check **Case Sensitive** if you want to find items that exactly match the uppercase or lowercase text you typed in step 2.
4  Check the type of items you want to find in the **Search** box.
5  Click **Find**.
6  In the **Found Items** list, check the item(s) whose text you want to replace. You can use the **Check All** or **Uncheck All** buttons if needed.
7  Type the new text in the **Replace With** field.
8  Click **Replace**.
9  Click **Close**.

---

**To find identical labels**

1  Right-click a label.
2  Select **Find Label Usages**.
3  Click an item in the list. That label is highlighted in the workspace.
4  Click **Close**.
To show a logical path

Right-click a wire, then select Highlight Connections.

If you leave the Highlight Connection box open while you highlight additional wires, each wire is highlighted with a different color. Click Change Color to select a different color for the highlight.

Click Clear Highlight to turn off the highlighting.

To show a wire's source microblock

1. Right-click a wire.
2. Select Go To Source.
You can create control programs in Snap that work with various types of wireless or ZS sensors. For each microblock that uses a sensor's value, you:

- Select an Rnet tag that defines what type of information the value is. If Snap does not have the Rnet tag you need, you can create custom Rnet tags (page 33).
- Define how the value should be displayed if using a ZS sensor. Snap lets you set the order for information to be displayed on a ZS sensor (page 32).

To set the order of information displayed on a ZS sensor

If the control program contains multiple microblocks whose values will appear on a ZS sensor screen, you can define the order in which the values will appear.

**EXAMPLES**

- If you assigned 3 microblocks to the Home screen, you can set the order that they will cycle through when no user is interacting with the sensor.
- If you assigned 3 microblocks to the Info screen, you can set the order that they will appear in when a user presses the sensor's button.

To set the order:

1. Select **Reorder > Sensor Display Order**.
2. Select the microblock(s) you want to move, then click ↑ or ↓.

**NOTES**

- Use Ctrl+click, Shift+click, or both to select multiple items.
- The first microblock in the list must be the first microblock that will appear on the Home screen.
- To highlight just the microblocks assigned to a particular screen or defined as Maintenance or Alarm, select an option in the **Highlight** list.

3. Optional: If you assigned multiple microblocks to the Home screen, the sensor will display the first microblock for 10 seconds by default. To shorten the time, select **3 seconds** at the bottom of the window.
4. Click **OK**.
To create custom Rnet tags

Rnet tags are descriptions and numbers that identify types of system values, and determine how a ZS sensor will display the value. For example:

- If a BACnet Binary Value Status microblock has the Rnet tag **Fan Status (100)**, the sensor will display a fan icon when the microblock is active.

- If a BACnet Multi-State Value Status microblock has the Rnet tag **Demand Level (502)**, the sensor will display the demand level along with the number 502 to identify the value.

The Snap application has pre-defined Rnet tags like those described above, but you can add custom tags if needed.

1. Select **Options > Preferences**.
2. On the **Rnet Tags** tab, select the tab (Binary, Analog, or Multi-state) for the type of microblock for which you are adding the tag.
3. Click **Add**.
4. Type a descriptive **Display Name** for the Rnet tag.
5. Optional: The **Rnet Tag Number** field is prefilled with the next available tag number for the type of tag you are adding. (Binary tags are in the 1100's, Analog tags are in the 1300's, and Multi-State tags are in the 1500's.) You can change this number if needed.
6. Click **OK** twice.

The new Rnet tag will appear in a microblock's **Rnet Tag** droplist.

⚠️ **CAUTION** If you create a control program with a custom Rnet tag and then open the program in another instance of the Snap application that has the same tag number defined for a different value, the Snap application will replace its tag name with the tag name from the control program.

**NOTES**

- To delete a custom Rnet tag, select it, and then click **Remove**.
- To copy all custom Rnet tags to another computer, click **Export**, then save the file. On the other computer, click **Import**, then select the exported file.
### Miscellaneous Snap menu commands and features

<table>
<thead>
<tr>
<th>Menu command</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit &gt; Third Party BACnet Addresses</strong></td>
<td>You can convert a control program into an integration program by setting Network I/O microblock addresses using discovered BACnet information from i-Vu®/Field Assistant.</td>
</tr>
<tr>
<td><strong>Control Program &gt; Bundled Resources</strong></td>
<td>i-Vu® Pro only: When making a control program for use in a non-English system, use this command to embed the translation files in the control program, omitting the need to maintain separate files. See “Setting up your system for non-English languages” in i-Vu® Pro Help.</td>
</tr>
<tr>
<td><strong>Control Program &gt; Unlock Control Program</strong></td>
<td>To edit a control program created in EquipmentBuilder, open the control program in Snap, then select this menu command.</td>
</tr>
<tr>
<td><strong>Options &gt; Preferences</strong></td>
<td>These apply to the Snap application, not just the current file.</td>
</tr>
</tbody>
</table>

**On this tab...**  **You can...**

| **General**                          | Set the metric option as the default for all future control programs. See To begin a control program (page 5).                                                                                                                                                                                                                     |
|                                      | Guarantee that all control program file names do not contain spaces.                                                                                                                                                                                                                                                                |
| **Alarm/Schedule Categories**        | Add custom alarm or schedule categories. See To use custom alarm and schedule categories (page 24).                                                                                                                                                                                                                               |
| **Rnet Tags**                        | Add custom Rnet tags. See To create custom Rnet tags (page 33).                                                                                                                                                                                                                                                                   |
|                                      | Export custom tags from one computer and import them on another.                                                                                                                                                                                                                                                                   |
| **Droplist Options**                 | Customize the following droplists in certain microblocks:                                                                                                                                                                                                                                                                      |
|                                      | • BACnet Engineering Units (Airflow, AO, AI)                                                                                                                                                                                                                                                                                     |
|                                      | • Output types (AO)                                                                                                                                                                                                                                                                                                              |
|                                      | • Actuator types (AO)                                                                                                                                                                                                                                                                                                            |
|                                      | • Input types (AI)                                                                                                                                                                                                                                                                                                               |
|                                      | • Sensor types (AI)                                                                                                                                                                                                                                                                                                              |

**Window**

Select another currently open file to view or edit.

**Help > Tip of the Day**

Uncheck **Show tips on startup** if you don't want to see the tips when you start the application.

**Help > Apply Update**

Use this command to install i-Vu®/Field Assistant service packs or patches, or to update all drivers, graphic libraries, or Help.

**Help > About**

Technical support may ask you for this version, license, or Java VM information.
Working with control programs for non-English systems

The following applies only to an i-Vu® Pro v6.5 system.

Creating control programs and translation files for a non-English system

To have the i-Vu®/Field Assistant interface display a control program’s user-defined text (such as microblock names and property text) in a non-English language, you must:

1. Create the control program using key terms instead of the text.
2. Create translation files of key terms and their language-specific equivalents.

In the i-Vu®/Field Assistant interface, the key term is replaced with its equivalent in the translation file for the current operator language. If an i-Vu®/Field Assistant Properties page or graphic shows `??key term??`, the key term is missing from the translation file.

**NOTE** To edit existing control programs or translation files, see Editing translation files, control programs, or graphics (page 38).

To enter a key term in the Snap application

In the Snap Property Editor, type `@` before each key term.

<table>
<thead>
<tr>
<th>Property Page Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Property Page Text</td>
</tr>
<tr>
<td>Property Page Text</td>
</tr>
</tbody>
</table>

**NOTES**

- Type only the key term in the Snap application. Expressions such as `$present_value$` are put in the translation file as part of the translated text. See EXAMPLES in “Translation files” below.
- Key terms can contain only alphanumeric characters and underscores (no spaces) and cannot start with a number.
**Translation files**

Translation files are used to translate key terms in control programs and graphics. A translation file contains key terms and their language-specific equivalents.

For a non-English system, you must create an English translation file and a non-English translation file* for each of the following:

- Each control program
- Key terms used in multiple control programs
- Key terms used in multiple graphics

**EXAMPLES**

<table>
<thead>
<tr>
<th>Translation files</th>
<th>Key term=Language-specific equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>English</td>
<td>This_value=This value is $present_value$&lt;br&gt;Zone_temp=Zone temperature</td>
</tr>
<tr>
<td>Spanish</td>
<td>This_value=Este valor es $present_value$&lt;br&gt;Zone_temp=Temperatura de zona</td>
</tr>
</tbody>
</table>

*If the i-Vu®/Field Assistant interface will display multiple non-English languages, create a translation file for each language.

**To create and implement a translation file**

Create your translation file in a text editor, such as Microsoft® Word, that supports the character encoding you need.

1. Type one key term and language equivalent per line, left justified, starting in column 1. Do not put spaces on either side of the equal sign.

2. Save the file using the appropriate file name and location in the table below.

<table>
<thead>
<tr>
<th>If key terms are used in...</th>
<th>the file name is...</th>
<th>File location</th>
</tr>
</thead>
<tbody>
<tr>
<td>A single control program</td>
<td>&lt;any_name&gt;._xx.native*</td>
<td>Any location</td>
</tr>
<tr>
<td>Multiple control programs</td>
<td>equipment_xx.native*</td>
<td>i-Vu_Tools\webroot&lt;system_name&gt;\resources</td>
</tr>
<tr>
<td>A single graphic</td>
<td>&lt;graphic_name&gt;._xx.native*</td>
<td>i-Vu_Tools\webroot&lt;system_name&gt;\graphics\vl5</td>
</tr>
<tr>
<td>Multiple graphics</td>
<td>translations_xx.native*</td>
<td>i-Vu_Tools\webroot&lt;system_name&gt;\resources</td>
</tr>
</tbody>
</table>

* xx = the language extension code. See “Extension codes and encoding” below.

If you are using:
- the English character set, save the file as Text only.
- a non-English character set, save the file as Encoded text. (See your application’s help for information on saving files as encoded text.) When prompted for the language and encoding, see “Extension codes and encoding” below.

3. Open the control program in the Snap application, then select **Control Program > Bundled Resources**.
4 Click , locate and select the translation file(s) for this control program, then click **Open**.

**NOTES**
- Do not add equipment_xx.native files that you created for multiple control programs.
- You can use **Ctrl+click** or **Shift+click** to select multiple files.

5 Save the control program. The translation files are embedded in the control program; the original files are no longer necessary.

### Extension codes and encoding

<table>
<thead>
<tr>
<th>Language</th>
<th>Extension codes</th>
<th>Encoding*</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brazilian Portuguese</td>
<td>_pt_BR</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>English</td>
<td>_en</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>Canadian French</td>
<td>_fr</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>French</td>
<td>_fr_FR</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>German</td>
<td>_de</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>Italian</td>
<td>_it</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>Japanese</td>
<td>_ja</td>
<td>EUC-JP</td>
</tr>
<tr>
<td>Korean</td>
<td>_ko</td>
<td>EUC-KR</td>
</tr>
<tr>
<td>Russian</td>
<td>_ru</td>
<td>KOI8_R</td>
</tr>
<tr>
<td>Spanish</td>
<td>_es</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>Swedish</td>
<td>_sv</td>
<td>ISO-8859-1</td>
</tr>
<tr>
<td>Simplified Chinese</td>
<td>_zh</td>
<td>GB2312</td>
</tr>
<tr>
<td>Traditional Chinese</td>
<td>_zh_TW</td>
<td>Big5</td>
</tr>
<tr>
<td>Thai</td>
<td>_th</td>
<td>TIS620</td>
</tr>
<tr>
<td>Vietnamese</td>
<td>_vi</td>
<td>Cp1258</td>
</tr>
</tbody>
</table>

* Encoding is used when you create the translation file.
Editing translation files, control programs, or graphics for a non-English system

If you add or edit a key term in a control program or graphic, be sure to make the same change in the translation file. See Creating control programs and translation files (page 35).

If you make changes after attaching a control program or graphic in SiteBuilder, do one of the following:

- If you changed text only in a control program or its translation file, right-click the control program on the Geographic tree, then select Rebuild Equipment Pages.
- If you changed logic in the control program, right-click the control program on the Geographic tree, then select Reload Control Program.
- If you changed a translation file located in <system_path>\webroot<system_name>\resources, right-click each applicable graphic on the Geographic tree, then select Rebuild Graphic Resources.

To edit a bundled resource

The Snap application bundles (embeds) the translation file(s) for a control program into the .equipment file. See steps 3 through 5 in To create and implement a translation file (page 36). To edit a bundled translation file:

1. Open the control program in the Snap application.
2. Select Control Program > Bundled Resources.
3. Select the file, then click to save it to your hard drive.
4. Edit the translation file.
5. In the Bundled Resources dialog box in the Snap application, click and select the edited file.
6. Click OK to overwrite the existing file.

Editing a control program in the Snap application

To edit a non-English control program:

1. Open the .equipment file in the Snap application, then make your edits.
2. Select Control Program > Bundled Resources.
3. Verify that the list shows all translation files specifically for the control program. Use the plus or minus button to add or delete translation files.
   
   **NOTE** This list shows the translation files in the i-Vu_Tools\webroot<system_name>\programs folder. This list should not include translation files for multiple control programs or graphics.

4. Click OK.
5. Save the control program. The translation files are bundled with the control program; the original files are no longer necessary.

**NOTE** If you need to change a translation file after you save the control program, see To edit a bundled resource (page 38).
**Copying translation files to another system**

To copy most translation files from one system to another, you copy the files in the source system and paste them into the same folders in the destination system.

However, if your source system and destination system have translation files with the same name, copying and pasting would overwrite the file(s) in the destination system. In this case:

1. Open the source system’s translation file in a text editor, then copy the key terms and translations.
2. Open the destination system’s translation file in a text editor, then paste into it the key terms that you copied. Remove any duplicate key terms.
Creating Snap programs to use in i-Vu® Open Controllers

Snap allows you to create programs to control points that reside in a different control program in the same controllers or in a different controllers. Use network microblocks to write to or read from points/properties in the equipment's control programs.

You can create a control program in Snap for the following i-Vu® Open controllers:

- AppController (OPN-APP)
- Carrier® ChillerVu™ (OPN-PSM-MPCXPE and OPN-PSM-SIM)
- i-Vu® Open Link (OPN-OL)
- MPC Open XP (OPN-MPCXP)
- UC Open (OPN-UC)
- UC Open XP (OPN-UCXP)
- UPC Open (OPN-UPC)

**NOTE** See i-Vu®/Field Assistant Help for instructions on downloading control programs into the controllers.

You must:

- Know the BACnet address of the point/property
- Ensure the point/property is **Network Visible**
- Have **Installer** role to download control programs or view **BACnet Points** tab

Create a control program

**Step 1: Identify Network points and network visibility**

1. Start the i-Vu®/Field Assistant application.
2. Select the controller/equipment from which points will be read from or written to.
3. Select **Report** tab > **Equipment** > **Point List**.
4. Click **Option** tab, Check the following boxes to get a report listing:
   - **Type**
   - **Device ID**
   - **BACnet points**
5. Click **Run** to generate a report listing of all available BACnet points in the controller.
6. Identify the desired points and required information to connect to them.
7. On the **Properties** page > **BACnet Objects** tab, locate the points that need to be configured as **Network Visible**. Select the **Network Visible** checkbox for all required points/properties.
8. Click **OK**.
NOTE Network Visible points are also accessible to third-party devices.

Step 2: Prepare the control program
1. Start Snap.
2. Place microblocks and connect wires.
3. Enter desired Display Name and Reference Name in the Property Editor for each microblock.

Step 3: Simulate program
In simulation mode, you specify microblock properties and define an operating environment to see how a control program will operate.

To simulate a control program:
1. Select Control Program > Simulate.
2. In the Simulator window, select Options > Setup.
3. Define the simulation conditions.
4. Do one of the following:
   - Click to run the simulation continuously until you click to stop it. Set the Time Increment fields (see table below) to define how fast the simulation will run.
   - Click to run the simulation one step at a time.
   - Click to run the simulation as fast as possible.
5. Click a microblock and then select Simulation to enter values to check in the program. NOTE See Simulating a control program (page 25) for more information.
6. Verify that the logic performs the desired sequence of operation.
7. Close the simulation window to return to the workspace.

Step 4: Save program
Click or File > Save to save your control program.

Step 5: Add a new control program to a programmable controller
1. Select the router in the navigation tree.
2. Select Devices > Manage tab.
3. Select the controller in the list on the page.
4. Click Add Control Program. A dialog window appears.
5 Enter a name for your control program in **Display Name** and select your controller in the **Controller** drop-down list.

**NOTE** If you already have the maximum number of control programs for a controller, it will not appear in the list.

6 If you have already added the desired control program to the i-Vu®/Field Assistant application, click the arrow next to **Control Program** and select your program.

7 If you have not previously added the control program, click **Add New** under **Control Programs**. A second dialog window appears.

8 Browse to the .equipment file that you created in Snap and click **Continue**.

9 To upload a graphic, click **Add New** under **Views** and browse to your .view file.

10 Click **Continue**. When message appears **File added successfully**, click **Close**.

11 Click **Close** again.

12 Right-click on the programmable controller in the controller list and select **Check Status** from the list. The status of the controller should say **File Mismatch**.

13 Click the **Download All Content** button.

---

**Step 6: Configure Network microblock address**

1 Select the programmable controller in the navigation tree.

2 Select **Properties** page > **Network Points** tab and click the point/property to open the microblock popup.

3 On the **Details** tab, select the point/property in the navigation tree.

4 Click **Apply**.
Example: Limit heating stages

Use the following steps to create a control program to write to the Number of Heating Stages, based on the Outdoor Air Temperature in an RTU Open controller and download it into a UC Open XP.

Step 1: Prepare the control program

1. Open Snap.
2. Use the following microblocks to create the program.

<table>
<thead>
<tr>
<th>Use...</th>
<th>To...</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANI</td>
<td>Read the Outdoor Air Temperature from the RTU Open.</td>
</tr>
<tr>
<td>ANI</td>
<td>Read the Number of Heating Stages actual value on the RTU Open and display the status on the Properties page &gt; Equipment tab of the UC Open XP.</td>
</tr>
<tr>
<td>ANO2</td>
<td>Write the max number of stages to the RTU Open, using Enable to restrict heating if OAT is above 30 degrees.</td>
</tr>
</tbody>
</table>

Step 2: Make points network visible and obtain addresses

1. Start i-Vu®/Field Assistant.
2. Select the RTU Open in the navigation tree.
4. Locate and click on **Outdoor Air Temperature**.

5. Select the **Details** tab on the microblock popup to ensure the point is **Network Visible**.

6. Repeat step 2 for the **Number of Heating Stages**.

**Step 3: Simulate program**

See *Simulating a control program* (page 25) for details.

**Step 4: Save program**

Click 🖼 or **File > Save** to save your control program.

**Step 5: Download program in i-Vu®/Field Assistant**

1. You may use either of the following methods to open the **Control Programs** dialog window in i-Vu®/Field Assistant:

   **Method 1**:
   - From the **Devices** page
     1. Select the router in the navigation tree and go to the **Devices** page.
     2. Select the UC Open XP in the list on the page.
     3. Click 📚. A dialog window appears.
     4. Enter a name for your control program in **Display Name** and select your controller in the **Controller** dropdown list.
     
     **NOTE** If you already have the maximum number of control programs for a controller, it will not appear in the list.
   
   5. If you have already added the desired control program to the i-Vu®/Field Assistant application, click the arrow next to **Control Program** and select your program.
   
   6. If you have not previously added the control program, click **Add New** under **Control Programs**. A second dialog window appears.
   
   7. Browse to the .equipment file that you created in Snap and click **Continue**.
   
   8. When message appears **File added successfully**, click **Close**.
   
   9. Click **Close** again.
10. Right-click on the programmable controller in the controller list and select **Check Status** from the list. The status of the controller should say **File Mismatch**.

11. Click the **Download All Content** button.

**Method 2**: From the navigation tree

1. Right-click the UC Open XP in the navigation tree and select **Configure** in the drop-down menu. A dialog window appears.
2. Click **Add New** under **Control Programs**. A new dialog window appears.
3. Browse to your edited control program and click **Continue**. When message appears **File added successfully**, click **Close**.
4. Click **Close** again.
5. Select the router in the navigation tree and go to the **Devices** page.
6. Right-click on the programmable controller in the controller list and select **Check Status** from the list. The status of the controller should say **File Mismatch**.
7. Click the **Download All Content** button.

**Step 6: Configure Network microblock address**

1. Select the UC Open XP in the navigation tree.
2. Select **Properties page > Network Points** tab and click the point/property to open the microblock popup.
3. On the **Details** tab, select the point/property in the navigation tree.
4. Click **Apply**.
5. Repeat these steps for all network microblock addresses.

**UPC Open control program**

When creating a Snap application for the UPC Open, you must identify and map the points from the CCN controller that you want to be accessible to i-Vu®/Field Assistant and/or a BAS system. Use the following guidelines to create a control program for the UPC Open.

**Step 1: Identify data**

- Identify the data to be mapped by the UPC Open.
- Identify the CCN table and point name for the desired data.
- Determine data that you need to be accessible over the network.
- Determine data that you need to trend.
Step 2: Standard communication logic

- Open Snap.
- Use the following microblocks to create the communication section of the control program.

Use... | To...
---|---
CCN Controller | Define the **Element** for the CCN equipment that the UPC Open interfaces with.
BACnet Binary Value Status | Display the status of communication between the BMS and CCN equipment.
Not | Invert the communication status signal from the CCN controller.
Delay On Make | Wait for a specified time before sending a signal to the alarm for lost communication.
Digital Trend | Record communication status for trend purposes.
BACnet Alarm | Display an alarm when communication is lost between the BMS and CCN equipment.

**NOTE** Go to the Driver page in i-Vu®/Field Assistant to finish configuring the control program once it is downloaded to the controller. See "Configuring the UPC Open's properties" in the **UPC Open Installation and Startup Guide**.

Step 3: Mapping the desired points

- Use the following guidelines to determine the type of Carrier microblocks you require:

**Guidelines: Carrier Value microblocks vs Carrier Point microblocks**

<table>
<thead>
<tr>
<th></th>
<th>Carrier Analog/Binary Value</th>
<th>Carrier Analog/Binary Point</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allows for trending</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Allows for alarming</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Network Visible</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Contains a BACnet Object</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Can be used in a graphic to</td>
<td></td>
<td></td>
</tr>
<tr>
<td>force a variable</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
• Place the appropriate microblock on the workspace.

NOTE These microblocks do not require output connections, as i-Vu®/Field Assistant automatically links to the CCN path and displays the status on the Properties page.

Setting the path
Use the information below to format a valid path for the particular microblock you are using to read from or write to the CCN point. Select Editable to edit path in i-Vu®/Field Assistant.

Path format: CCN://device specifier/table specifier/point name:instance#

NOTE Each item in the path is limited to 8 alpha-numeric characters.

Device specifier
LINK is always the Device Specifier CCN://LINK/…

Table specifier - Use one of the following:
Definition table name: Name of table containing the desired point CCN://LINK/MYTABLE:MYDATA1

Data table name CCN://LINK/MYDATA1

Point name:instance#
Field name CCN://LINK/…/FLDNAME

Optional
Instance# is the instance number of the point name. Use this item in the path if more than one field in a table share the same point name.
EXAMPLES

Use the following syntax to read the CCN Chiller Start/Stop point shown below:

CCN://LINK/GENUNIT/CHIL_S_S

### GENERAL PARAMETERS

<table>
<thead>
<tr>
<th>Description</th>
<th>Value</th>
<th>Units</th>
<th>Status</th>
<th>Force</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Type</td>
<td>Local</td>
<td></td>
<td></td>
<td></td>
<td>ch_type</td>
</tr>
<tr>
<td>Run Status</td>
<td>Tripout</td>
<td></td>
<td></td>
<td></td>
<td>STATUS</td>
</tr>
<tr>
<td>CCN Chiller Start/Stop</td>
<td>Disable</td>
<td></td>
<td></td>
<td></td>
<td>CHIL_S_S—Point name</td>
</tr>
<tr>
<td>Chiller Occupied?</td>
<td>Yes</td>
<td></td>
<td></td>
<td></td>
<td>CHIL_OCC</td>
</tr>
</tbody>
</table>

Points with the same point name must specify the instance #. Use the following syntax:

- Current Alarm 1  CCN://LINK/GENUNIT/alarm:1
- Current Alarm 2  CCN://LINK/GENUNIT/alarm:2
- Current Alarm 3  CCN://LINK/GENUNIT/alarm:3

### CHILLER: Generic Chiller - 0, 131 :: GENUNIT

<table>
<thead>
<tr>
<th>Description</th>
<th>Value</th>
<th>Units</th>
<th>Status</th>
<th>Force</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm State</td>
<td>Shutdown</td>
<td></td>
<td></td>
<td></td>
<td>ALM</td>
</tr>
<tr>
<td>Current Alarm 1</td>
<td>th-01</td>
<td></td>
<td></td>
<td></td>
<td>alarm</td>
</tr>
<tr>
<td>Current Alarm 2</td>
<td>th-02</td>
<td></td>
<td></td>
<td></td>
<td>alarm</td>
</tr>
<tr>
<td>Current Alarm 3</td>
<td>th-10</td>
<td></td>
<td></td>
<td></td>
<td>alarm</td>
</tr>
<tr>
<td>Current Alarm 4</td>
<td>Pr-01</td>
<td></td>
<td></td>
<td></td>
<td>alarm</td>
</tr>
<tr>
<td>Current Alarm 5</td>
<td>Pr-02</td>
<td></td>
<td></td>
<td></td>
<td>alarm</td>
</tr>
<tr>
<td>Percent Total Capacity</td>
<td>0  %</td>
<td></td>
<td></td>
<td></td>
<td>CAP_T</td>
</tr>
<tr>
<td>Active Demand Limit Val</td>
<td>100 %</td>
<td></td>
<td></td>
<td></td>
<td>DEM_LIM</td>
</tr>
</tbody>
</table>
Change editable addresses/paths in i-Vu®/Field Assistant on the:

- The Details tab of a Point Properties dialog box.
- The Address column on the Properties > Network Points page.

**Step 4: Occupancy**

- To support BACnet scheduling in the CCN controller, through the UPC Open, you must add a Carrier Schedule microblock from the Carrier library.

![Carrier Schedule Microblock](occ)

- Edit the **Write to global schedule number** and enter the number of the occupancy table (OCCPC##) of the CCN Controller that is to be written to.

**Step 5: Linkage**

If you require **Airside Linkage**, you must create a separate control program in EquipmentBuilder and download it to the UPC Open controller. No setup is required for the Linkage application in UPC Open using i-Vu®/Field Assistant.

**NOTE** This is only applicable if the UPC Open interfaces to an i-Vu®/Field Assistant system where the CCN controller is the air source for the i-Vu®/Field Assistant zoning system.
# Document revision history

Important changes to this document are listed below. Minor changes such as typographical or formatting errors are not listed.

<table>
<thead>
<tr>
<th>Date</th>
<th>Topic</th>
<th>Change description</th>
<th>Code*</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>No changes yet</td>
<td></td>
</tr>
</tbody>
</table>

* For internal use only